在线检测未来函数

通达信散户黑马指标公式

来源:Internet,编辑:股旁网,2010-08-12

LC:=REF(CLOSE,1);
RSI5:=((SMA(MAX((CLOSE - LC),0),5,1) / SMA(ABS((CLOSE - LC)),5,1)) * 100);
TR1:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),10);
HD:=(HIGH - REF(HIGH,1));
LD:=(REF(LOW,1) - LOW);
DMP:=SUM(IF(((HD > 0) AND (HD > LD)),HD,0),10);
DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),10);
PDI:=((DMP * 100) / TR1);
MDI:=((DMM * 100) / TR1);
ADX:=MA(((ABS((MDI - PDI)) / (MDI + PDI)) * 100),5);
AV:=(RSI5 + ADX);
DXR:=(((ADX + REF(ADX,5)) / 2) + RSI5);
0,COLORFF00FF;
WR10:=((100 * (HHV(HIGH,10) - CLOSE)) / (HHV(HIGH,10) - LLV(LOW,10)));
NEWVOL:=(RSI5 - WR10);
阶段底部:=(AV + NEWVOL);
STICKLINE((阶段底部 < 0),0,-10,0.8,1),LINETHICK6,COLORYELLOW;
趋势线:=LLV(阶段底部,1),COLORWHITE,LINETHICK0;
STICKLINE(CROSS(阶段底部,0),0,-10,0.8,1),LINETHICK6,COLORRED;
STICKLINE((趋势线 >230 ),100,90,0.3,1),LINETHICK6,COLORGREEN;
LOWV:=LLV(LOW,9);
HIGHV:=HHV(HIGH,9);
{股旁网-股票公式网站 www.gupang.com}
RSV:=EMA((CLOSE-LOWV)/(HIGHV-LOWV)*100,3);
K:EMA(RSV,3);
D:MA(K,3);
STICKLINE(K>D , K,D ,2.5,0),COLORRED,LINETHICK2;
STICKLINE(D>K,K,D,2.5,0),COLORGREEN,LINETHICK2;
逃顶线:90,COLORGREEN;
中轴线: 50,COLORRED;
抄底线:10,COLORGREEN;
DRAWICON(CROSS(K,D),12,1)COLORRED;
DRAWICON(CROSS(D,K),88,2)COLORGREEN;
警戒:阶段底部 < 0,LINETHICK0,COLORYELLOW;
出击:CROSS(阶段底部,0),LINETHICK0,COLORRED;
AA1:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*200-100;
AA2:=SMA(AA1,3,1);
AA3:=SMA(AA2,3,1);
AA4:=(3*AA2-2*AA3)/5+50;
AA5:=DRAWLINE(AA4<REF(AA4,1),AA4,AA4>REF(AA4,1),AA4,0);
AA6:=AA4>REF(AA4,1);
AA7:=DRAWLINE(AA6,AA4,AA4<REF(AA4,1),AA4,0);
AA8:=(EMA(CLOSE,12) - EMA(CLOSE,26));
AA9:=EMA(AA8,9);
AA0:=HHV(MAX(AA2,MAX(AA3,AA4)),250);
BB1:=HHV(MAX(AA8,AA9),250);
BB2:=INTPART(AA0/BB1)/2;
BB3:=BB2*AA8+50;
BB4:=BB2*AA9+50;
BB5:=1.5*(BB3-BB4)>REF(1.5*(BB3-BB4),1);
STICKLINE(BB5,0,AA5,0,-1),COLOR77FFFF;
STICKLINE(AA4<REF(AA4,1),0,AA5,0,1),COLORFF00FF;
STICKLINE(AA6,0,AA7,0,1),COLOR00FF00;
STICKLINE(CLOSE>0,4,-1,5,0),COLORBBBBBB;
MAC:AA5,COLOR0000FF,LINETHICK5;

通达信散户黑马指标公式

 

相关文章