在线检测未来函数

通达信苍狼MACD指标公式

来源:Internet,编辑:股旁网,2010-08-25

N1:=3; N2:=10;N3:=10;N4:=20;M:=9;
短波:(EMA(C,N1)-EMA(C,N2))*1000,LINETHICK0,COLORRED;
均线:EMA(短波,M),LINETHICK0,COLORCYAN;
MACD:=2*(短波-短均线);
{中波}
中波:(EMA(C,N3)-EMA(C,N4))*1000,COLORYELLOW;
中均线:EMA(中波,M),COLORBLUE;
MACD2:2*(中波-中均线),LINETHICK1;
STICKLINE(MACD2>=0,MACD2,0,2,1),COLORMAGENTA;
STICKLINE(MACD2<0,MACD2,0,2,1),COLORWHITE;
STICKLINE(中波>=中均线,中波,中均线,6,0),COLORYELLOW;
STICKLINE(中波<中均线,中波,中均线,6,0),COLORBLUE;
短均线,LINETHICK2,COLORCYAN;
短波,COLORGREEN,LINETHICK2;
IF(短波>=短均线,短波,DRAWNULL),COLORRED,LINETHICK2;
{股旁网-股票公式网站 www.guPang.com}
EE:=CROSS(中波,中均线) AND MACD2>REF(MACD2,1) AND 短波>=REF(短波,1) AND 中均线>=REF(中均线,1);
出来:=FILTER(EE,10);
DRAWICON(出来,中均线,1);

通达信苍狼MACD指标公式

 

相关文章