在线检测未来函数

通达信长短集合指标公式

来源:Internet,编辑:股旁网,2010-08-26

Y:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA(SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1),3,1);
趋势:=EMA(Y,3)-10;
R7:=LLV(L,30); R8:=HHV(H,30);
E:=EMA((C-R7)/(R8-R7)*4,4)*25;
STICKLINE(E>90,110,115,10,2),COLOR00FF00;
AR:=SMA(ABS(L-REF(L,1)),3,1)/SMA(MAX(L-REF(L,1),0),3,1)*100;
RV:=HHV(AR,30)*8;
P:=EMA(IF(L<=R7 AND 趋势<40,(AR+RV),0),3)/618;
{深 青色立柱}
STICKLINE(P>0,0,P,2.5,0),COLORCC0000;
STICKLINE(P>0,0,P,1.5,0),COLORFF4400;
STICKLINE(P>0,0,P,0.5,0),COLORFF8800;
STICKLINE(P>0,0,P,0,0),COLORFFCC00;
{股旁网-股票公式网站 www.gupAng.com}
Q:=4*SMA((C-LLV(L,5))/(HHV(H,5)-LLV(L,5))*100,5,1)-3*SMA(SMA((C-LLV(L,5))/(HHV(H,5)-LLV(L,5))*100,5,1),3.2,1);
{短线}
STICKLINE(CROSS(Q,8),90,110,0,0),COLORWHITE;
{红色立柱}
STICKLINE(CROSS(Q,8),90,55,2.0,0),COLOR000088;
STICKLINE(CROSS(Q,8),90,55,1.1,0),COLOR0000AA;
STICKLINE(CROSS(Q,8),90,55,0.5,0),COLOR0000CC;
STICKLINE(CROSS(Q,8),90,55,0,0),COLOR0000EE;
{黄色立柱}
STICKLINE(CROSS(Q,8),25,55,3,0),COLOR338888;
STICKLINE(CROSS(Q,8),25,55,2,0),COLOR33AAAA;
STICKLINE(CROSS(Q,8),25,55,1,0),COLOR33CCCC;
STICKLINE(CROSS(Q,8),25,55,0.1,0),COLOR33EEEE;
{绿色立柱}
STICKLINE(CROSS(Q,8),25,0,4,0),COLOR008800;
STICKLINE(CROSS(Q,8),25,0,3,0),COLOR00AA00;
STICKLINE(CROSS(Q,8),25,0,2,0),COLOR00CC00;
STICKLINE(CROSS(Q,8),25,0,1,0),COLOR00FF00;
W:=EMA(100*(C-LLV(L,34))/(HHV(H,34)-LLV(L,34)),3)/4;
{黄色立柱}
STICKLINE((W>23.16),110,70,2.3,0 ),COLOR009999;
STICKLINE((W>23.16),110,70,1.5,0 ),COLOR00BBBB;
STICKLINE((W>23.16),110,70,0.8,0 ),COLOR00DDDD;
STICKLINE((W>23.16),110,70,0.1,0),COLOR00FFFF;
{粉红立柱}
STICKLINE((W>23.16),70,35,1.5,0 ),COLORAA00AA;
STICKLINE((W>23.16),70,35,0.9,0 ),COLORDD00DD;
STICKLINE((W>23.16),70,35,0.1,0 ),COLORFF00FF;
STICKLINE((W>23.16),0,35,0,0 ),COLOR888888;
VAR1:=LLV(L,5); VAR2:=HHV(H,5);
买:EMA((C-VAR1)/(VAR2-VAR1)*100,4),COLORWHITE;
卖:EMA(0.667*REF(买,1)+0.333*买,2),COLORMAGENTA;
VAR3:=(2*C+H+L)/4; VAR4:=LLV(L,34); VARA:=HHV(H,34);
方:EMA((VAR3-VAR4)/(VARA-VAR4)*150,13),COLORRED;
向:EMA(0.667*REF(方,1)+0.333*方,2),COLORGREEN;
DRAWICON(CROSS(78.89,7*SMA((C-LLV(L,27))/(HHV(H,27)-LLV(L,27))*30,4,1)-3*SMA(SMA((C-LLV(LOW,27))/(HHV(H,27)-LLV(LOW,27))*30,4,1),3,1)-SMA(SMA(SMA((C-LLV(L,27))/(HHV(H,27)-LLV(L,27))*30,4,1),3,1),2,1))AND 买>35,方,15);
VARA5:=IF(( (SMA(SMA(((C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100),3,1),3,1)+100)-(SMA(((HHV(H,9)-C)/(HHV(H,9)-LLV(LOW,9))*100- 70),9,1)+100))>60, ( (SMA(SMA(((C-LLV(L,9))/(HHV(H,9)- LLV(L,9))*100),3,1),3,1)+100)-(SMA(((HHV(H,9)-C)/(HHV(H,9)-LLV(LOW,9))*100- 70),9,1)+100))-60,0);
波:VARA5*0.1819,COLORRED;
参与:MA(波,3),COLOR196829;
平衡:50,COLORGRAY,POINTDOT;
0,COLORWHITE,LINETHICK4,POINTDOT;

通达信长短集合指标公式

 

相关文章