在线检测未来函数

通达信庄家散户指标公式

来源:Internet,编辑:股旁网,2010-08-31

VAR2:=REF(LOW,1);
VAR3:=SMA(ABS(LOW-VAR2),13,1)/SMA(MAX(LOW-VAR2,0),13,1)*100;
VAR4:=EMA(IF(CLOSE*1.2,VAR3*13,VAR3/13),13);
VAR5:=LLV(LOW,34);
VAR6:=HHV(VAR4,34);
VAR7:=IF(LLV(LOW,55),1,0);
VAR8:=EMA(IF(LOW<=VAR5,(VAR4+VAR6*2)/2,0),3)/618*VAR7;
VAR9:=EMA(CLOSE,5);
VAR10:=(CLOSE-MA(CLOSE,34))/MA(CLOSE,34)*(-10);
VAR11:=EMA(IF(LOW<=VAR5,(VAR4+VAR6*2)/2,0),3)/618*VAR7*(-1);
VAR12:=EMA(CLOSE,5)*(-1);
备钱:IF(VAR8>REF(VAR8,1),0,VAR8),COLOR0FFFFF,NODRAW;
界:0,COLORFFFFFF;
XL1:=MA(LOW,2)*0.96;
XL2:=MA(LOW,26)*0.85;
XL3:=REF(XL1,1)<XL2 AND REF(XL1,1)<XL1 AND REF(XL1,1)<REF(XL1,2);
启动:IF(XL3,0,VAR8*3),COLORRED,NODRAW;
DRAWBAND(启动,RGB(180,80,200),0,DRAWNULL);
STICKLINE(XL3,0,VAR8*3,4,0),COLORRED;
STICKLINE(VAR8>REF(VAR8,1),0,VAR8,2,0),COLOR10FFFF;
STICKLINE(VAR11>REF(VAR11,1),0,VAR11,4,1),COLORFFF810;
DRAWICON(VAR11>REF(VAR11,1) AND CROSS(VAR11,VAR12),VAR11,11);
40,POINTDOT;
VA:=(C+2*H+L)/4;
VB:=LLV(L,8);
VC:=HHV(H,8);
VD:=EMA(((VA-VB)/(VC-VB)-VC/VB)*81,5)*-1;
红线上穿买:REVERSE(VD)+100,COLORRED;
红线下穿卖:EMA(红线上穿买,3),COLORFFFF00;
DRAWBAND(红线上穿买,RGB(150,030,030),红线下穿卖,RGB(20,150,20));
IF(红线上穿买>=红线下穿卖,红线上穿买,DRAWNULL),COLORLIMAGENTA,LINETHICK2;
IF(红线上穿买<红线下穿卖,红线上穿买,DRAWNULL),COLORGREEN,LINETHICK2;
散户:= EMA(((2*CLOSE+HIGH+LOW)/4-LLV(LOW,5))/(HHV(HIGH,4)-LLV(LOW,5))*100,4);
庄家:= EMA(0.667*REF(散户,1)+0.333*散户,2);
DRAWICON(CROSS(散户,庄家) AND 散户<30,红线上穿买*0.98,1);
DRAWICON(CROSS(庄家,散户) AND 散户>70,红线上穿买*1.02,2);
极品底:IF((MA(C,5)-C)/C>0.04 AND (MA(C,10)-MA(C,5))/MA(C,5)>0.04,23,0),COLORFF00FF,NODRAW;
DRAWICON((MA(C,5)-C)/C>0.04 AND (MA(C,10)-MA(C,5))/MA(C,5)>0.04,-3,25);
RSV:=(((CLOSE - LLV(LOW,9)) / (HHV(HIGH,9) - LLV(LOW,9))) * 100);
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
X:=LLV(J,2)=LLV(J,8);
DRAWTEXT(CROSS(J,REF(J+0.01,1)) AND X AND J<19,红线上穿买*0.9,'短'),COLORLIRED;
DRAWICON(CROSS(J,REF(J+0.01,1)) AND X AND J<16,红线上穿买,7);
QVAR1A:=((HHV(HIGH,21)-CLOSE)/(HHV(HIGH,21)-LLV(LOW,21)))*(100)-10;
QVAR1B:=((CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21)))*(100);
QVAR1C:=SMA(QVAR1B,13,8);
QVAR1D:=SMA(QVAR1A,21,8);
机会来临:SMA(QVAR1C,13,1),COLORCCCC00,LINETHICK2;
{股旁网-股票公式网站 www.gUpang.com}
STICKLINE(机会来临>90,90,机会来临,2,0),COLORCYAN;
IF(机会来临>=REF(机会来临,1),机会来临,DRAWNULL),COLORCC33CC,LINETHICK2;
中线:EMA(机会来临,55),COLOR9933FF,LINETHICK2;
IF(中线<REF(中线,1),中线,DRAWNULL),COLOR66FF66,LINETHICK2;
AAS:=FILTER((COUNT((机会来临-QVAR1D<(-65)),3)=3),34);
波段买点:IF(AAS,15,0),COLORFFFFFF,NODRAW;
DRAWTEXT(AAS,32,'波段买'),COLORFFFFFF;
STICKLINE(AAS,0,31,0.3,0),COLORMAGENTA;
DRAWICON(CROSS(机会来临,QVAR1D),机会来临,23);
{DDX预警}
JJ:=(HIGH+LOW+CLOSE)/3;QJ0:=VOL/IF(HIGH=LOW,4,HIGH-LOW);
QJ1:=IF(CAPITAL=0,QJ0*(JJ-MIN(CLOSE,OPEN)),QJ0*IF(HIGH=LOW,1,(MIN(OPEN,CLOSE)-LOW)));
QJ2:=IF(CAPITAL=0,QJ0*(MIN(OPEN,CLOSE)-LOW),QJ0*IF(HIGH=LOW,1,(JJ-MIN(CLOSE,OPEN))));
QJ3:=IF(CAPITAL=0,QJ0*(HIGH-MAX(OPEN,CLOSE)),QJ0*IF(HIGH=LOW,1,(HIGH-MAX(OPEN,CLOSE))));
QJ4:=IF(CAPITAL=0,QJ0*(MAX(CLOSE,OPEN)-JJ),QJ0*IF(HIGH=LOW,1,(MAX(CLOSE,OPEN)-JJ)));
DDX:=((QJ1+QJ2)-(QJ3+QJ4))/IF(CAPITAL=0,1000000,10000);
DX:=MA(DDX,5)*20;
DDX1:=SMA(DX,3,1);
DDX2:=SMA(DDX1,3,1);
DDX3:=EMA(DDX2,5);
预警:=DDX>0 AND MA(V,5)>MA(MA(V,5),5) AND CROSS(DDX1,DDX2);
STICKLINE(预警,40,50,1,0),COLORLIRED;
{密码1号}
GJTJ1:=100*(C-LLV(L,5))/(HHV(C,5)-LLV(L,5));
GJTJ2:=100*(C-LLV(L,10))/(HHV(C,10)-LLV(L,10));
GJTJ3:=100*(C-LLV(L,20))/(HHV(C,20)-LLV(L,20));
GJTJ4:=100*(C-LLV(L,30))/(HHV(C,30)-LLV(L,30));
A:=BARSLAST(CROSS(30,GJTJ1))<2 AND BARSLAST(CROSS(GJTJ1,50))<2;
B:=BARSLAST(CROSS(GJTJ4,GJTJ1))<2 AND GJTJ1>GJTJ4;
STICKLINE(A AND B ,40,47,2,0),COLORRED;
{横盘突破}
O1:=(SUM(EMA((CLOSE+LOW)/2,1)/3,3));
CP1:=HHV(O1,20);
CP2:=HHV(O1,1);
AV:=CROSS(CP2,CP1);
STICKLINE(AV,40,45,4,0),COLORLIMAGENTA;

通达信庄家散户指标公式

 

相关文章