在线检测未来函数

通达信轻松短线指标公式

来源:Internet,编辑:股旁网,2010-09-21

N:=65;
MA5:=MA(CLOSE,5);
MA21:=MA(CLOSE,21);
MA65:=MA(CLOSE,N);
多头:=COUNT(MA21>MA65,10)=10;
GX:=MAX(MA5,MAX(MA21,MA65));
DX:=MIN(MA5,MIN(MA21,MA65));
粘合:=ABS(GX/DX-1)*100<=15;
多头粘合:IF(多头 AND 粘合,1,0),COLORFF00FF,POINTDOT,NODRAW;
DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26);
{股旁网-股票公式网站 www.guPang.com}
DEA:=EMA(DIFF,9);
MACD:=2*(DIFF-DEA);
庄股:COUNT(MACD<0,10)=10,COLORFFFF00,POINTDOT,NODRAW;
目标:IF(多头 AND 粘合 AND 庄股,5,0),COLORFFFFFF,LINETHICK2;
跟踪:=IF(目标,BARSLAST(CROSS(目标,0))+1,0),COLOR00FF00,POINTDOT,LINETHICK2;
出击:IF(CROSS(0.1,目标) AND CROSS(MACD,0),8,0),COLOR00FFFF,LINETHICK2;
MJSJ:=BARSLAST(出击>0);
涨幅:IF(MJSJ<=120,(C/REF(C,MJSJ)-1)*100,0),COLOR0000FF,CIRCLEDOT;
日涨:=IF(MJSJ<=120,涨幅/MJSJ,0),COLORFFFFFF,POINTDOT,NODRAW;
TPX:=MIN(MA65*1.15,MA21*1.13);
突破:IF(CROSS(C,TPX) AND 粘合 AND MA65>REF(MA65,1),10,0),COLOR0000FF,LINETHICK2;
{以下设置副图显示方式}
STICKLINE(多头粘合,0,1,3,0),COLORFF00FF;
STICKLINE(庄股,0,MACD*10,3,0),COLORFFFF00;
DRAWTEXT(出击>0,8,'★买'),COLOR00FFFF;
STICKLINE(CROSS(涨幅,20) AND COUNT(CROSS(涨幅,20),MJSJ)=1,-5,10,0,0),COLOR0000FF;

通达信轻松短线指标公式

 

相关文章