在线检测未来函数

通达信虎拓主图指标公式

来源:Internet,编辑:股旁网,2010-09-26

MA5:MA(C,5),COLOR000099;
MA10:MA(C,10),COLOR006600;
MA20:MA(C,20),COLOR005555;
{
DRAWTEXT(30,0,BKNAME ),COLORDDDDDD;
DRAWTEXT(30,15,'流通盘:'+CAPITAL/100+'万股,利润增长:'+FINANCE2(10)+'%。每股收益:'+FINANCE2(3)+'元。' ),COLOR00DDDD;
DRAWTEXT(30,30,'红白柱买入,蓝绿柱卖出。' ),COLORFFDD00;
}
STICKLINE(C>=REF(C,1),O,C,3,1),COLOR000000;
STICKLINE(C<REF(C,1),O,C,3,1),COLOR000000;
{
A1:=EMA(CLOSE,5)>EMA(CLOSE,6) AND EMA(CLOSE,6)>EMA(CLOSE,7) AND EMA(CLOSE,7)>EMA(CLOSE,8) AND EMA(CLOSE,8)>EMA(CLOSE,9)
AND EMA(CLOSE,9)>EMA(CLOSE,10) AND EMA(CLOSE,10)>EMA(CLOSE,11) AND EMA(CLOSE,11)>EMA(CLOSE,12)
AND EMA(CLOSE,12)>EMA(CLOSE,13) AND EMA(CLOSE,13)>EMA(CLOSE,14) AND EMA(CLOSE,14)>EMA(CLOSE,15)
AND EMA(CLOSE,15)>EMA(CLOSE,20) AND EMA(CLOSE,20)>EMA(CLOSE,30) AND EMA(CLOSE,30)>EMA(CLOSE,60) AND EMA(CLOSE,60)>EMA(CLOSE,90)
AND EMA(CLOSE,90)>EMA(CLOSE,120) AND EMA(CLOSE,120)>EMA(CLOSE,250);
}
A101:=EMA(CLOSE,5)>EMA(CLOSE,6) AND EMA(CLOSE,6)>EMA(CLOSE,7) AND EMA(CLOSE,7)>EMA(CLOSE,8) AND EMA(CLOSE,8)>EMA(CLOSE,9)
AND EMA(CLOSE,9)>EMA(CLOSE,10) AND EMA(CLOSE,10)>EMA(CLOSE,11) AND EMA(CLOSE,11)>EMA(CLOSE,12)
AND EMA(CLOSE,12)>EMA(CLOSE,13) AND EMA(CLOSE,13)>EMA(CLOSE,14) AND EMA(CLOSE,14)>EMA(CLOSE,15);
A102:=EMA(CLOSE,15)>EMA(CLOSE,20) AND EMA(CLOSE,20)>EMA(CLOSE,30) AND EMA(CLOSE,30)>EMA(CLOSE,60) AND EMA(CLOSE,60)>EMA(CLOSE,90)
AND EMA(CLOSE,90)>EMA(CLOSE,120) AND EMA(CLOSE,120)>EMA(CLOSE,250);
A1:= A101 AND A102;
A2:=EMA(CLOSE,5)>EMA(CLOSE,6) AND EMA(CLOSE,6)>EMA(CLOSE,7) AND EMA(CLOSE,7)>EMA(CLOSE,8) AND EMA(CLOSE,8)>EMA(CLOSE,9)
AND EMA(CLOSE,9)>EMA(CLOSE,10) AND EMA(CLOSE,10)>EMA(CLOSE,11) AND EMA(CLOSE,11)>EMA(CLOSE,12)
AND EMA(CLOSE,12)>EMA(CLOSE,13) AND EMA(CLOSE,13)>EMA(CLOSE,14);
B1:=IF(A1,1,2);
VAR1:=((CLOSE > REF(CLOSE,1)) AND (CLOSE > REF(CLOSE,2)));
{股旁网-股票公式网站 www.guPang.com}
VAR2:=((REF(VAR1,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR3:=((REF(VAR2,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR4:=((REF(VAR3,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR5:=((REF(VAR4,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR6:=((REF(VAR5,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR7:=((REF(VAR6,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR8:=((REF(VAR7,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR9:=((REF(VAR8,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VARA:=((REF(VAR9,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VARB:=((REF(VARA,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VARC:=((REF(VARB,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
STICKLINE((((((((((((VAR1 OR VAR2) OR VAR3) OR VAR4) OR VAR5) OR VAR6) OR VAR7) OR VAR8) OR VAR9) OR VARA) OR VARB) OR VARC),C,REF(C,1),3,0),COLOR0000DD;
STICKLINE((((((((((((VAR1 OR VAR2) OR VAR3) OR VAR4) OR VAR5) OR VAR6) OR VAR7) OR VAR8) OR VAR9) OR VARA) OR VARB) OR VARC),L,H,0.5,0),COLOR0000DD;
VARD:=((CLOSE < REF(CLOSE,1)) AND (CLOSE < REF(CLOSE,2)));
VARE:=((REF(VARD,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VARF:=((REF(VARE,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR10:=((REF(VARF,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR11:=((REF(VAR10,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR12:=((REF(VAR11,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR13:=((REF(VAR12,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR14:=((REF(VAR13,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR15:=((REF(VAR14,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR16:=((REF(VAR15,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR17:=((REF(VAR16,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR18:=((REF(VAR17,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
STICKLINE((((((((((((VARD OR VARE) OR VARF) OR VAR10) OR VAR11) OR VAR12) OR VAR13) OR VAR14) OR VAR15) OR VAR16) OR VAR17) OR VAR18),C,REF(C,1),3 ,0 ),COLOR00DD00;
STICKLINE((((((((((((VARD OR VARE) OR VARF) OR VAR10) OR VAR11) OR VAR12) OR VAR13) OR VAR14) OR VAR15) OR VAR16) OR VAR17) OR VAR18),H,L,0.5 ,0 ),COLOR00DD00;
VAR19:=(REF((((((((((((VARD OR VARE) OR VARF) OR VAR10) OR VAR11) OR VAR12) OR VAR13) OR VAR14) OR VAR15) OR VAR16) OR VAR17) OR VAR18),1) AND VAR1);
VAR1A:=(REF((((((((((((VAR1 OR VAR2) OR VAR3) OR VAR4) OR VAR5) OR VAR6) OR VAR7) OR VAR8) OR VAR9) OR VARA) OR VARB) OR VARC),1) AND VARD);
STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),3 ,0 ),COLORDDDDDD;
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),3,0),COLORDD8800;

通达信虎拓主图指标公式

 

相关文章