在线检测未来函数

大智慧完美KDJ指标公式

来源:Internet,编辑:股旁网,2010-09-02

N:= 9 ;
M1 := 3 ;
M2 := 3 ;
M3:= 5 ;
RSV:= (CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
FASTK:=SMA(RSV,M1,1);
K:SMA(FASTK,M2,1);
D:SMA(K,M3,1);
J:3*K-2*D;
partline(j,j>ref(j,1),rgb(255,0,0),j<ref(j,1),rgb(0,255,0));
BB:=count(J<ref(J,1),5)=5;
B:(ref(BB,1) and J>=ref(J,1) and j<30)*10,LINETHICK0;
LB:if(B,LLV(L,10),0),linethick0;
DRAWICON(B,J*0.99,1),ALIGN1;
BIAS:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
XG:((CROSS(K,D)AND D<16 AND BIAS<-6))*80;
j:=3*k-2*d;
PARTLINE(J,J>ref(J,1),RGB(255,50,0),J<ref(J,1),RGB(0,255,255)),linethick2;
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
VAR1:=HHV(DEA,53);
VAR2:=LLV(DEA,55);
VAR3:=DEA-(DIF-DEA);
UP:=IF(DIF>VAR1 AND DEA=VAR1,MAX(LLV(VAR1,10),VAR3),VAR1);
{股旁网-股票公式网站 www.Gupang.com}
DN:=IF(DIF<VAR2 AND DEA=VAR2,MIN(HHV(VAR2,10),VAR3),VAR2);
PARTLINE(104,DIF>UP,RGB(0,180,0)),LINETHICK3,LAYER7;
PARTLINE(-5,DIF<DN,RGB(0,180,0)),LINETHICK3,LAYER7;

大智慧完美KDJ指标公式

 

相关文章