在线检测未来函数

通达信量能明白指标公式

来源:Internet,编辑:股旁网,2010-09-07

换手:=V/CAPITAL*100,STICK;
STICKLINE(换手,0,换手,2,1),COLORRED;
红色区域可做票:=MA(CLOSE,5),COLORYELLOW,NODRAW;
VA:=IF(CLOSE>REF(CLOSE,1),VOL,-VOL);
OBV:=SUM(IF(CLOSE=REF(CLOSE,1),0,VA),0);
MAOBV:=MA(OBV,30);
STICKLINE((OBV>REF(OBV,1) AND OBV>MAOBV),0,换手,2,1),COLORLIRED;
STICKLINE(NOT(OBV>REF(OBV,1) AND OBV>MAOBV),0,换手,2,0),COLORCYAN;
JJ:=(HIGH+LOW+CLOSE)/3;QJ0:=AMOUNT/IF(HIGH=LOW,4,HIGH-LOW);
买1:=QJ0*(MIN(OPEN,CLOSE)-LOW)*2;
买2:=QJ0*(JJ-MIN(CLOSE,OPEN))*2;
卖1:=QJ0*(MAX(CLOSE,OPEN)-JJ)*2;
卖2:=QJ0*(HIGH-MAX(OPEN,CLOSE))*2;
DT:=((买1+买2)-(卖1+卖2))/10000*6,NODRAW;
主力增:DT,NODRAW,COLORRED;
STICKLINE(DT>0,0,换手*0.5,0.5,0),COLOR0000FF;
STICKLINE(DT<0,0,-换手*0.4,0.5,0),COLORGREEN;
TD1:=QJ0*(MIN(OPEN,CLOSE)-LOW);DD1:=QJ0*(JJ-MIN(CLOSE,OPEN));
DD2:=QJ0*(HIGH-MAX(OPEN,CLOSE));TD2:=QJ0*(MAX(CLOSE,OPEN)-JJ);
TD:=TD1-TD2;DA:=DD1-DD2;XD1:=1-(TD1+DD1);XD2:=1-(TD2+DD2);
TZ:=V/SUM(V,60)*100;DTA:=((XD1-XD2)/10000)/TZ;
散户减:DTA,NODRAW,COLORGREEN;
主力比散户:DT/ABS(DTA),NODRAW;
趋势为先:(EMA(CLOSE,12)-EMA(CLOSE,26)),COLORYELLOW,,NODRAW;
缩量买进:EMA(趋势为先,9),COLORMAGENTA,LINETHICK2,NODRAW;
DRAWICON(CROSS(趋势为先,缩量买进),缩量买进,5);
VAR11:=MA(HHV(HIGH,485),17);
VAR21:=MA(HHV(HIGH,222),17);
VAR31:=MA(HHV(HIGH,96),17);
VAR41:=MA(LLV(LOW,485),17);
VAR51:=MA(LLV(LOW,222),17);
VAR61:=MA(LLV(LOW,96),17);
VAR71:=MA((VAR41*0.96+VAR51*0.96+VAR61*0.96+VAR11*0.558+VAR21*0.558+
VAR31*0.558)
/6,17);
VAR81:=MA((VAR41*1.25+VAR51*1.23+VAR61*1.2+VAR11*0.55+VAR21*0.55+VAR31*0.65)
/6,17);
VAR91:=MA((VAR41*1.3+VAR51*1.3+VAR61*1.3+VAR11*0.68+VAR21*0.68+VAR31*0.68)
/6,17);
VARA:=MA((VAR71*3+VAR81*2+VAR91)/6*1.738,17);
VARB:=IF(DATE<=1341231,VARA,VARA*DAY);
VARC:=LOW;
VARD:=REF(LOW,1);
VARE:=SMA(ABS(VARC-VARD),3,1)/SMA(MAX(VARC-VARD,0),3,1)*100;
VARF:=MA(IF(CLOSE*1.35<=VARB,VARE*10,VARE/10),3);
VAR10:=LLV(LOW,30);
VAR111:=HHV(VARF,30);
VAR12:=1341231;
SS:=IF(DATE<=VAR12,MA(IF(LOW<=VAR10,(VARF+VAR11*2)/2,0),3),100000000);
STICKLINE(SS,换手,换手*0.5,0.5,0),COLORBLUE;
{股旁网-股票公式网站 www.Gupang.com}
N:=3;
M1:=10;
VAR1:=(C-EMA(C,6))/EMA(C,6)*100;
VAR2:=(C-MA(C,24))/MA(C,24)*100;
VAR3:=(C-MA(C,32))/MA(C,32)*100;
VAR4:=(VAR1+VAR2+VAR3)/3;
量价结合:MEMA(VAR4,N),COLORWHITE,LINETHICK2;
波段操作:MEMA(量价结合,3),COLORGREEN,LINETHICK2;
IF(量价结合>REF(量价结合,1),量价结合,DRAWNULL),COLORYELLOW,LINETHICK2;
IF(波段操作>REF(波段操作,1),波段操作,DRAWNULL),COLORFF00FF,LINETHICK2;
KX1:=MEMA(量价结合,2);
DRAWTEXT(CROSS(量价结合,KX1),换手*1.1,'买?'),COLORRED;

通达信量能明白指标公式

 

相关文章