在线检测未来函数

通达信黑马线指标公式

来源:Internet,编辑:股旁网,2010-10-05

A0:=HHV(H,9)-LLV(L,9);
A1:=HHV(H,9)-C;
A2:=C-LLV(L,9);
A3:= A1/A0*100-70;
A4:=(C-LLV(L,60))/(HHV(H,60)-LLV(L,60))*100;
A5:=(2*C+H+L)/4;
A6:=SMA(A2/A0*100,3,1);
A7:=LLV(L,34);
A8:=SMA(A6,3,1)-SMA(A3,9,1);
A9:=IF(A8>100,A8-100,0);
AA:=HHV(H,34);
AB:=A9*2;
AC:=EMA((A5-A7) / (AA-A7)*100,13);
AD:= EMA(0.667*REF(AC,1)+0.333*AC,2);
AE:=SMA(A4,20,1);
AF:=SMA(AB,2,1)-AB;
B0:=EMA(0.667*REF(AC,1)+0.333*AC,2)-AC;
B1:=(HHV(H,9)-C)/(HHV(H,9)-LLV(LOW,9))*100- 70;
B2:=SMA(B1,9,1)+100;
B3:=(C-LLV(L,9))/(HHV(H,9)- LLV(L,9))*100;
B4:=SMA(B3,3,1);
B5:=SMA(B4,3,1)+100;
B6:=B5-B2;
B7:=IF(B6>60,B6-60,0);
STICKLINE(REF(B7,1)<B7,B7,REF(B7,1),5,0),COLORRED;
STICKLINE(REF(B7,1)>B7,B7,REF(B7,1),5,0),COLORFFFF00;
主力:EMA((CLOSE-MA(CLOSE,7))/MA(CLOSE,7)*480,2),LINETHICK2,COLORRED;
散户:EMA((CLOSE-MA(CLOSE,11))/MA(CLOSE,11)*480,7),LINETHICK2,COLORWHITE;
DRAWTEXT(CROSS(主力,散户) AND 主力<-10,-20,'升'),COLORYELLOW;
{股旁网-股票公式网站 www.guPang.com}
DRAWICON(CROSS(主力,散户) AND 主力<-10 AND 散户>REF(散户,1)OR CROSS(主力,散户) AND 散户<-35 ,-15,1);
加速探底:IF((MA(C,5)-C)/C>0.04 AND (MA(C,10)-MA(C,5))/MA(C,5)>0.04,40,0.85),COLORYELLOW;
机会来临1:REF(IF(REF(C,1)/C>0.04 AND (MA(C,10)-MA(C,5))/MA(C,5)>0.04,40,0),1),COLOR9999FF;
A11:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1);
黑马线:=EMA(A11,5);
A21:=(黑马线-REF(黑马线,1))/REF(黑马线,1)*100;
A31:=EMA(C,5);
A41:=((C-LLV(L,21))/(HHV(H,21)-LLV(L,21)))*100;
趋势线:=(MA(3*SMA(A41,6,1)-2*SMA(SMA(A41,5,1),5,1),2));
A51:=(HHV(H,60)-C)/(HHV(H,60)-LLV(L,60))*100;
DRAWTEXT(FILTER(REF(黑马线,1)>90 AND A21<0,7),黑马线,'跑'),COLOR00FF00;
DRAWTEXT(CROSS(A11,黑马线)AND 黑马线<A51,黑马线,'黑马'),COLORYELLOW;
DRAWTEXT(CROSS(黑马线,A51)AND 趋势线<80,黑马线,'追涨'),COLOR688EC1;
DRAWTEXT(CROSS(趋势线,0)AND 黑马线<40,5,'大黑马'),COLORFFFF00;
底部:=(A21<-10 AND A21>REF(A21,1))*25;
DRAWICON(底部 AND A31>REF(A31,1),25,1);
机会来临2:REF(IF((MA(C,5)-C)/C>0.04 AND (MA(C,10)-MA(C,5))/MA(C,5)>0.04,65,0),1),COLORF00FF0;

通达信黑马线指标公式

 

相关文章