在线检测未来函数

通达信短线买卖主图指标公式

来源:Internet,编辑:股旁网,2010-10-08

MA10:MA(CLOSE,5),
COLOR00FFFF;
AA:MA(CLOSE,32);
AA,COLORFF00FF,LINETHICK3;
IF(AA<REF(AA,1),AA,DRAWNULL),COLORFF0000,LINETHICK3;
生命线:EMA(C,453),COLORRED,LINETHICK2;
YTSL:=(3*C+L+O+H)/6;
①:(20*YTSL+19*REF(YTSL,1)+18*REF(YTSL,2)+17*REF(YTSL,3)+16*REF(YTSL,4)+15*REF(YTSL,5)+14*REF(YTSL,6)+13*REF(YTSL,7)+12*REF(YTSL,8)+11*REF(YTSL,9)+10*REF(YTSL,10)+9*REF(YTSL,11)+8*REF(YTSL,12)+7*REF(YTSL,13)+6*REF(YTSL,14)+5*REF(YTSL,15)+4*REF(YTSL,16)+3*REF(YTSL,17)+2*REF(YTSL,18)+REF(YTSL,20))/211,COLORFFFF00;
VAR1:=(C>REF(C,1) AND C>REF(C,2));
VAR2:=(REF(VAR1,1) AND C<=REF(C,1) AND C>=REF(C,2));
VAR3:=(REF(VAR2,1) AND C>=REF(C,1) AND C<=REF(C,2));
VAR4:=(REF(VAR3,1) AND C<=REF(C,1) AND C>=REF(C,2));
VAR5:=(REF(VAR4,1) AND C>=REF(C,1) AND C<=REF(C,2));
VAR6:=(REF(VAR5,1) AND C<=REF(C,1) AND C>=REF(C,2));
VAR7:=(REF(VAR6,1) AND C>=REF(C,1) AND C<=REF(C,2));
VAR8:=(REF(VAR7,1) AND C<=REF(C,1) AND C>=REF(C,2));
VAR9:=(REF(VAR8,1) AND C>=REF(C,1) AND C<=REF(C,2));
VARA:=(REF(VAR9,1) AND C<=REF(C,1) AND C>=REF(C,2));
VARB:=(REF(VARA,1) AND C>=REF(C,1) AND C<=REF(C,2));
VARC:=(REF(VARB,1) AND C<=REF(C,1) AND C>=REF(C,2));
{股旁网-股票公式网站 www.guPang.com}
BB:IF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,①,DRAWNULL),COLORRED,POINTDOT,LINETHICK8;
VARD:=(C<REF(C,1) AND C<REF(C,2));
VARE:=(REF(VARD,1) AND C>=REF(C,1) AND C<=REF(C,2));
VARF:=(REF(VARE,1) AND C<=REF(C,1) AND C>=REF(C,2));
VAR10:=(REF(VARF,1) AND C>=REF(C,1) AND C<=REF(C,2));
VAR11:=(REF(VAR10,1) AND C<=REF(C,1) AND C>=REF(C,2));
VAR12:=(REF(VAR11,1) AND C>=REF(C,1) AND C<=REF(C,2));
VAR13:=(REF(VAR12,1) AND C<=REF(C,1) AND C>=REF(C,2));
VAR14:=(REF(VAR13,1) AND C>=REF(C,1) AND C<=REF(C,2));
VAR15:=(REF(VAR14,1) AND C<=REF(C,1) AND C>=REF(C,2));
VAR16:=(REF(VAR15,1) AND C>=REF(C,1) AND C<=REF(C,2));
VAR17:=(REF(VAR16,1) AND C<=REF(C,1) AND C>=REF(C,2));
VAR18:=(REF(VAR17,1) AND C>=REF(C,1) AND C<=REF(C,2));
VAR19:=((REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1)) AND VAR1);
VAR1A:=((REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,1)) AND VARD);
DRAWTEXT(VAR19,L,'←短买'),COLOR33FFCC;
DRAWTEXT(VAR1A,H+0.1,'←逃顶'),COLORFF99FF;

通达信短线买卖主图指标公式

 

相关文章