在线检测未来函数

通达信周MACD+超跌码+变色主图指标公式

来源:Internet,编辑:股旁网,2010-10-10

{MACD}
RC:=DYNAINFO(3)*1.1;
DK:="MACD.MACD"(60,130,45)*2;
控盘:=DK;
STICKLINE(控盘<0 AND 控盘<REF(控盘,1),控盘+RC,RC,0.05,0),COLORLIBLUE;
STICKLINE(控盘<0 AND 控盘>REF(控盘,1),控盘+RC,RC,0.05,0),COLORWHITE;
STICKLINE(控盘>REF(控盘,1) AND 控盘>0,控盘+RC,RC,0.05,0),COLORRED;
STICKLINE(控盘<REF(控盘,1) AND 控盘>0,控盘+RC,RC,0.05,0),COLOR00FF00;
{超跌反弹原码}{加在主图即可}
KS:=(C-MA(C,13))/MA(C,13)*(-100);
RKS:=REF(KS,1);
MLS:=RKS/KS>=1.23 AND RKS>=8 AND C/REF(C,1)>=1.02;
超跌:STICKLINE(KS>=8,H,L,0,1),COLORWHITE,LINETHICK1;
STICKLINE(KS>=8,O,C,7,1),COLORWHITE,LINETHICK1;
反弹:STICKLINE(MLS=1,H,L,0,1),COLORMAGENTA,LINETHICK1;
STICKLINE(MLS=1,O,C,7,1),COLORMAGENTA,LINETHICK1;
MA5:EMA(C,5),COLORWHITE LINETHICK1;
{股旁网-股票公式网站 www.guPang.com}
IF(MA5>=REF(MA5,1),MA5,DRAWNULL),LINETHICK2,COLORRED;
IF(MA5<=REF(MA5,1),MA5,DRAWNULL),LINETHICK1,COLORGREEN;
MA10:EMA(C,10),COLORWHITE LINETHICK1;
IF(MA10>=REF(MA10,1),MA10,DRAWNULL),LINETHICK2,COLORRED;
IF(MA10<=REF(MA10,1),MA10,DRAWNULL),LINETHICK1,COLORGREEN;
MA20:EMA(C,20),COLORWHITE LINETHICK1;
IF(MA20>=REF(MA20,1),MA20,DRAWNULL),LINETHICK2,COLORRED;
IF(MA20<=REF(MA20,1),MA20,DRAWNULL),LINETHICK1,COLORGREEN;
M30:EMA(C,30),COLORWHITE POINTDOT;
IF(M30>=REF(M30,1),M30,DRAWNULL),LINETHICK2,COLOR0066FF;
IF(M30<=REF(M30,1),M30,DRAWNULL),LINETHICK1,COLORCYAN;
M60:EMA(C,60),COLORWHITE POINTDOT;
IF(M60>=REF(M60,1),M60,DRAWNULL),LINETHICK2,COLORYELLOW;
IF(M60<=REF(M60,1),M60,DRAWNULL),LINETHICK1,COLORCC9900;
M120:EMA(C,120),COLORWHITE POINTDOT;
IF(M120>=REF(M120,1),M120,DRAWNULL),LINETHICK1,COLOR0066FF POINTDOT;
IF(M120<=REF(M120,1),M120,DRAWNULL),LINETHICK1,COLORWHITE POINTDOT;
M240:EMA(C,240),COLORWHITE POINTDOT;
IF(M240>=REF(M240,1),M240,DRAWNULL),LINETHICK1,COLOR0066FF POINTDOT;
IF(M240<=REF(M240,1),M240,DRAWNULL),LINETHICK1,COLORMAGENTA POINTDOT;

通达信周MACD+超跌码+变色主图指标公式

 

相关文章