在线检测未来函数

飞狐高抛画线主图指标公式

来源:Internet,编辑:股旁网,2010-10-14

input:M(55,1,999);
DRAWGBK(CLOSE=CLOSE,COLORRGB(130,130,130),COLORRGB(30,30,30),1);
逃遁:=(SMA(HIGH, 21,2) * 1.05);
STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,9,0),colorFF5B00;
STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,8,0),colorFF6C00;
STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,7,0),colorFF7B00;
STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,6,0),colorFF9C00;
STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,5,0),colorFFBE00;
STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,3.5,0),colorFFCC00;
STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,1.5,0),colorFFFF00;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,9,0),color70084;
{股旁网-股票公式网站 www.guPang.com}
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,8,0),colorA3;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,7,0),colorB7;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,6,0),colorCD;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,5,0),colorE9;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,3,0),color754E9;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,1.5,0),color76EF3;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,1,0),color77BF3;
STICKLINE((CLOSE > OPEN),OPEN,LOW,2,0),color726CA;
STICKLINE((CLOSE > OPEN),CLOSE,HIGH,2,0),color726CA;
STICKLINE((OPEN > CLOSE),CLOSE,LOW,2,0),colorDE9100;
STICKLINE((OPEN > CLOSE),OPEN,HIGH,2,0),colorDE9100;
STICKLINE(((((CLOSE / OPEN) > 1.04) AND (CLOSE < 逃遁)) AND ((CLOSE - REF(CLOSE,2)) > 0)),CLOSE,OPEN,9,0),color90FF;
STICKLINE(((((CLOSE / OPEN) > 1.04) AND (CLOSE < 逃遁)) AND ((CLOSE - REF(CLOSE,2)) > 0)),CLOSE,OPEN,8,0),color9FFF;
STICKLINE(((((CLOSE / OPEN) > 1.04) AND (CLOSE < 逃遁)) AND ((CLOSE - REF(CLOSE,2)) > 0)),CLOSE,OPEN,4,0),colorB5FF;
STICKLINE(((((CLOSE / OPEN) > 1.04) AND (CLOSE < 逃遁)) AND ((CLOSE - REF(CLOSE,2)) > 0)),CLOSE,OPEN,2,0),colorE4FF;
STICKLINE(((((CLOSE / OPEN) > 1.04) AND (CLOSE < 逃遁)) AND ((CLOSE - REF(CLOSE,2)) > 0)),OPEN,LOW,0.7,0),colorFFFF;
STICKLINE(((((CLOSE / OPEN) > 1.04) AND (CLOSE < 逃遁)) AND ((CLOSE - REF(CLOSE,2)) > 0)),CLOSE,HIGH,0.7,0),colorFFFF;
STICKLINE(((((CLOSE < REF(CLOSE,1)) AND (CLOSE < REF(CLOSE,1))) AND (HIGH > 逃遁)) AND (CLOSE < 逃遁)),OPEN,LOW,0.7,0),colorFF76FF;
STICKLINE(((((CLOSE < REF(CLOSE,1)) AND (CLOSE < REF(CLOSE,1))) AND (HIGH > 逃遁)) AND (CLOSE < 逃遁)),CLOSE,HIGH,0.7,0),colorFF76FF;
STICKLINE(((((CLOSE < REF(CLOSE,1)) AND (CLOSE < REF(CLOSE,1))) AND (HIGH > 逃遁)) AND (CLOSE < 逃遁)),CLOSE,OPEN,9,0),colorFF00FF;
STICKLINE(((((CLOSE < REF(CLOSE,1)) AND (CLOSE < REF(CLOSE,1))) AND (HIGH > 逃遁)) AND (CLOSE < 逃遁)),CLOSE,OPEN,6,0),colorFF62FF;
STICKLINE(((((CLOSE < REF(CLOSE,1)) AND (CLOSE < REF(CLOSE,1))) AND (HIGH > 逃遁)) AND (CLOSE < 逃遁)),CLOSE,OPEN,4,0),colorFF76FF;
STICKLINE(((((CLOSE < REF(CLOSE,1)) AND (CLOSE < REF(CLOSE,1))) AND (HIGH > 逃遁)) AND (CLOSE < 逃遁)),CLOSE,OPEN,2,0),colorFFA8FF;
买进:=((CLOSE-REF(MA(CLOSE,6),1))/6+MA(CLOSE,6))*1.004;
买进条件:=CROSS(CLOSE,买进) AND 买进>REF(买进,1),LINETHICK0;
加仓:=((CLOSE-REF(MA(CLOSE,18),1))/18+MA(CLOSE,18))*1.004;
加仓条件:=CROSS(CLOSE,加仓) AND 加仓>REF(加仓,1),LINETHICK0;
STICKLINE(CLOSE>OPEN AND 加仓条件 AND 买进条件,CLOSE,HIGH,2.2,1),COLORBROWN,linethick2;
STICKLINE(CLOSE>OPEN AND 加仓条件 AND 买进条件,LOW,OPEN,2.2,1),COLORBROWN,linethick2;
STICKLINE(CLOSE>OPEN AND 加仓条件 AND 买进条件,CLOSE,OPEN,2.2,1),COLORBROWN,linethick2;
aa1:=AMOUNT/VOL;
bb1:=LOW<aa1*0.9;
cc1:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100>1.2;
dd1:=LOW<MA(CLOSE,5)*0.921;
ee1:=VOL<MA(VOL,5)*1.5;
老鼠仓:bb1 and cc1 and dd1 and ee1,linethick0,ColorFFFFFF;
STICKLINE(老鼠仓,OPEN,CLOSE,2.2,1),linethick2,ColorFFFFFF;
A:=BACKSET(ISLASTBAR,(HHVBARS(HIGH,M) + 1));
B:=(A > REF(A,1));
D:=BACKSET(ISLASTBAR,(LLVBARS(LOW,M) + 1));
E:=(D > REF(D,1));
HH:=REF(HIGH,BARSLAST(B));
LL:=REF(LOW,BARSLAST(E));
选取最低:LL,LINETHICK1,COLORBLUE;
DRAWTEXT(ISLASTBAR,(LL ),' 起动点'),ALIGN1,COLORBLUE;
PARTLINE(1,(LL * 1.191)),COLORRED,LINETHICK1;
PARTLINE(1,(LL * 1.382)),LINETHICK1,COLORMAGENTA,LINEDASH;
PARTLINE(1,(LL * 1.5)),LINETHICK1,ColorFFFFFF;
PARTLINE(1,(LL * 1.618)),COLORYELLOW,LINEDASH,LINETHICK1;
PARTLINE(1,(LL * 1.809)),COLORGREEN,LINETHICK1;
PARTLINE(1,(LL * 2)),COLORCYAN;
DRAWTEXT(ISLASTBAR,(LL * 1.191),'(1.191)\n耐心持有\n待 突 破'),ALIGN1,COLORRED;
DRAWTEXT(ISLASTBAR,(LL * 1.382),'(1.382)\n高抛低吸\n取 黄 金'),ALIGN1,COLORMAGENTA;
DRAWTEXT(ISLASTBAR,(LL * 1.5),'平 衡'),ALIGN1,ColorFFFFFF;
DRAWTEXT(ISLASTBAR,(LL * 1.618),'(1.618)\n高高在上\n买 不 宜'),ALIGN1,COLORYELLOW;
DRAWTEXT(ISLASTBAR,(LL * 1.809),'(1.809)\n风光无限\n在 险 峰'),ALIGN1,COLORGREEN;
DRAWTEXT(ISLASTBAR,(LL * 2),'实顶位'),ALIGN1,COLORCYAN;
YB:=SYSPARAM(2);
黄:=SYSPARAM(3);
P:=(黄 - YB);
金:=((黄 - YB) + 1);
分:=HHV(HIGH,金);
割:=LLV(LOW,金);
YC:=((P * 0.191) + YB);
YD:=((P * 0.382) + YB);
YE:=((P * 0.5) + YB);
YF:=((P * 0.618) + YB);
YG:=((P * 0.809) + YB);
S4:=SYSPARAM(4);
S5:=SYSPARAM(5);
HH:=HHVBARS(HIGH,(P + 1));
LL:=LLVBARS(LOW,(P + 1));
X:=(BARPOS = (黄 - HH[黄]));
Y:=(BARPOS = (黄 - LL[黄]));
K:=((S4 - S5) / (黄 - YB));
DRAWSL(Y,LOW,((10 * K) / 60),0,0),LINEDASH,COLORFFFFFF;
DRAWSL(Y,LOW,((30 * K) / 60),0,0),LINEDASH,COLOR99FFFF;
DRAWSL(Y,LOW,((60 * K) / 60),0,0),LINEDASH,COLOR00FFFF;
DRAWSL(Y,LOW,((90 * K) / 60),0,0),LINEDASH,color00CCFF;
DRAWSL(Y,LOW,((120 * K) / 60),0,0),LINEDASH,color0099FF;
DRAWSL(Y,LOW,((180 * K) / 60),0,0),LINEDASH,color0066FF;
DRAWSL(Y,LOW,((300 * K) / 60),0,0),LINEDASH,COLOR0000FF;
DRAWSL(Y,LOW,((540 * K) / 60),0,0),LINEDASH,COLORFF3366;
DRAWSL(Y,LOW,((1020 * K) / 60),0,0),LINEDASH,COLOR00FF33;
LC:=REF(CLOSE,1);
RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100);
FF:=EMA(CLOSE,3);
MA15:=EMA(CLOSE,21);
DRAWTEXT(CROSS(FF,MA15),(LOW * 0.99),'△背离'),COLOR0000FF;
{阳光普照 fxj主图}
{A4:=MA(CLOSE,20);
A5:=(CLOSE > MA(CLOSE,5));
A6:=(MA(CLOSE,5) > MA(CLOSE,10));
A7:=(CLOSE > MA(CLOSE,10));
A8:=(MA(CLOSE,5) > MA(CLOSE,20));
A9:=(CLOSE > MA(CLOSE,20));
A10:=REF(A4,1);
A11:=(A4 > A10);
AVX:=(((((IF(A5,10,(0 - 10)) + IF(A6,10,(0 - 10))) + IF(A7,10,(0 - 10))) + IF(A8,10,(0 - 10))) + IF(A9,10,(0 - 10))) + IF(A11,10,(0 - 10)));
DSLX:=(CLOSE / INDEXC);
DSLX1:=MA(DSLX,5);
DSLX2:=MA(DSLX,10);
V1:=MA(VOL,5);
V2:=MA(VOL,10);
mc:=REF(CLOSE,1);
TJTS1:=BARSTATUS=2 and CLOSE<200;
TJTS2:=BARSTATUS=2 and CLOSE>200;
T := BARSLAST(SYSPARAM(2)=BARPOS)+1;
HHg := HHV(HIGH, T);
ddg := LLV(LOW, T);
{Hk := LL-HH; G12 := LL-HK*1.55; }
k2:=HHV(HIGH*1.03,BARSLAST(SYSPARAM(2)=BARPOS)+1);
DRAWTEXT(TJTS1 and ((CROSS(AVX,1) AND (V1 >= V2)) AND (DSLX >= DSLX1)) ,k2*0.99,'★该股的量能理想,有明显走强迹象,可以考虑中线进场参与,仓位在2/3左右。 '),ALIGN2,color0000FF,LINETHICK2;
DRAWTEXT(TJTS1 and ((CROSS(AVX,1) AND (V1 < V2)) AND (DSLX >= DSLX1)) ,k2*0.99,'★该股虽然走势趋强,但量能还显不足,可以考虑短线进场,仓位在1/2左右。 '),ALIGN2,color0000FF,LINETHICK2;
DRAWTEXT(TJTS1 and ((CROSS(AVX,1) AND (V1 > V2)) AND (DSLX < DSLX1)) ,k2*0.99,'★该股量价配合良好,但相对其它股票并没有明显走强,可以考虑短线进场,仓位1/2左右。 '),ALIGN2,color0000FF,LINETHICK2;
DRAWTEXT(TJTS1 and ((CROSS(AVX,1) AND (V1 <= V2)) AND (DSLX < DSLX1)) ,k2*0.99,'★该股形态尚可,但量能不足,股票也未完全走强,可以短线参与,仓位1/3左右。 '),ALIGN2,color0000FF,LINETHICK2;
DRAWTEXT(TJTS1 and ((CROSS(1,AVX) AND (V1 >= V2)) AND (DSLX >= DSLX1)) ,k2*0.99,'★该股形态变坏,但走势相对其它股票尚可,重仓者减持大半,清仓者可以观望。 '),ALIGN2,color00FF00,LINETHICK2;
DRAWTEXT(TJTS1 and ((CROSS(1,AVX) AND (V1 < V2)) AND (DSLX >= DSLX1)) ,k2*0.99,'★该股随大盘一起下跌,程明显缩量走势,考虑到大盘风险,减持或清仓。 '),ALIGN2,color00FF00,LINETHICK2;
DRAWTEXT(TJTS1 and ((CROSS(1,AVX) AND (V1 >= V2)) AND (DSLX < DSLX1)) ,k2*0.99,'★该股放量下跌,走势明显偏弱,离场观望。 '),ALIGN2,color00FF00,LINETHICK2;
DRAWTEXT(TJTS1 and ((CROSS(1,AVX) AND (V1 < V2)) AND (DSLX < DSLX1)) ,k2*0.99,'★该股缩量下跌,走势偏弱,离场观望。 '),ALIGN2,color00FF00,LINETHICK2;
DRAWTEXT(TJTS1 and ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 >= V2)) AND (DSLX >= DSLX1)) ,k2*0.99,'★该股形态良好,强势明显,量能充足,可以继续持有。 '),ALIGN2,color00FFFF,LINETHICK2;
DRAWTEXT(TJTS1 and ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 < V2)) AND (DSLX >= DSLX1)) ,k2*0.99,'★该股上行趋势不变,强势依然,但量能开始转弱,注意风险。 '),ALIGN2,color00FFFF,LINETHICK2;
DRAWTEXT(TJTS1 and ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 >= V2)) AND (DSLX < DSLX1)) ,k2*0.99,'★该股仍然具备上涨潜力,但股性偏弱,可考虑减仓。 '),ALIGN2,color00FFFF,LINETHICK2;
DRAWTEXT(TJTS1 and ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 < V2)) AND (DSLX < DSLX1)) ,k2*0.99,'★该股走势趋弱,量能不足,减持大部分筹码。 '),ALIGN2,color00FFFF,LINETHICK2;
DRAWTEXT(TJTS1 and ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 >= V2)) AND (DSLX >= DSLX1)) ,k2*0.99,'★该股形态不佳,注意成交量的变化,但目前不适合参与。 '),ALIGN2,LINETHICK2;
DRAWTEXT(TJTS1 and ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 < V2)) AND (DSLX >= DSLX1)) ,k2*0.99,'★该股趋势不明,股价偏弱,注意量能变化,目前不宜参与。 '),ALIGN2,LINETHICK2;
DRAWTEXT(TJTS1 and ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 >= V2)) AND (DSLX < DSLX1)) ,k2*0.99,'★该股有走强迹象,但量能不足,趋势不明,不适合操作。 '),ALIGN2,LINETHICK2;
DRAWTEXT(TJTS1 and ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 < V2)) AND (DSLX < DSLX1)) ,k2*0.99,'★该股走势太弱,没有参与价值。 '),ALIGN2,LINETHICK2;
DRAWTEXT(TJTS2 and (CROSS(AVX,1) AND (V1 >= V2)) ,k2*0.99,'★大盘量能理想,有明显走强迹象,可以考虑中线进场参与,仓位在2/3左右, '),ALIGN2,color0000FF;
DRAWTEXT(TJTS2 and (CROSS(AVX,1) AND (V1 >= V2)) ,k2*0.98,'★如前期经过一轮下跌,此时为最佳买点,但如果前期有过一段涨幅则介入需谨慎。 '),ALIGN2,color0000FF,LINETHICK2;
DRAWTEXT(TJTS2 and (CROSS(AVX,1) AND (V1 < V2)) ,k2*0.99,'★大盘虽然走势趋强,但量能还显不足,如果前期经过一轮下跌, '),ALIGN2,color0000FF,LINETHICK2;
DRAWTEXT(TJTS2 and (CROSS(AVX,1) AND (V1 < V2)) ,k2*0.98,' ★可以考虑短线进场,仓位在1/2左右,一旦量能放大可以加仓买入。 '),ALIGN2,color0000FF,LINETHICK2;
DRAWTEXT(TJTS2 and (CROSS(1,AVX) AND (V1 >= V2)) ,k2*0.99,'★大盘形态走坏,重仓者可以减去大部分仓位。 '),ALIGN2,color00FF00,LINETHICK2;
DRAWTEXT(TJTS2 and (CROSS(1,AVX) AND (V1 < V2)) ,k2*0.99,'★大盘缩量调整,注意风险,短线清仓观望。 '),ALIGN2,color00FF00,LINETHICK2;
DRAWTEXT(TJTS2 and (((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 >= V2)) ,k2*0.99,'★大盘走势良好,量能理想,可以继续持有强势股。 '),ALIGN2,color00FFFF,LINETHICK2;
DRAWTEXT(TJTS2 and (((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 < V2)) ,k2*0.99,'★大盘形态良好,但量能稍显不足,随时准备减仓。 '),ALIGN2,color00FFFF;
DRAWTEXT(TJTS2 and (((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 >= V2)) ,k2*0.99,'★大盘趋势不明,注意成交量变化,目前不适宜进场。 '),ALIGN2,LINETHICK2;
DRAWTEXT(TJTS2 and (((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 < V2)) ,k2*0.99,'★大盘趋势向下,量能萎缩,不适合进场。 '),ALIGN2,LINETHICK2;

飞狐高抛画线主图指标公式

 

相关文章