在线检测未来函数

大智慧大盘对对指标公式

来源:Internet,编辑:股旁网,2010-10-19

N1:=2000;N2:=11;N3:=24;N4:=0;N5:=0;
M:=BARSLAST(DATE=(2009-1900)*10000+11*100+24)-0;
收:="SH000001$CLOSE";
开:="SH000001$OPEN";
高:="SH000001$HIGH";
低:="SH000001$LOW";
DCC:=收/ref(收,m);
DOO:=DCC*开/收;
DHH:=DCC*高/收;
DLL:=DCC*低/收;
CC:=c/ref(c,m);
OO:=CC*O/C;
HH:=CC*H/C;
LL:=CC*L/C;
C1:=EMA(INDEXC,500)/EMA(C,500);
D1:=INDEXO/C1;
D2:=INDEXH/C1;
D3:=INDEXL/C1;
D4:=INDEXC/C1;
MAdp1:MA(DCC,5);
MAdp2:MA(dCC,10);
MAdp3:MA(DCC,20);
MA1:MA(CC,5);
MA2:MA(CC,10);
MA3:MA(CC,20);
大盘涨幅:(dcc-ref(dcc,1))/ref(dcc,1)*100,ColorFFFFFF,LINETHICK0;
个股涨幅:(cc-ref(cc,1))/ref(cc,1)*100,ColorFF00FF,LINETHICK0;
大盘阶段涨幅:(DCC-1)*100,ColorFFFFFF,LINETHICK0;
个股阶段涨幅:(CC-1)*100,ColorFF00FF,LINETHICK0;
板块:=IFS(INBLOCK('工程建筑'),'工程建筑',IFS(INBLOCK('电力'),'电力',IFS(INBLOCK('计算机'),'计算机',IFS(INBLOCK('电子信息'),'电子信息',
IFS(INBLOCK('房地产'),'房地产',IFS(INBLOCK('纺织服装'),'纺织服装',IFS(INBLOCK('钢铁'),'钢铁',IFS(INBLOCK('供水供气'),'供水供气',
IFS(INBLOCK('化工化纤'),'化工化纤',IFS(INBLOCK('电器'),'电器',IFS(INBLOCK('交通设施'),'交通设施',IFS(INBLOCK('银行类'),'银行类',
IFS(INBLOCK('旅游酒店'),'旅游酒店',IFS(INBLOCK('煤炭石油'),'煤炭石油',IFS(INBLOCK('酿酒食品'),'酿酒食品',IFS(INBLOCK('农林牧渔'),'农林牧渔',
IFS(INBLOCK('商业连锁'),'商业连锁',IFS(INBLOCK('建材'),'建材',IFS(INBLOCK('其他行业'),'其他行业',IFS(INBLOCK('汽车类'),'汽车类',
IFS(INBLOCK('机械'),'机械',IFS(INBLOCK('医药'),'医药',IFS(INBLOCK('外贸'),'外贸',IFS(INBLOCK('教育传媒'),'教育传媒',IFS(INBLOCK('仪电仪表'),'仪电仪表',
IFS(INBLOCK('有色金属'),'有色金属',IFS(INBLOCK('造纸印刷'),'造纸印刷',IFS(INBLOCK('券商'),'券商',IFS(INBLOCK('电力设备'),'电力设备',
IFS(INBLOCK('通信'),'通信',IFS(INBLOCK('运输物流'),'运输物流',IFS(INBLOCK('保险'),'保险',''))))))))))))))))))))))))))))))));
DRAWTEXTABS(0,15,'所属: '+板块+'指数'),COLORYELLOW;
所属板块:=BKNAME;
DRAWTEXTABS(0,2, '所属板块: '+所属板块),Color888888{,COLORYELLOW};
{股旁网-股票公式网站 www.gupanG.com}
STICKLINE(n5=0 and CC>=OO,CC,OO,5,0),colorred;
STICKLINE(n5=0 and CC>=OO,HH,CC,0.5,0),colorred;
STICKLINE(n5=0 and CC>=OO,OO,LL,0.5,0),colorred;
STICKLINE(n5=0 and CC<OO,CC,OO,5,0),colorgreen;
STICKLINE(n5=0 and CC<OO,LL,HH,0.5,0),colorgreen;
STICKLINE(n5=0 and DCC>=DOO,DCC,DOO,5,1),color5255ff;
STICKLINE(n5=0 and DCC>=DOO,DHH,DCC,0.5,0),color5255ff;
STICKLINE(n5=0 and DCC>=DOO,DOO,DLL,0.5,0),color5255ff;
STICKLINE(n5=0 and DCC<DOO,DCC,DOO,5,0),colorffff52;
STICKLINE(n5=0 and DCC<DOO,DLL,DHH,0.5,0),colorffff52;
STICKLINE(n5=1 and D4>=D1,D4,D1,5,1),color5255ff;
STICKLINE(n5=1 and D4>=D1,D2,D4,0.5,0),color5255ff;
STICKLINE(n5=1 and D4>=D1,D1,D3,0.5,0),color5255ff;
STICKLINE(n5=1 and D4<D1,D4,D1,5,0),colorffff52;
STICKLINE(n5=1 and D4<D1,D3,D2,0.5,0),colorffff52;
STICKLINE(n5=1 and c>=o,c,o,5,0),colorred;
STICKLINE(n5=1 and c>=o,h,c,0.5,0),colorred;
STICKLINE(n5=1 and c>=o,o,l,0.5,0),colorred;
STICKLINE(n5=1 and c<o,c,o,5,0),colorgreen;
STICKLINE(n5=1 and c<o,l,h,0.5,0),colorgreen;

大智慧大盘对对指标公式

 

相关文章