在线检测未来函数

大智慧短线狙击指标公式

来源:Internet,编辑:股旁网,2010-10-20

双线持币:HHV(MA(HIGH,(3)),2),LINETHICK2,color00ff00;
单线持股:LLV(MA(HIGH,(3)),1),LINETHICK2,color0000FF;
DRAWTEXTREL(400,10,'双线持币.单线持股'),LINETHICK4,Coloryellow;
A74:=MA(CLOSE,20);
A75:=(CLOSE > MA(CLOSE,5));
A76:=(MA(CLOSE,5) > MA(CLOSE,10));
A77:=(CLOSE > MA(CLOSE,10));
A78:=(MA(CLOSE,5) > MA(CLOSE,20));
A79:=(CLOSE > MA(CLOSE,20));
A710:=REF(A74,1);
A711:=(A74 > A710);
AVX:=(((((IF(A75,10,(0 - 10)) + IF(A76,10,(0 - 10))) + IF(A77,10,(0 - 10))) + IF(A78,10,(0 - 10))) + IF(A79,10,(0 - 10))) + IF(A711,10,(0 - 10)));
DSLX:=(CLOSE / INDEXC);
DSLX1:=MA(DSLX,5);
DSLX2:=MA(DSLX,10);
V1:=MA(VOL,5);
V2:=MA(VOL,10);T := BARSLAST(DISPSTATUS=1)+1;
T := BARSLAST(DISPSTATUS=1)+1;
HHg := HHV(H, T);
ddg := LLV(L, T);
{Hk := LL-HH; G12 := LL-HK*1.55; }
IF BARSTATUS=2 and c<200 and ((CROSS(AVX,1) AND (V1 >= V2)) AND (DSLX >= DSLX1)) THEN
DRAWTEXTABS(32,100,'该股的量能理想,有明显走强迹象,可以考虑中线进场参与,仓位在2/3左右。 '),color0000FF,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((CROSS(AVX,1) AND (V1 < V2)) AND (DSLX >= DSLX1)) THEN
DRAWTEXTABS(32,100,'该股虽然走势趋强,但量能还显不足,可以考虑短线进场,仓位在1/2左右。 '),color0000FF,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((CROSS(AVX,1) AND (V1 > V2)) AND (DSLX < DSLX1)) THEN
DRAWTEXTABS(20,100,'该股量价配合良好,但相对其它股票并没有明显走强,可以考虑短线进场,仓位1/2左右。 '),color0000FF,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((CROSS(AVX,1) AND (V1 <= V2)) AND (DSLX < DSLX1)) THEN
DRAWTEXTABS(32,100,'该股形态尚可,但量能不足,股票也未完全走强,可以短线参与,仓位1/3左右。 '),color0000FF,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((CROSS(1,AVX) AND (V1 >= V2)) AND (DSLX >= DSLX1)) THEN
DRAWTEXTABS(32,100,'该股形态变坏,但走势相对其它股票尚可,重仓者减持大半,清仓者可以观望。 '),color00FF00,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((CROSS(1,AVX) AND (V1 < V2)) AND (DSLX >= DSLX1)) THEN
DRAWTEXTABS(32,100,'该股随大盘一起下跌,程明显缩量走势,考虑到大盘风险,减持或清仓。 '),color00FF00,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((CROSS(1,AVX) AND (V1 >= V2)) AND (DSLX < DSLX1)) THEN
DRAWTEXTABS(32,100,'该股放量下跌,走势明显偏弱,离场观望。 '),color00FF00,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((CROSS(1,AVX) AND (V1 < V2)) AND (DSLX < DSLX1)) THEN
DRAWTEXTABS(32,100,'该股缩量下跌,走势偏弱,离场观望。 '),color00FF00,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 >= V2)) AND (DSLX >= DSLX1)) THEN
DRAWTEXTABS(32,100,'该股形态良好,强势明显,量能充足,可以继续持有。 '),color00FFFF,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 < V2)) AND (DSLX >= DSLX1)) THEN
DRAWTEXTABS(32,100,'该股上行趋势不变,强势依然,但量能开始转弱,注意风险。 '),color00FFFF,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 >= V2)) AND (DSLX < DSLX1)) THEN
DRAWTEXTABS(32,100,'该股仍然具备上涨潜力,但股性偏弱,可考虑减仓。 '),color00FFFF,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 < V2)) AND (DSLX < DSLX1)) THEN
DRAWTEXTABS(32,100,'该股走势趋弱,量能不足,减持大部分筹码。 '),color00FFFF,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 >= V2)) AND (DSLX >= DSLX1)) THEN
DRAWTEXTABS(32,100,'该股形态不佳,注意成交量的变化,但目前不适合参与。 '),COLOR00FF00,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 < V2)) AND (DSLX >= DSLX1)) THEN
DRAWTEXTABS(32,100,'该股趋势不明,股价偏弱,注意量能变化,目前不宜参与。 '),COLOR00FF00,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 >= V2)) AND (DSLX < DSLX1)) THEN
DRAWTEXTABS(32,100,'该股有走强迹象,但量能不足,趋势不明,不适合操作。 '),COLOR00FF00,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 < V2)) AND (DSLX < DSLX1)) THEN
DRAWTEXTABS(32,100,'该股走势太弱,没有参与价值。 '),COLOR00FF00,LINETHICK3;
IF BARSTATUS=2 and c>200 and (CROSS(AVX,1) AND (V1 >= V2)) THEN
DRAWTEXTABS(32,100,'大盘量能理想,有明显走强迹象,可以考虑中线进场参与,仓位在2/3左右, '),color0000FF,LINETHICK3;
IF BARSTATUS=2 and c>200 and (CROSS(AVX,1) AND (V1 >= V2)) THEN
DRAWTEXTABS(32,100,'如前期经过一轮下跌,此时为最佳买点,但如果前期有过一段涨幅则介入需谨慎。 '),color0000FF,LINETHICK3;
IF BARSTATUS=2 and c>200 and (CROSS(AVX,1) AND (V1 < V2)) THEN
DRAWTEXTABS(32,100,'大盘虽然走势趋强,但量能还显不足,如果前期经过一轮下跌, '),color0000FF,LINETHICK3;
IF BARSTATUS=2 and c>200 and (CROSS(AVX,1) AND (V1 < V2)) THEN
DRAWTEXTABS(32,100,'可以考虑短线进场,仓位在1/2左右,一旦量能放大可以加仓买入。 '),color0000FF,LINETHICK3;
IF BARSTATUS=2 and c>200 and (CROSS(1,AVX) AND (V1 >= V2)) THEN
DRAWTEXTABS(32,100,'大盘形态走坏,重仓者可以减去大部分仓位。 '),color00FF00,LINETHICK3;
IF BARSTATUS=2 and c>200 and (CROSS(1,AVX) AND (V1 < V2)) THEN
DRAWTEXTABS(32,100,'大盘缩量调整,注意风险,短线清仓观望。 '),color00FF00,LINETHICK3;
IF BARSTATUS=2 and c>200 and (((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 >= V2)) THEN
DRAWTEXTABS(32,100,'大盘走势良好,量能理想,可以继续持有强势股。 '),color00FFFF,LINETHICK3;
IF BARSTATUS=2 and c>200 and (((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 < V2)) THEN
DRAWTEXTABS(32,100,'大盘形态良好,但量能稍显不足,随时准备减仓。 '),color00FFFF,LINETHICK3;
IF BARSTATUS=2 and c>200 and (((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 >= V2)) THEN
DRAWTEXTABS(32,100,'大盘趋势不明,注意成交量变化,目前不适宜进场。 '),COLOR00FF00,LINETHICK3;
IF BARSTATUS=2 and c>200 and (((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 < V2)) THEN
DRAWTEXTABS(32,100,'大盘趋势向下,量能萎缩,不适合进场。 '),COLOR00FF00,LINETHICK3;
DRAWGBK((CLOSE > 0),STRIP(RGB(4,1,28),RGB(4,1,35),0));
PT := REF(HIGH,1)-REF(LOW,1);
重心:=(HIGH + LOW + CLOSE)/3;
压力Ⅰ:= 2*重心-LOW;
压力Ⅱ:= 重心 + PT;
支撑Ⅰ:= 2*重心-HIGH;
支撑Ⅱ:= 重心 - PT;
{股旁网-股票公式网站 www.gupanG.com}
DRAWTEXTABS(100,13,' 《逆势操作》'),ColorFFFFFF;
DRAWTEXTABS(175,13,' 重心:'+重心),Coloryellow;
DRAWTEXTABS(100,32,' 支 撑'),ColorFFFFFF;
DRAWTEXTABS(100,49,' '+支撑Ⅰ),ColorFFFFFF;
DRAWTEXTABS(100,67,' '+支撑Ⅱ),ColorFFFFFF;
DRAWTEXTABS(100,32,' 压 力'),ColorFFFFFF;
DRAWTEXTABS(100,49,' '+压力Ⅰ),ColorFFFFFF;
DRAWTEXTABS(100,67,' '+压力Ⅱ),ColorFFFFFF;
DRAWTEXTABS(100,10,'│'),Color00FFFF;
DRAWTEXTABS(100,22,'│'),Color00FFFF;
DRAWTEXTABS(100,34,'│'),Color00FFFF;
DRAWTEXTABS(100,46,'│'),Color00FFFF;
DRAWTEXTABS(100,58,'│'),Color00FFFF;
DRAWTEXTABS(100,70,'│'),Color00FFFF;
DRAWTEXTABS(243,10,'│'),Color00FFFF;
DRAWTEXTABS(243,22,'│'),Color00FFFF;
DRAWTEXTABS(243,34,'│'),Color00FFFF;
DRAWTEXTABS(243,46,'│'),Color00FFFF;
DRAWTEXTABS(243,58,'│'),Color00FFFF;
DRAWTEXTABS(243,70,'│'),Color00FFFF;
DRAWTEXTABS(171,30,'│'),Color00FFFF;
DRAWTEXTABS(171,34,'│'),Color00FFFF;
DRAWTEXTABS(171,46,'│'),Color00FFFF;
DRAWTEXTABS(171,58,'│'),Color00FFFF;
DRAWTEXTABS(171,70,'│'),Color00FFFF;
DRAWTEXTABS(105,5,'────────────'),Color00FFFF;
DRAWTEXTABS(105,25,'────────────'),Color00FFFF;
DRAWTEXTABS(105,42,'────────────'),Color00FFFF;
DRAWTEXTABS(105,59,'────────────'),Color00FFFF;
DRAWTEXTABS(105,76,'────────────'),Color00FFFF;
Var1:=ma((v/(h-l)),4);
Var33:=abs(c-o);Var44:=v/(h-l);
TIPTEXT(Var44<var1 AND Var33<ma(Var33,4),0,'资金无入场意愿,萎缩中\n');
TIPTEXT(Var44<var1 AND Var33>ma(Var33,4),0,'场内资金运作行为\n');
TIPTEXT(Var44>var1 AND Var33<ma(Var33,4),0,'多空双方激烈争夺中\n');
TIPTEXT(Var44>var1 AND Var33>ma(Var33,4),0,'场外资金介入(或出局)意愿强烈\n');
TR := SUM(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),14);
HD := HIGH-REF(HIGH,1);
LD := REF(LOW,1)-LOW;
DMP:= SUM(IF(HD>0 AND HD>LD,HD,0),14);
DMM:= SUM(IF(LD>0 AND LD>HD,LD,0),14);
PDI:= DMP*100/TR;
MDI:= DMM*100/TR;
ADX:= MA(ABS(MDI-PDI)/(MDI+PDI)*100,6);
ADXR:=(ADX+REF(ADX,6))/2;
TIPTEXT(cross(pdi,mdi),0,'PDI线从下向上突破MDI线,显示有新多头进场,为买进信号\n');
TIPTEXT(cross(mdi,pdi),0,'PDI线从上向下跌破MDI线,显示有新空头进场,为卖出信号\n');
TIPTEXT(adx>ref(adx,1),0,'ADX值持续高于前一日,行情将维持原趋势\n');
TIPTEXT(adx<ref(adx,1) and adx<20,0,'ADX值递减,降到20以下,且横向行进时,市场气氛为盘整\n');
TIPTEXT(adx<ref(adx,1) and ref(adx,1)<ref(adx,2) and ref(adx,2)>ref(adx,3) and ref(adx,3)>ref(adx,4),0,'ADX值从上升倾向转为下降时,表明行情即将反转\n');
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
TIPTEXT(1=1,0,'');
TIPTEXT(cross(j,k) and k<50,0,'KDJ金叉\n');
TIPTEXT(cross(k,j) and k>50,0,'KDJ死叉\n');
TIPTEXT(j>84,0,'KDJ指标高位');
TIPTEXT(j<16,0,'KDJ指标低位\n');
TYP := (HIGH + LOW + CLOSE)/3;
cci:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14));
TIPTEXT(cci<-100,0,'CCI指标底位,买入机会\n');
TIPTEXT(cci>100,0,'CCI指标高位,卖出机会\n');
wr:=-100*(HHV(HIGH,14)-CLOSE)/(HHV(HIGH,14)-LLV(LOW,14));
TIPTEXT(wr>-20,0,'W&R超买,即将见顶,应及时卖出\n');
TIPTEXT(wr<-80,0,'W&R超卖,即将见底,应伺机买进\n');
MTM := CLOSE-REF(CLOSE,6);
MTMMA := MA(MTM,6);
TIPTEXT(CROSS(MTM,MTMMA),0,'MTM从下向上突破MTMMA,买入信号\n');
TIPTEXT(CROSS(MTMMA,MTM),0,'MTM从上向下跌破MTMMA,卖出信号\n');
LC := REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
RSI2:=SMA(MAX(CLOSE-LC,0),12,1)/SMA(ABS(CLOSE-LC),12,1)*100;
TIPTEXT(RSI1>85,0,'6日RSI向上突破85,超买,考虑卖出\n');
TIPTEXT(RSI1<15,0,'6日RSI向下跌破15,超卖,考虑买入\n');
TIPTEXT(CROSS(RSI1,RSI2),0,'6日RSI向上突破12日RSI,买进信号\n');
TIPTEXT(CROSS(RSI2,RSI1),0,'6日RSI向下跌破12日RSI,卖出信号\n');
VarA:=EMA((CLOSE-LLV(LOW,14))/(HHV(HIGH,14)-LLV(LOW,14))*4,3);
VarB:=REF(LOW,1)*0.9;
VarC:=LOW*0.9;
VarD:=(VarC*VOL+VarB*(CAPITAL-VOL))/CAPITAL;
VarE:=EMA(VarD,30);
VarF:=CLOSE-REF(CLOSE,1);
Var10:=MAX(VarF,0);
Var11:=ABS(VarF);
Var12:=SMA(Var10,5,1)/SMA(Var11,5,1)*100;
Var13:=SMA(Var10,14,1)/SMA(Var11,14,1)*100;
Var14:=SMA(MAX(VarF,0),4,1)/SMA(ABS(VarF),4,1)*100;
Var15:=(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))*(-100);
Var16:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;
Var17:=SMA((SMA(Var16,4,1)-50)*2,3,1);
Var18:=(INDEXC-LLV(INDEXL,20))/(HHV(INDEXH,28)-LLV(INDEXL,20))*100;
Var19:=SMA(Var18,4,1);
Var1B:=(HHV(HIGH,30)-CLOSE)/CLOSE*100;
妖精:=Var14<=30 AND Var15<-30 AND Var1B>20 AND VarE-CLOSE>=-0.248 AND Var12<22 AND Var13<30;
Var20:=(INDEXC-LLV(INDEXL,15))/(HHV(INDEXH,15)-LLV(INDEXL,15))*100;
Var21:=SMA(Var20,4,1);
Var1C:=SMA(Var21,3,1);
都不能少:=Var14<=20 AND Var15<-80 AND Var1B>20 AND Var17<-30 AND Var1C<30 AND VarE-CLOSE>=-1 AND Var12<20 AND Var13<26;
TIPTEXT(妖精=1 ,0,'提示:吸货50%,中短期底部。');
TIPTEXT(妖精=1 ,0,'财富降临,有资金在逢低买入。');
TIPTEXT(都不能少=1 ,0,'中短期底部,一个都不能少。');
TIPTEXT(都不能少=1,0,'财富降临,资金在逢低建仓。');

大智慧短线狙击指标公式

 

相关文章