在线检测未来函数

飞狐MACD+KDJ金死叉指标公式

来源:Internet,编辑:股旁网,2010-10-21

DIFF:=(EMA(CLOSE,12)-EMA(CLOSE,26));
DEA:=EMA(DIFF,9);
MACD:2*(DIFF-DEA),COLORSTICK;
STICKLINE(MACD<ref(MACD,1)and MACD>0,0,MACD,8,0),COLOR00aaff;
STICKLINE(MACD<ref(MACD,1)and MACD>0,0,MACD,6.6,0),COLOR00bbff;
STICKLINE(MACD<ref(MACD,1)and MACD>0,0,MACD,4.4,0),COLOR00ccff;
STICKLINE(MACD<ref(MACD,1)and MACD>0,0,MACD,3.3,0),COLOR00ddff;
STICKLINE(MACD<ref(MACD,1)and MACD>0,0,MACD,2.2,0),COLOR00eeff;
STICKLINE(MACD<ref(MACD,1)and MACD>0,0,MACD,1.1,0),COLOR00ffff;
STICKLINE(MACD>=ref(MACD,1)and MACD>0,0,MACD,8,0),COLOR0000aa;
STICKLINE(MACD>=ref(MACD,1)and MACD>0,0,MACD,6.6,0),COLOR0011bb;
STICKLINE(MACD>=ref(MACD,1)and MACD>0,0,MACD,4.4,0),COLOr0022cc;
STICKLINE(MACD>=ref(MACD,1)and MACD>0,0,MACD,3.3,0),COLOR0033dd;
STICKLINE(MACD>=ref(MACD,1)and MACD>0,0,MACD,2.2,0),COLOR0044ee;
STICKLINE(MACD>=ref(MACD,1)and MACD>0,0,MACD,1.1,0),COLOR0055ff;
STICKLINE(MACD>ref(MACD,1)and MACD<0,0,MACD,8,0),COLOraa00bb;
STICKLINE(MACD>ref(MACD,1)and MACD<0,0,MACD,6.6,0),COLORbb11bb;
STICKLINE(MACD>ref(MACD,1)and MACD<0,0,MACD,4.4,0),COLOrcc22bb;
STICKLINE(MACD>ref(MACD,1)and MACD<0,0,MACD,3.3,0),COLORdd33bb;
STICKLINE(MACD>ref(MACD,1)and MACD<0,0,MACD,2.2,0),COLORee44bb;
STICKLINE(MACD>ref(MACD,1)and MACD<0,0,MACD,1.1,0),COLORff55bb;
STICKLINE(MACD<=ref(MACD,1)and MACD<0,0,MACD,8,0),COLOrffaa00;
STICKLINE(MACD<=ref(MACD,1)and MACD<0,0,MACD,6.6,0),COLORffbb11;
STICKLINE(MACD<=ref(MACD,1)and MACD<0,0,MACD,4.4,0),COLOrffcc22;
STICKLINE(MACD<=ref(MACD,1)and MACD<0,0,MACD,3.3,0),COLORffdd33;
STICKLINE(MACD<=ref(MACD,1)and MACD<0,0,MACD,2.2,0),COLORffee44;
STICKLINE(MACD<=ref(MACD,1)and MACD<0,0,MACD,1.1,0),COLORffff55;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:3*K-2*D,linethick0;
周K:=MA("KDJ.K#WEEK"(9,3,3),5),pointdot,LINETHICK2,COLORWHITE;
周D:=MA("KDJ.D#WEEK"(9,3,3),5),pointdot,LINETHICK2,COLOR33FF99;
周J:=MA("KDJ.J#WEEK"(9,3,3),5),LINETHICK1,COLORred;
DRAWICON(k<20 and cross(k,d),MACD,8),linethick,align2,COLORBROWN;
日金▲: DRAWTEXT(CROSS("KDJ.K#DAY"(9,3,3),"KDJ.D#DAY"(9,3,3)),MACD,'▲'),linethick,align2,COLORgray;
日死▼: DRAWTEXT(CROSS("KDJ.d#DAY"(9,3,3),"KDJ.k#DAY"(9,3,3)),macd*1.5,'▼'),linethick,align2,COLORwhite;
周金▲: DRAWTEXT(CROSS("KDJ.K#WEEK"(9,3,3),"KDJ.D#WEEK"(9,3,3)),MACD,'▲'),linethick,align2,COLORred;
周死▼: DRAWTEXT(CROSS("KDJ.d#WEEK"(9,3,3),"KDJ.k#WEEK"(9,3,3)),macd*1.5,'▼'),linethick,align2,COLORgreen;
月金▲: DRAWTEXT(CROSS("KDJ.K#MONTH"(9,3,3),"KDJ.D#MONTH"(9,3,3)),MACD,'▲'),linethick,align2,COLORMAGENTA;
月死▼: DRAWTEXT(CROSS("KDJ.D#MONTH"(9,3,3),"KDJ.K#MONTH"(9,3,3)),macd*1.5,'▼'),linethick,align2,COLORYELLOW;
DIFF: (EMA(CLOSE,12)-EMA(CLOSE,26)),COLORWHITE;
DEA:EMA(DIFF,9),COLORWHITE;
{股旁网-股票公式网站 www.gupanG.com}
partline(c>ma(c,15) and diff>=dea,dea),colormagenta,linethick2;
partline(c>ma(c,15) and diff>=dea,diff),colorred,linethick2;
partline(c<ma(c,15),dea),colorgreen,linethick2;
partline(c<ma(c,15),diff),colorgreen,linethick2;
vertline(diff<70 AND cross(diff,dea)),colorRED;
vertline(cross(dea,diff)),colorWHITE;

飞狐MACD+KDJ金死叉指标公式

 

相关文章