在线检测未来函数

通达信指标王之操盘黄金主图指标公式

来源:Internet,编辑:股旁网,2010-10-25

操盘线:EMA(CLOSE,13),COLORRED;
M5:MA(CLOSE,5),COLORWHITE;
黄金线:COST(24),COLORYELLOW,POINTDOT,LINETHICK4;
底线:COST(5),COLORGREEN;
1号线:MA(CLOSE,144),COLORWHITE,LINETHICK2;
4号线:EMA(CLOSE,453),COLORRED,LINETHICK2;
VAR2:=(HIGH+LOW+CLOSE*2)/4;
VAR3:=EMA(VAR2,21);
VAR4:=STD(VAR2,21);
VAR5:=((VAR2-VAR3)/VAR4*100+200)/4;
VAR6:=(EMA(VAR5,5)-25)*1.56;
AK:=EMA(VAR6,2)*1.22;
AD:=EMA(AK,2);
AJ:=3*AK-2*AD;
STICKLINE(CROSS(AK,AD),LOW,LOW-0.09,8,0),COLORRED;{短线买}
AC:=CLOSE;
AH:=HIGH;
AL:=LOW;
AO:=OPEN;
STICKLINE(AC>=AO,AH,AC,1,0),COLOR008899;
STICKLINE(AC>=AO,AH,AC,0,0),COLOR77FFEE;
STICKLINE(AC>=AO,AO,AL,1,0),COLOR008899;
STICKLINE(AC>=AO,AO,AL,0,0),COLOR77FFEE;
STICKLINE(AC>AO,AC,AO,8,0),COLOR008899;
STICKLINE(AC>AO,AC,AO,7,0),COLOR1199AA;
STICKLINE(AC>AO,AC,AO,6,0),COLOR22AABB;
STICKLINE(AC>AO,AC,AO,5,0),COLOR33BBCC;
STICKLINE(AC>AO,AC,AO,4,0),COLOR44CCDD;
STICKLINE(AC>AO,AC,AO,3,0),COLOR55DDEE;
STICKLINE(AC>AO,AC,AO,2,0),COLOR66EEEE;
STICKLINE(AC>AO,AC,AO,1,0),COLOR77FFEE;
STICKLINE(AC<=AO,AH,AC,1,0),COLORFF8800;
STICKLINE(AC<=AO,AH,AC,0,0),COLORFFFF33;
STICKLINE(AC<=AO,AO,AL,1,0),COLORFF8800;
STICKLINE(AC<=AO,AO,AL,0,0),COLORFFFF33;
STICKLINE(AC<=AO,AC,AO,8,0),COLORFF8800;
STICKLINE(AC<=AO,AC,AO,7,0),COLORFF9900;
STICKLINE(AC<=AO,AC,AO,6,0),COLORFFAA11;
STICKLINE(AC<=AO,AC,AO,5,0),COLORFFBB11;
STICKLINE(AC<=AO,AC,AO,4,0),COLORFFCC22;
STICKLINE(AC<=AO,AC,AO,3,0),COLORFFDD22;
STICKLINE(AC<=AO,AC,AO,2,0),COLORFFEE33;
STICKLINE(AC<=AO,AC,AO,1,0),COLORFFFF33;
{股旁网-股票公式网站 www.gupanG.com}
F:=100*(CLOSE-REF(CLOSE,1))/REF(CLOSE,1);
今小昨:=IF(CLOSE<REF(OPEN,1) AND F<0,1,0);
P1:=今小昨;
今小前:=IF(CLOSE<REF(OPEN,2) AND F<0,1,0);
P2:=今小前;
STICKLINE(P1=0 AND REF(P1,1)=1 AND P2=0 AND REF(P2,1)=1,OPEN,CLOSE,4,0),COLORRED;{短线进}
STICKLINE(P1=1 AND REF(P1,1)=0 AND P2=1 AND REF(P2,1)=0,OPEN,CLOSE,4,0),COLORBLUE;{短线出}
N:=13;
A:=HHV(HIGH,N)=HIGH AND HIGH>REF(HIGH,1);A1:=FILTER(A,N-1);
B:=LLV(LOW,N)=LOW AND LOW<REF(LOW,1);B1:=FILTER(B,N-1);
TS1:=BARSLAST(A1);
箱顶:REF(HIGH,TS1) ,COLORFF00FF, LINETHICK0;
STICKLINE(1,箱顶,箱顶,7,0),COLORFF00FF;
TS11:=BARSLAST(B1);
箱底:REF(LOW,TS11) ,COLORFF8080, LINETHICK0;
STICKLINE(1,箱底,箱底,7,0),COLORFF8080;
DRAWICON(CROSS(CLOSE,箱顶),HIGH*1.01,4);
DRAWICON(CROSS(箱底,CLOSE),LOW*0.99,5);
DRAWICON(CROSS(箱顶,CLOSE) AND REF(CLOSE,1)>=箱顶,箱顶,12);

 

相关文章