在线检测未来函数

通达信指标王之色柱操作主图指标公式

来源:Internet,编辑:股旁网,2010-10-25

GJ:=(C+H+L+O)/4;
明日阻力:=L+(GJ-L)+(C-L);
明日支撑:=L+(C-GJ);
今日阻力:=REF(明日阻力 , 1),LINETHICK0;
今日支撑:=REF(明日支撑 , 1),LINETHICK0;
年:MA(CLOSE,26),POINTDOT,COLORRED,LINETHICK5;
IF(年<REF(年,1),年,DRAWNULL),POINTDOT,COLORGREEN,LINETHICK5;
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,2.8,0 ),COLORFFAA00;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2.8,0) ,COLOR000099;
{股旁网-股票公式网站 www.gupanG.com}
VAR9Q:= (HHV(C,4) AND REF(C,1)>=REF(C,2))
OR ( HHV(C,4) AND REF(C,1)>=REF(C,3))
OR (REF(C,1)=HHV(C,4) AND CLOSE>=REF(C,2))
OR (REF(C,2)=HHV(C,4) AND REF(C,3)=LLV(C,4) AND C>=REF(C,1))
OR (REF(C,3)=HHV(C,4) AND C>=REF(C,1) AND C>=REF(C,2));
红持:=VAR9Q,COLOR0000FF,LINETHICK0;
DRAWTEXT(ISLASTBAR AND 红持,今日阻力,'——红持'),COLOR0000DD;
STICKLINE(VAR9Q,C,(O+C)/2,2.8,0),COLOR0000DD;
VARAQ:=C>=HHV(C,4) AND (REF(C,1)=LLV(C,4));
粉变:=VARAQ;
DRAWTEXT(ISLASTBAR AND 粉变,今日阻力,'—— 粉变'),COLORFF66FF;
STICKLINE(VARAQ,C,(O+C)/2,2.8,0),COLORFF66FF;
VARBQ:=C=LLV(C,4) AND (REF(C,1)<REF(C,2) OR REF(C,1)<REF(C,3))
OR REF(C,1)=LLV(C,4) AND C<REF(C,2)
OR REF(C,2)=LLV(C,4) AND REF(C,1) != HHV(C,4) AND C<REF(C,1)
OR REF(C,3)=LLV(C,4) AND C<REF(C,1) AND C<REF(C,2);
灰跌:=VARBQ;
DRAWTEXT(ISLASTBAR AND 灰跌,今日支撑,'——灰跌'),COLORAAAAAA;
STICKLINE(VARBQ,C,(O+C)/2,2.8,0),COLORAAAAAA;
VARCQ:=(REF(C,1)=LLV(C,4) AND C>=REF(C,2))
OR (REF(C,2)=LLV(C,4) AND REF(C,1)<=REF(C,3) AND REF(C,2)<REF(C,4) AND C>=REF(C,1));
绿买:=VARCQ;
DRAWTEXT(ISLASTBAR AND 绿买,今日支撑,'—— 绿买'),COLOR008800;
STICKLINE(VARCQ,O,(O+C)/2,2.8,0),COLOR008800;
VARDQ:=REF(C,1)=HHV(C,4) AND C<REF(C,2)
OR (REF(C,2)=HHV(C,4) AND REF(C,1)>REF(C,3)AND REF(C,2)>=REF(C,4) AND C<REF(C,1))
OR (REF(C,3)=HHV(C,4) AND REF(C,1)>REF(C,2)
AND REF(C,2)>=REF(C,4) AND C<REF(C,1));
蓝抛:=VARDQ;
DRAWTEXT(ISLASTBAR AND 蓝抛,今日阻力,'—— 蓝抛'),COLOR008800;
STICKLINE(VARDQ,O,(O+C)/2,2.8,0),COLORFF6600;
STICKLINE(C>0,O,C,0,0),COLORFFFFFF;

通达信色柱操作主图指标公式

 

相关文章