在线检测未来函数

通达信指标王之至尊操盘主图指标公式

来源:Internet,编辑:股旁网,2010-10-26

EMA13:EMA(C,13),COLORFF44FF,LINETHICK1;
EMA34:EMA(C,34),COLOR00FF00;
EMA55:EMA(C,55),COLOR008888;
STICKLINE(MA(C,1)>MA(C,30),CLOSE,OPEN,6,1),COLOR3333FF;
STICKLINE(MA(C,1)>MA(C,30),HIGH,LOW,0.8,1),COLOR3333FF;
STICKLINE(MA(C,30)>MA(C,1),CLOSE,OPEN,6,1),COLORFFFF00;
STICKLINE(MA(C,30)>MA(C,1),HIGH,LOW,0.8,1),COLORFFFF00;
VAR1:=(VOL / (((HIGH - LOW) * 2) - ABS((CLOSE - OPEN))));
买盘:=IF((CLOSE > OPEN),(VAR1 * (HIGH - LOW)),IF((CLOSE < OPEN),(VAR1 * ((HIGH - OPEN) + (CLOSE - LOW))),(VOL / 2)));
卖盘:=IF((CLOSE > OPEN),(0 - (VAR1 * ((HIGH - CLOSE) + (OPEN - LOW)))),IF((CLOSE < OPEN),(0 - (VAR1 * (HIGH - LOW))),(0 - (VOL / 2))));
买卖差:=(买盘 + 卖盘);
JX1:=BARSSINCE(买盘);
JY1:=IF(((121 > JX1) AND (JX1 > 0)),JX1,120);
JY2:=IF(((4 > JX1) AND (JX1 > 0)),JX1,3);
VAR30:=MA(VOL,JY2);
神比:=(买盘 / VAR30);
鬼比:=(卖盘 / VAR30);
VAR2:=(HIGH - LOW);
VAR3:=ABS((OPEN - CLOSE));
VAR4:=(HIGH - IF((CLOSE > OPEN),CLOSE,OPEN));
VAR5:=(IF((CLOSE > OPEN),OPEN,CLOSE) - LOW);
VAR6:=((VAR3 / VAR2) * VOL);
VAR7:=((VAR4 / VAR2) * VOL);
VAR8:=((VAR5 / VAR2) * VOL);
VAR9:=IF(((VOL / CAPITAL) > 0.001),1,EXP(ABS(LOG(((VOL / CAPITAL) * 100)))));
VARA:=(((CLOSE - MA(CLOSE,5)) / MA(CLOSE,5)) * 100);
VARB:=(((MA(CLOSE,5) > MA(CLOSE,10)) AND (MA(CLOSE,10) > MA(CLOSE,30))) AND (MA(CLOSE,30) > MA(CLOSE,60))); VARC:=((MA(CLOSE,5) < MA(CLOSE,10)) AND (MA(CLOSE,10) < MA(CLOSE,30)));
VARD:=REF(CLOSE,1);
VAR40:=((IF((((VAR6 >= VAR7) AND (VAR6 >= VAR8)) AND (CLOSE > OPEN)),VAR6,买盘) + 买盘) / 2);
VAR41:=((IF(((VAR7 > VAR6) AND (VAR7 > VAR8)),VAR7,买盘) + 买盘) / 2);
VAR42:=((IF(((VAR8 > VAR6) AND (VAR8 > VAR7)),VAR8,买盘) + 买盘) / 2);
VAR50:=((IF((((VAR6 >= VAR7) AND (VAR6 >= VAR8)) AND (CLOSE < OPEN)),VAR6,卖盘) + 卖盘) / 2);
MA6:=MA(C,13);
EMA(C,5),COLORWHITE;
EMA120:=EMA(C,120),COLORFFCC22;
AR1:=EMA55>EMA34 AND EMA34>EMA13;
AR2:=BARSLAST((C-EMA13)/EMA13*100<-6);
AR3:=EMA13>=REF(EMA13,2);
AR4:=COUNT(CROSS(C,EMA13),AR2)=1;
AR5:=AR1 AND AR2 AND AR3 AND AR4;
AR6:=AR5 AND FILTER(AR5,10);
股道短:=MA(C,13);
股道中:=MA(C,34);
股道长:=MA(C,55);
短交长:=CROSS(股道短,股道长);
中交长:=CROSS(股道中,股道长);
空头排列:=股道短<股道中 AND 股道短<股道长 AND 股道中<股道长;
走平上行:=股道短>=REF(股道短,1);
DRAWTEXT(短交长 OR 中交长,L-0.04,'底马'),COLORYELLOW;
多头排列:=股道短>股道中 AND 股道短>股道长 AND 股道中>股道长;
DRAWTEXT(O<股道短 AND C>股道短 AND 多头排列,L-0.04,'满园春色'),COLORFF44FF;
DRAWTEXT(O<股道短 AND O<股道中 AND O<股道长 AND C>股道短 AND
C>股道中 AND C>股道长,L-0.08,'买推'),COLORFF44FF;
BR1:=COUNT(BETWEEN((C-REF(C,1))/REF(C,1)*100,0,5) ,5)=5;
BR2:=ABS((EMA13-EMA34)+(EMA34-EMA55))/C<0.2;
BR3:=C>EMA55 AND (REF(C,1)<REF(EMA55,1) OR REF(C,2)<REF(EMA55,2) OR REF(C,3)<REF(EMA55,3) OR REF(C,4)<REF(EMA55,4) OR REF(C,5)<REF(EMA55,5));
BR4:=BR1 AND BR2 AND BR3;
DRAWTEXT(BR4 AND FILTER(BR4,10),L-0.08,'底蚁'),COLOR00C5FF;
STICKLINE(BR4 AND FILTER(BR4,10),H,L,0.5,1),COLOR00C5FF;
STICKLINE(BR4 AND FILTER(BR4,10),O,C,6,1),LINETHICK2,COLOR00C5FF;
CR1:=(C-REF(C,1))/REF(C,1)*100>0.5;
CR2:=V>MA(V,5)*0.6;
CR3:=COUNT(CROSS(EMA13,EMA55),3)=1;
CR4:=ABS(EMA34-EMA55)/EMA55<0.03;
CR5:=EMA55<=EMA120 AND EMA55>=REF(EMA55,1);
CR6:=FILTER(CR1 AND CR2 AND CR3 AND CR4 AND CR5,2);
STICKLINE(CR6,H,L,0.5,1),COLORF00FF0;
STICKLINE(CR6,O,C,6,1),LINETHICK2,COLORF00FF0;
DRAWTEXT(CR6,L-0.08,'买衣'),COLORF00FF0;
DR1:=EMA13>EMA34 AND EMA34<EMA55;
DR2:=BARSLAST(CROSS(C,EMA55) );
DR3:=H=HHV(H,DR2);
DR4:=BARSLAST(DR3);
DR5:=COUNT(O>C AND C<REF(C,1) AND C>EMA55 AND BETWEEN((C-EMA55)/EMA55,0,0.02),DR4)=1;
DR6:=C>REF(C,1) ;
DR7:= DR1 AND DR5 AND DR6 ;
DR8:=DR7 AND FILTER(DR7 ,10);
DRAWTEXT(DR8,L-0.08,'回黑'),COLORYELLOW;
STICKLINE(DR8,H,L,0.5,1),COLORD6BA63;
STICKLINE(DR8,O,C,6,1),LINETHICK2,COLORD6BA63;
ER:=BARSLAST(REF(CROSS(EMA55,EMA34),1)) AND CROSS(EMA34,EMA55);
DRAWTEXT(ER,L-0.08,'多均'),COLOR0099FF;
STICKLINE(ER,H,L,0.5,1),COLOR0099FF;
STICKLINE(ER,O,C,6,1),LINETHICK2,COLOR0099FF;
FR:=BARSLAST(REF(CROSS(EMA34,EMA13),1)) AND CROSS(EMA13,EMA34);
DRAWTEXT(FR,L-0.04,'升梅'),COLORFF44FF;
STICKLINE(FR,H,L,0.5,1),COLORWHITE;
STICKLINE(FR,O,C,6,1),LINETHICK2,COLORWHITE;
GR1:=BARSLAST(BETWEEN("BIAS.BIAS2"(6,13,24),0,5) );
GR2:=EMA13>EMA34 AND EMA34>EMA55 AND EMA13>REF(EMA13,1);
GR3:=COUNT("BIAS.BIAS2"(6,13,24)>10 AND H=HHV(H,GR1),GR1);
GR4:=H=HHV(H,GR1);
GR5:="MACD.MACD"(12,26,9)<REF("MACD.MACD"(12,26,9),1);
GR6:=GR2 AND GR3 AND GR4;
GR7:=GR2 AND GR3 AND GR4 AND GR5;
DRAWTEXT(GR6 AND GR7,H+0.08,'顶逃!'),COLOR00FF00;
STICKLINE(GR6 AND GR7,H,H+0.09,4,0),COLOR00FF00;
HR2:=EMA13>=REF(EMA13,3) AND EMA34>=REF(EMA34,1) AND EMA55>=REF(EMA55,1) AND CROSS(C,EMA13) AND CROSS(C,EMA34) AND CROSS(C,EMA55);
DRAWTEXT(HR2 AND FILTER(HR2,10),L-0.08,'买推'),COLORFFC8FF;
STICKLINE(HR2 AND FILTER(HR2,10),H,L,0.5,1),COLORFFC8FF;
STICKLINE(HR2 AND FILTER(HR2,10),O,C,6,1),LINETHICK2,COLORFFC8FF;
EMA17:=EMA(C,17),COLORRED,LINETHICK2;
DRAWTEXT(BR4 AND FILTER(BR4,10),L-0.08,'底蚁'),COLOR00C5FF;
{STICKLINE(BR4 AND FILTER(BR4,10),H,L,0.5,1),COLOR00C5FF;
STICKLINE(BR4 AND FILTER(BR4,10),O,C,6,1),LINETHICK2,COLOR00C5FF;}
{STICKLINE(CR6,H,L,0.5,1),COLORF00FF0;
STICKLINE(CR6,O,C,6,1),LINETHICK2,COLORF00FF0;}
DRAWTEXT(CR6,L-0.08,'买衣'),COLORF00FF0;
{股旁网-股票公式网站 www.gupanG.com}
DRAWTEXT(DR8,L-0.08,'回黑'),COLORYELLOW;
{STICKLINE(DR8,H,L,0.5,1),COLORD6BA63;
STICKLINE(DR8,O,C,6,1),LINETHICK2,COLORD6BA63;}
DRAWTEXT(ER,L-0.08,'多均'),COLOR0099FF;
{STICKLINE(ER,H,L,0.5,1),COLOR0099FF;
STICKLINE(ER,O,C,6,1),LINETHICK2,COLOR0099FF;}
DRAWTEXT(FR,L-0.04,'升梅'),COLORFF44FF;
{STICKLINE(FR,H,L,0.5,1),COLORWHITE;
STICKLINE(FR,O,C,6,1),LINETHICK2,COLORWHITE;}
DRAWTEXT(GR6 AND GR7,H+0.13,'*!'),COLOR00FF00;
STICKLINE(GR6 AND GR7,H,H+0.09,4,0),COLOR00FF00;
DRAWTEXT(HR2 AND FILTER(HR2,10),L-0.08,'买推'),COLORFFC8FF;
STICKLINE(HR2 AND FILTER(HR2,10),H,L,0.5,1),COLORFFC8FF;
STICKLINE(HR2 AND FILTER(HR2,10),O,C,6,1),LINETHICK2,COLORFFC8FF;
MA11:=MA(CLOSE,10),COLORRED;
MA33:=MA(CLOSE,30),COLORYELLOW;
MA55:=MA(CLOSE,55),COLORBLUE;
年线:=MA(CLOSE,250),COLORGREEN;
Y:=(MA(C,11)-MA(C,55))/MA(C,11)*100;

通达信指标王之至尊操盘主图指标公式

 

相关文章