在线检测未来函数

通达信优化KDJ带K线指标公式

来源:Internet,编辑:股旁网,2010-11-09

VAR1:=SMA(MAX(OPEN-REF(OPEN,1),0),6,1)/SMA(ABS(OPEN-REF(OPEN,1)),6,1)*100;
VAR2:=SMA(MAX(CLOSE- REF(CLOSE,1),0),6,1)/SMA(ABS(CLOSE- REF(CLOSE,1)),6,1)*100;
VAR3:=SMA(MAX(HIGH-REF(HIGH,1),0),6,1)/SMA(ABS(HIGH-REF(HIGH,1)),6,1)*100;
VAR4:=SMA(MAX(LOW- REF(LOW,1),0),6,1)/SMA(ABS(LOW- REF(LOW,1)),6,1)*100;
VAR5:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
短:=SMA(VAR5,6,1),COLORWHITE;
中:=SMA(短,3,1),COLORYELLOW;
领先:=3*短-2*中,COLORLIMAGENTA;
{股旁网-股票公式网站 www.gupanG.com}
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:SMA(RSV,3,1);
D:SMA(K,3,1);
J:3*K-2*D;
DRAWKLINE(VAR3,VAR1,VAR4,VAR2);
STICKLINE(短>0 AND 短-中>=0,79,80,6,0),COLORRED;
STICKLINE(短>0 AND 短-中<0,79,80,6,0),COLORYELLOW;
STICKLINE(短>0 AND 短-中>=0,49,50,6,0),COLORRED;
STICKLINE(短>0 AND 短-中<0,49,50,6,0),COLORYELLOW;
STICKLINE(短>0 AND 短-中>=0,9,10,6,0),COLORRED;
STICKLINE(短>0 AND 短-中<0,9,10,6,0), COLORYELLOW;
顶:100, LINETHICK2 ,COLOR55AA77;
底:0, LINETHICK2 ,COLOR55AA77;

通达信优化KDJ带K线指标公式

 

相关文章