在线检测未来函数

通达信立体MACD指标公式

来源:Internet,编辑:股旁网,2010-11-09

A1:=100*(EMA(C,12)-EMA(C,26))/EMA(C,26);
A2:=EMA(A1,9);
MACD:(A1-A2)*2,NODRAW;
STICKLINE(MACD>=0 AND MACD>=REF(MACD,1),0,MACD,3,0),COLOR0000AA;{红色}
STICKLINE(MACD>=0 AND MACD>=REF(MACD,1),0,MACD,2,0),COLOR0000CC;
STICKLINE(MACD>=0 AND MACD>=REF(MACD,1),0,MACD,1,0),COLOR0000EE;
STICKLINE(MACD>=0 AND MACD>=REF(MACD,1),0,MACD,0.1,0),COLOR5555FF;
STICKLINE(MACD>=0 AND MACD>=REF(MACD,1),0,MACD,0,0),COLOR8080FF;
STICKLINE(MACD>=0 AND MACD<REF(MACD,1),0,MACD,3,0),COLOR770077;{紫色}
STICKLINE(MACD>=0 AND MACD<REF(MACD,1),0,MACD,2,0),COLOR990099;
{股旁网-股票公式网站 www.gupanG.com}
STICKLINE(MACD>=0 AND MACD<REF(MACD,1),0,MACD,1,0),COLORBB00BB;
STICKLINE(MACD>=0 AND MACD<REF(MACD,1),0,MACD,0,0),COLORDD00DD;
STICKLINE(MACD>=0 AND MACD<REF(MACD,1),0,MACD,0.1,0),COLORFF00FF;
STICKLINE(MACD<0 AND MACD>=REF(MACD,1),0,MACD,3,0),COLORFF0000;{蓝色}
STICKLINE(MACD<0 AND MACD>=REF(MACD,1),0,MACD,2,0),COLORFF5500;
STICKLINE(MACD<0 AND MACD>=REF(MACD,1),0,MACD,1,0),COLORFF9900;
STICKLINE(MACD<0 AND MACD>=REF(MACD,1),0,MACD,0,0),COLORFFFF00;
STICKLINE(MACD<0 AND MACD<REF(MACD,1),0,MACD,3,0),COLOR155500;{绿色}
STICKLINE(MACD<0 AND MACD<REF(MACD,1),0,MACD,2,0),COLOR208000;
STICKLINE(MACD<0 AND MACD<REF(MACD,1),0,MACD,1,0),COLOR2BAA00;
STICKLINE(MACD<0 AND MACD<REF(MACD,1),0,MACD,0.1,0),COLOR35D500;
STICKLINE(MACD<0 AND MACD<REF(MACD,1),0,MACD,0,0),COLOR40FF00;
DIF:A1,COLORWHITE;DEA:A2,COLORYELLOW;
DD:=EMA(EMA((C-LLV(L,10))/(HHV(H,10)-LLV(L,10))*100,3),3);
关注:IF(DD<30 AND MACD<0 AND MACD>=REF(MACD,1),MACD*0.5,DRAWNULL)CIRCLEDOT,COLORMAGENTA;
A3:=BARSLAST(REF(CROSS(DIF,DEA),1));
DRAWTEXT(REF(CLOSE,A3+1)>CLOSE AND DIF>REF(DIF,A3+1) AND CROSS(DIF,DEA),-3,'DB');
RSV:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
K:SMA(RSV,3,1)NODRAW,COLORYELLOW;
D:=SMA(K,3,1);
J:3*K-2*D,NODRAW,COLORYELLOW;

通达信立体MACD指标公式

 

相关文章