在线检测未来函数

通达信换手量能指标公式

来源:Internet,编辑:股旁网,2010-11-12

X1:=EMA(C,20);
X2:=REF(X1,1);
廿日均线斜率:(X1-X2)/X2*100,NODRAW;
JJ:=(HIGH+LOW+CLOSE)/3;
QJ0:=VOL/IF(HIGH=LOW,4,HIGH-LOW);
主买1:=(QJ0*(JJ-MIN(CLOSE,OPEN)));
主卖1:=(QJ0*(MIN(OPEN,CLOSE)-LOW));
散买:=(QJ0*(HIGH-MAX(OPEN,CLOSE)));
散卖:=(QJ0*(MAX(CLOSE,OPEN)-JJ));
PHD:=25;
SAT:=(AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20));
N:=11;
HSL:=VOL/CAPITAL*100;
量能:=SUM(HSL,N);
涨幅1:=100*(CLOSE-REF(CLOSE,N))/REF(CLOSE,N);
MA13:=MA(CLOSE,13);
MA75:=MA(CLOSE,75);
LC:=REF(C,1);
K9:=SMA((C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100,3,1);
D9:=SMA(K9,3,1);
J9:=3*K9-2*D9;
VAR1:=DYNAINFO(17)*REF(MA(V,5),1);
VAR2:=DYNAINFO(7)=C AND DYNAINFO(10)=AMOUNT;
VAR3:=IF(DYNAINFO(7)=C AND DYNAINFO(10)=AMOUNT,VAR1,VAR2);
预量:=IF(V>=VAR3 AND PERIOD=5,V,VAR3);
比:=预量/V;
买盘:=DYNAINFO(23)*比;
卖盘:=DYNAINFO(22)*比;
压力1:=MA(C,26)+2*STD(C,26);
YYY:=EMA((INDEXC-LLV(INDEXL,11))/(HHV(INDEXH,25)-LLV(INDEXL,11))*4,8)+1;
YY:=POW(YYY,2)-10;
XXX:=EMA((C-LLV(L,11))/(HHV(H,25)-LLV(L,11))*4,8)+1;
XX:=IF(1=1,POW(XXX,2)-10,DRAWNULL);
量能2:=SUM(HSL,3);
涨幅A:=(C-REF(C,3))/REF(C,3)*100;
流通市值:=CAPITAL*C;{流通市值相对越小,涨幅越大,相对越大,涨幅越小}
BB1:=REF(CLOSE,1);
BB2:=SMA(MAX(CLOSE-BB1,0),7,1)/SMA(ABS(CLOSE-BB1),7,1)*100;
CC1:=WINNER(CLOSE)*100;
CC2:=100-BB1;
CC3:=ABS(BB1-BB2);
TD:=BACKSET(ISLASTBAR,1);
NX:=IF(EMA(C,3)>MAX(EMA(C,13),EMA(C,55)),1,IF(EMA(C,3)<MIN(EMA(C,13),EMA(C,55)),-1,0));
DRAWBAND(100,RGB(50,50,0),0,RGB(0,0,0));
庄净入:IF((主买1-主卖1)>0,主买1-主卖1,0)/10000,COLORRED,NODRAW;
庄净出:IF((主买1-主卖1)<0,主买1-主卖1,0)/10000,COLORGREEN,NODRAW;
散净入:IF((散买-散卖)>0,散买-散卖,0)/10000,COLORGREEN,NODRAW;
散净出:IF((散买-散卖)<0,散买-散卖,0)/10000,COLORRED,NODRAW;
量能饱和度:IF(SAT>1,1,SAT)*100,COLORYELLOW,NODRAW;
预计换手:IF(DYNAINFO(7)=CLOSE AND DYNAINFO(10)=AMOUNT,MAX(VOL,DYNAINFO(17)*REF(MA(VOL,5),1))/CAPITAL*100,0),NODRAW;
十日换手平均:MA(HSL,10),NODRAW;
活跃度:IF(DATE>1000101,(MA(VOL,11)+MA(VOL,11*2)+MA(VOL,11*3)+MA(VOL,11*4))/4/CAPITAL*1000,1),NODRAW;
STICKLINE(TD,CC1,0,5,0 ),COLORRED;
STICKLINE(TD,CC2,0,3,0 ),COLORYELLOW;
STICKLINE(TD,CC3,0,1,0),COLORMAGENTA;
牛:IF(NX=1 AND V>1,12,0),LINETHICK4,COLORRED;
熊:STICKLINE(NX=-1 AND V>1,0,4,2,0)COLORYELLOW;
马:STICKLINE(NX=0 AND V>1,0,4,2,0)COLORMAGENTA;
STICKLINE(NX=1 AND V>1,0,4,2,0),COLORRED;
STICKLINE(CURRBARSCOUNT=PHD,30*1.9,30*1.5,100,1),COLOR00DDDD;
STICKLINE(CLOSE>OPEN AND CURRBARSCOUNT=PHD,30*1.88,30*1.52,量能饱和度,0),COLOR0033FF;
STICKLINE(CLOSE>OPEN AND CURRBARSCOUNT=PHD,30*1.82,30*1.58,量能饱和度,0),COLOR0077FF;
STICKLINE(CLOSE>OPEN AND CURRBARSCOUNT=PHD,30*1.76,30*1.64,量能饱和度,0),COLOR0099FF;
STICKLINE(CLOSE>OPEN AND CURRBARSCOUNT=PHD,30*1.7,30*1.7,量能饱和度,0),COLOR00DDFF;
STICKLINE(CLOSE<OPEN AND CURRBARSCOUNT=PHD,30*1.88,30*1.52,量能饱和度,0),COLORFF7700;
STICKLINE(CLOSE<OPEN AND CURRBARSCOUNT=PHD,30*1.82,30*1.58,量能饱和度,0),COLORFF9900;
STICKLINE(CLOSE<OPEN AND CURRBARSCOUNT=PHD,30*1.76,30*1.64,量能饱和度,0),COLORFFBB00;
STICKLINE(CLOSE<OPEN AND CURRBARSCOUNT=PHD,30*1.71,30*1.69,量能饱和度,0),COLORCYAN;
{股旁网-股票公式网站 www.gupanG.com}
DRAWTEXT(HSL<=2 AND ISLASTBAR,50,' 少人关注');
DRAWTEXT(HSL>2 AND HSL<3 AND ISLASTBAR,50,' 成交温和');
DRAWTEXT(HSL>3 AND HSL<5 AND ISLASTBAR,50,' 交投活跃');
DRAWTEXT(HSL>5 AND HSL<8 AND ISLASTBAR,50,' 带量');
DRAWTEXT(HSL>8 AND HSL<15 AND ISLASTBAR,50,' 放量');
DRAWTEXT(HSL>15 AND HSL<25 AND ISLASTBAR,50,' 巨量');
DRAWTEXT(HSL>=25 AND ISLASTBAR,50,' 成交怪异');
DRAWTEXT(量能>3*N AND 涨幅1>3*N AND ISLASTBAR,30,' 继续大涨');
DRAWTEXT(量能<0.5*N AND 涨幅1<N AND ISLASTBAR,30,' 继续小涨');
DRAWTEXT(量能<0.5*N AND 涨幅1>-N AND 涨幅1>0 AND ISLASTBAR,10,' 继续小跌');
DRAWTEXT(量能>3*N AND 涨幅1<-3*N AND ISLASTBAR,30,' 继续大跌');
DRAWTEXT(((量能>3*N AND 涨幅1<N) OR (量能<0.5*N AND 涨幅1>3*N)OR (量能>3*N AND 涨幅1>-N AND 涨幅1<0) OR (量能<0.5*N AND 涨幅1<-3*N))AND ISLASTBAR,5,' 注意反转');
STICKLINE(CURRBARSCOUNT=53 ,100,0,88,0),COLOR333344;
DRAWTEXT(V/CAPITAL>0.075 AND CURRBARSCOUNT=59,80,'换手过大,小心主力出逃,短期头部'),COLORFFFF00;
DRAWTEXT(涨幅A>0 AND CURRBARSCOUNT=59,90,'流通市值减小,涨幅加大');
DRAWTEXT(涨幅A<=0 AND CURRBARSCOUNT=59,90,'流通市值加大,涨幅减小');
DRAWTEXT(CURRBARSCOUNT=59,60,'牛大于马,则后市见顶的概率较大'),COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=59,50,'熊大于马,则后市见底或有反弹概率较大'),COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=59,40,'股态: 红色=牛 黄色=熊 洋红色=马'),COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=59,20,'斜率大胜率越大,>1.5胜率超7成, <0.3可买跌'),COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=59,10,'斜率0.5-1要选热门,1-1.5选活跃股胜率较大'),COLORGREEN;
DRAWTEXT(活跃度>=41 AND ISLASTBAR,80,' 热门股'),COLORGREEN;
DRAWTEXT(活跃度>20 AND 活跃度<=40 AND ISLASTBAR,80,' 活跃股'),COLORGREEN;
DRAWTEXT(活跃度<=20 AND ISLASTBAR,80,' 冷门股'),COLORGREEN;

通达信换手量能指标公式

 

相关文章