在线检测未来函数

通达信心爱变色MAKDJ指标公式

来源:Internet,编辑:股旁网,2010-11-15

M5:=MA(C,5);
五日乖离:(CLOSE/M5-1)*100,NODRAW;
上乖离:=(HIGH/M5-1)*100,NODRAW,COLORCYAN;
下乖离:=(LOW/M5-1)*100,NODRAW,COLORRED;
KX:=CROSS(CLOSE,M5);
XFX:=REF(LOW,1)=LLV(LOW,13) AND REF(CLOSE,1)=LLV(CLOSE,13)
AND REF(VOL,1)<MA(VOL,13);
下分形:IF(XFX,-0.5,-1),COLORYELLOW;
M:=BARSLAST(XFX);
买:IF(KX AND M<=5,-0.5,-1),COLORRED;
SFX:=REF(HIGH,1)=HHV(HIGH,13) AND REF(CLOSE,1)=HHV(CLOSE,13)
AND REF(VOL,1)>MA(VOL,13);
KX1:=CROSS(M5,CLOSE);
M1:=BARSLAST(SFX);
上分形:IF(SFX,0.5,1),COLORGREEN;
{股旁网-股票公式网站 www.gupanG.com}
卖:IF(KX1 AND M1<=5,0.5,1),COLORCYAN;
MCD:"MACD.MACD"*2,COLORSTICK,COLORLIRED;
DIF:="MACD.DIF";
STICKLINE(DIF>0 AND MCD>0,MCD,0,0.01,0),COLORRED;
STICKLINE(DIF>0 AND MCD<0,MCD,0,0.01,0),COLORCYAN;
{变色KDJ 分段线源码};
{变色KDJ 分段线源码}
RSV:=(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*2-1;
K:SMA(RSV,3,1),COLORWHITE;
D:SMA(K,3,1),COLORYELLOW;
J:3*K-2*D,COLORYELLOW;
A:=BARSLAST(WEEKDAY-REF(WEEKDAY,1)<0);
B:=IF(WEEKDAY=5,CLOSE,REF(CLOSE,A+1));
X:=IF(B!=REF(B,1),B,DRAWNULL);
周末收:B,NODRAW,COLORWHITE;
IF(K<REF(K,1),K,DRAWNULL),COLORGREEN,LINETHICK1;
IF(D<REF(D,1),D,DRAWNULL),COLORGREEN,LINETHICK1;
IF(J<REF(J,1),J,DRAWNULL),COLORFFFF00,LINETHICK1;
IF(K>REF(K,1),K,DRAWNULL),COLORRED,LINETHICK1;
IF(D>REF(D,1),D,DRAWNULL),COLORRED,LINETHICK1;
IF(J>REF(J,1),J,DRAWNULL),COLORFF00FF,LINETHICK1;

通达信心爱变色MAKDJ指标公式

 

相关文章