在线检测未来函数

通达信主力能量指标公式

来源:Internet,编辑:股旁网,2010-11-20

V1:=DMA((((HIGH + LOW) + (CLOSE * 2)) / 4.15),0.9);
HY1:=REF(EMA(V1,3),1);
主力:=MA(CLOSE,1),COLOR006400;
大户:=HY1,COLOR400080;
中户:=MA(HY1,17);
散户:=MA(HY1,34);
多空趋势:=(MA((CLOSE - HY1)*10,2))*0.1;
{股旁网-股票公式网站 www.gupanG.com}
操盘4:STICKLINE(多空趋势>=0 AND 多空趋势>=REF(多空趋势,1),6,6+多空趋势,1,0),COLORRED;
减仓4:STICKLINE(多空趋势>=0 AND 多空趋势< REF(多空趋势,1),6,6+多空趋势,3,0),COLOR0D06AA;
减仓5:STICKLINE(多空趋势>=0 AND 多空趋势< REF(多空趋势,1),6,6+多空趋势,2,0),COLOR2108C1;
减仓6:STICKLINE(多空趋势>=0 AND 多空趋势< REF(多空趋势,1),6,6+多空趋势,1,0),COLORRED;
DRAWTEXT(ISLASTBAR=1,IF(多空趋势>=0,6,6.3),'主力'),COLORMAGENTA;
反弹3:STICKLINE(多空趋势<0 AND 多空趋势>=REF(多空趋势,1),6,6+多空趋势,3,0),COLOR00AA00;
反弹4:STICKLINE(多空趋势<0 AND 多空趋势>=REF(多空趋势,1),6,6+多空趋势,2,0),COLOR40FF00;
反弹5:STICKLINE(多空趋势<0 AND 多空趋势>=REF(多空趋势,1),6,6+多空趋势,1,0),COLORMAGENTA;
寻底2:STICKLINE(多空趋势<0 AND 多空趋势< REF(多空趋势,1),6,6+多空趋势,3,0),COLOR1B7411;
寻底3:STICKLINE(多空趋势<0 AND 多空趋势< REF(多空趋势,1),6,6+多空趋势,2,0),COLOR17A715;
寻底4:STICKLINE(多空趋势<0 AND 多空趋势< REF(多空趋势,1),6,6+多空趋势,1,0),COLOR40FF00;
DRAWTEXT(ISLASTBAR=1,IF(多空趋势>=0,6,6.3),'多空'),NODRAW;
均量:=(主力+大户+中户+散户)/4;
主力能量:(主力-均量)COLORRED,NODRAW;
大户量:(大户-均量)COLORMAGENTA,NODRAW;
中户量:(中户-均量)COLORYELLOW,NODRAW;
散户量:(散户-均量),NODRAW;
操盘A:STICKLINE(多空趋势>=0 AND 多空趋势>=REF(多空趋势,1),4.5,4.5+多空趋势,2,0),COLOR440044;
操盘B:STICKLINE(多空趋势>=0 AND 多空趋势>=REF(多空趋势,1),4.5,4.5+多空趋势,1,0),COLORFF00FF;
反弹A:STICKLINE(多空趋势>=0 AND 多空趋势< REF(多空趋势,1),4.5,4.5+多空趋势,3,0),COLOR00CC20;
反弹B:STICKLINE(多空趋势>=0 AND 多空趋势< REF(多空趋势,1),4.5,4.5+多空趋势,2,0),COLOR08D306;
反弹C:STICKLINE(多空趋势>=0 AND 多空趋势< REF(多空趋势,1),4.5,4.5+多空趋势,1,0),COLOR40FF00;
减仓:STICKLINE(多空趋势<0 AND 多空趋势>=REF(多空趋势,1),4.5,4.5+多空趋势,1,0),COLOR00CCCC;
寻底:STICKLINE(多空趋势<0 AND 多空趋势< REF(多空趋势,1),4.5,4.5+多空趋势,1,0),COLORFF9900;
DRAWTEXT(ISLASTBAR=1,IF(多空趋势>=0,4.2,4.8),'机构'),COLORRED;
操盘1:STICKLINE(主力能量>=0 AND 主力能量>=REF(主力能量,1),3,3+主力能量,1,0),COLORRED;
减仓1:STICKLINE(主力能量>=0 AND 主力能量< REF(主力能量,1),3,3+主力能量,1,0),COLOR00CC20;
反弹1:STICKLINE(主力能量<0 AND 主力能量>=REF(主力能量,1),3,3+主力能量,1,0),COLOR00CCCC;
寻底1:STICKLINE(主力能量<0 AND 主力能量< REF(主力能量,1),3,3+主力能量,1,0),COLORFF9900;
DRAWTEXT(ISLASTBAR=1,IF(主力能量>=0,2.7,3.3),'大户'),COLORMAGENTA;
操盘2:STICKLINE(大户量>=0 AND 大户量>=REF(大户量,1),1.5,1.5+大户量,1,0),COLORRED;
反弹2:STICKLINE(大户量>=0 AND 大户量< REF(大户量,1),1.5,1.5+大户量,1,0),COLOR00CC20;
减仓2:STICKLINE(大户量<0 AND 大户量>=REF(大户量,1),1.5,1.5+大户量,3,0),COLOR00CCCC;
寻底0:STICKLINE(大户量<0 AND 大户量< REF(大户量,1),1.5,1.5+大户量,1,0),COLORFF9900;
DRAWTEXT(ISLASTBAR=1,IF(中户量>=0,1.2,1.8),'中户'),COLORYELLOW;

通达信主力能量指标公式

 

相关文章