在线检测未来函数

通达信跟庄MACD指标公式

来源:Internet,编辑:股旁网,2010-11-24

STICKLINE(C>0,-100,200,8,0),COLOR444444;
N:=1.5;
M:=3;
P:=64;
DIFF:=EMA((EMA(CLOSE,N*12)-EMA(CLOSE,N*26))/EMA(CLOSE,N*26)*1000,M);
DEA:=EMA(DIFF,N*9),COLOR000088;
MACD:=2*(DIFF-DEA);
MACDX:=MACD;
MACDO:=EMA(MACD,5),COLORFF77FF;
DIFFO:=EMA(DEA,P)*1.8;
B:=MACD-REF(MACD,1);
(MACD>0 AND B>0,0,MACD,0,1),COLOR0000CD;
STICKLINE(MACD>0 AND B<0,0,MACD,0,0),COLOR0000CD;
{股旁网-股票公式网站 www.gupanG.com}
STICKLINE(MACD<0 AND B>0,0,MACD,0,1),COLORCYAN;
STICKLINE(MACD<0 AND B<0,0,MACD,0,0),COLORCYAN;
STICKLINE(DIFF>DEA,DIFF,DEA,4,0),COLOR0089FF;
STICKLINE(DIFF<DEA,DIFF,DEA,4,0),COLORBLUE;
发现机构入场:IF(DIFF>=REF(DIFF,1) AND DEA<REF(DEA,1),DIFF,DRAWNULL),COLOR00C500,LINETHICK4;
短线出局:IF(DIFF<REF(DIFF,1) AND DEA>REF(DEA,1),DIFF,DRAWNULL),COLORYELLOW,LINETHICK4;
IF(DIFF>=REF(DIFF,1) AND DEA>REF(DEA,1),DIFF,DRAWNULL),COLORGRAY;
IF(DIFF<REF(DIFF,1) AND DEA<REF(DEA,1),DIFF,DRAWNULL),COLORBLUE;
IF(DIFFO>=REF(DIFFO,1),DIFFO,DRAWNULL),COLORYELLOW;
IF(DIFFO=REF(DIFFO,1),DIFFO,DRAWNULL),COLORYELLOW;
IF(DIFFO<REF(DIFFO,1),DIFFO,DRAWNULL),COLORMAGENTA;
DRAWTEXT(C=C AND CURRBARSCOUNT=150,180,'操作:蓝转绿试买;见橙加仓;维持橙持股'),COLOR008987;
DRAWTEXT(C=C AND CURRBARSCOUNT=150,150,'橙转黄减仓;蓝色空仓'),COLOR008987;

通达信跟庄MACD指标公式

 

相关文章