在线检测未来函数

飞狐均线+筹码堆积主图指标公式

来源:Internet,编辑:股旁网,2010-11-26

DRAWGBK(DATE>900101,COLORRGB(95,95,95),COLORRGB(0,0,0),1);
a0:=BARSCOUNT(c);
a3:=SYSPARAM(3);
a2:=SYSPARAM(2);
a4:=SYSPARAM(4);
a5:=SYSPARAM(5);
nn0:=a3-a2;nn:=a0-a2;hh1:=(a4-a5)/8;
hh2:=hh1/4;
ll1:=llv(l,nn0);ll2:=ll1[a3];
y0:=a0>=a2;vv0:=if(y0=1 and SYSPARAM(1)>=a0,v,0);
c1:=if(BETWEEN(c,a4-0*hh1,a4-1*hh1),vv0,0);
c2:=if(BETWEEN(c,a4-1*hh1,a4-2*hh1),vv0,0);
c3:=if(BETWEEN(c,a4-2*hh1,a4-3*hh1),vv0,0);
c4:=if(BETWEEN(c,a4-3*hh1,a4-4*hh1),vv0,0);
c5:=if(BETWEEN(c,a4-4*hh1,a4-5*hh1),vv0,0);
c6:=if(BETWEEN(c,a4-5*hh1,a4-6*hh1),vv0,0);
c7:=if(BETWEEN(c,a4-6*hh1,a4-7*hh1),vv0,0);
c8:=if(BETWEEN(c,a4-7*hh1,a4-8*hh1),vv0,0);
c9:=if(BETWEEN(c,a4-8*hh1,a4-9*hh1),vv0,0);
c10:=if(BETWEEN(c,a4-9*hh1,a4-10*hh1),vv0,0);
v1:=STRTONUM(NUMTOSTR(if(ISLASTBAR,sum(c1,nn0),0),2)),LINETHICK;
v2:=STRTONUM(NUMTOSTR(if(ISLASTBAR,sum(c2,nn0),0),2));
v3:=STRTONUM(NUMTOSTR(if(ISLASTBAR,sum(c3,nn0),0),2));
v4:=STRTONUM(NUMTOSTR(if(ISLASTBAR,sum(c4,nn0),0),2));
v5:=STRTONUM(NUMTOSTR(if(ISLASTBAR,sum(c5,nn0),0),2));
v6:=STRTONUM(NUMTOSTR(if(ISLASTBAR,sum(c6,nn0),0),2));
v7:=STRTONUM(NUMTOSTR(if(ISLASTBAR,sum(c7,nn0),0),2));
v8:=STRTONUM(NUMTOSTR(if(ISLASTBAR,sum(c8,nn0),0),2));
v9:=STRTONUM(NUMTOSTR(if(ISLASTBAR,sum(c9,nn0),0),2));
v10:=STRTONUM(NUMTOSTR(if(ISLASTBAR,sum(c10,nn0),0),2));
av0:=max(v1,max(v2,max(v3,max(v4,max(v5,max(v6,max(v7,max(v8,max(v9,v10)))))))));
x1:=v1/av0>=nn/nn0 and nn>=0;
x2:=v2/av0>=nn/nn0 and nn>=0;
x3:=v3/av0>=nn/nn0 and nn>=0;
x4:=v4/av0>=nn/nn0 and nn>=0;
x5:=v5/av0>=nn/nn0 and nn>=0;
x6:=v6/av0>=nn/nn0 and nn>=0;
x7:=v7/av0>=nn/nn0 and nn>=0;
x8:=v8/av0>=nn/nn0 and nn>=0;
FILLRGN(v1/av0>=nn/nn0 and nn>=0,a4-0*hh1,a4-1*hh1+hh1*0.5),Color003CB7;
FILLRGN(v2/av0>=nn/nn0 and nn>=0,a4-1*hh1,a4-2*hh1+hh1*0.5),Color808000;
FILLRGN(v3/av0>=nn/nn0 and nn>=0,a4-2*hh1,a4-3*hh1+hh1*0.5),Color8B4D43;
FILLRGN(v4/av0>=nn/nn0 and nn>=0,a4-3*hh1,a4-4*hh1+hh1*0.5),Color1B3D70;
FILLRGN(v5/av0>=nn/nn0 and nn>=0,a4-4*hh1,a4-5*hh1+hh1*0.5),Color00AEAE;
FILLRGN(v6/av0>=nn/nn0 and nn>=0,a4-5*hh1,a4-6*hh1+hh1*0.5),color666666;
FILLRGN(v7/av0>=nn/nn0 and nn>=0,a4-6*hh1,a4-7*hh1+hh1*0.5),color666666;
FILLRGN(v8/av0>=nn/nn0 and nn>=0,a4-7*hh1,a4-8*hh1+hh1*0.5),color666666;
DRAWNUMBER(FILTER(refx(x1<ref(x1,1),6) and v1>0,10),a4,a4-0*hh1,2),COLOR00FF00;
DRAWNUMBER(FILTER(refx(x2<ref(x2,1),6) and v2>0,10),(a4-1*hh1),a4-1*hh1,2),COLOR00FF00;
DRAWNUMBER(FILTER(refx(x3<ref(x3,1),6) and v3>0,10),(a4-2.7*3*hh2),a4-2*hh1,2),COLOR00FF00;
DRAWNUMBER(FILTER(refx(x4<ref(x4,1),6) and v4>0,10),(a4-12*hh2),a4-3*hh1,2),COLOR00FF00;
DRAWNUMBER(FILTER(refx(x5<ref(x5,1),6) and v5>0,10),(a4-16*hh2),a4-4*hh1,2),COLOR00FF00;
DRAWNUMBER(FILTER(refx(x6<ref(x6,1),6) and v6>0,10),(a4-20*hh2),a4-5*hh1,2),COLOR00FF00;
DRAWNUMBER(FILTER(refx(x7<ref(x7,1),6) and v7>0,10),(a4-24*hh2),a4-6*hh1,2),COLOR00FF00;
DRAWNUMBER(FILTER(refx(x8<ref(x8,1) and v8>0,5),10),ll2+1*4*hh2,a4-7*hh1,2),COLOR00FF00;
指导线:= EMA((EMA(C,4)+EMA(C,6)+EMA(C,12)+EMA(C,24))/4,2),linethick0,Color00ffFF,LINEDOT;
界:= MA(CLOSE,21),linethick0,ColorFEBAF5;
上限: 界+3*STD(C,20),linethick0,Color00FFFF;
卖: 界+2*STD(C,20),linethick0,ColorFF00FF;
买: 界-2*STD(C,20),linethick0,ColorF0FF00;
下限: 界-2.9*STD(close,20),linethick0,Color00FF00;
DRAWICON(H>=上限,h,10),ALIGN0,pxup15;
DRAWICON(cross(H,上限),h,12),ALIGN0;
DRAWTEXT(cross(H,上限),H,' ̄'),ALIGN0,Color00ffff;
DRAWICON(cross(上限,H),h,5),ALIGN0;
DRAWTEXT(cross(上限,H),H,' ̄'),ALIGN0,Color00ffff;
DRAWICON(cross(H,卖),h,5),ALIGN0;
DRAWTEXT(cross(H,卖),H,' ̄'),ALIGN0,Colorff00ff;
DRAWTEXT(cross(C,卖),H,' ̄'),ALIGN0,Colorff0000;
DRAWICON(cross(C,卖),h,5),ALIGN0;
DRAWTEXT(cross(下限,L),l,'跟'),ALIGN0,Color00ff00;
DRAWTEXT(cross(下限,L),l,' ̄'),ALIGN0,Color00ff00;
DRAWTEXT(cross(买,L),l,'△'),ALIGN0,Colorffff00;
DRAWTEXT(cross(买,L),l,' ̄'),ALIGN0,Colorffff00;
DRAWTEXT(cross(买,C),L,'▲'),ALIGN0,Colorffff00;
DRAWTEXT(cross(买,C),L,' ̄'),ALIGN0,Colorffff00;
STICKLINE(C>=O,C,O,7,0),COLOR0000AA;
STICKLINE(C>=O,C,O,6,0),COLOR0000bb ;
STICKLINE(C>=O,C,O,5,0),COLOR0000cc;
STICKLINE(C>=O,C,O,4,0),COLOR0000DD ;
STICKLINE(C>=O,C,O,3,0),COLOR0000ee;
STICKLINE(C>=O,C,O,2,0),COLOR0000FF;
STICKLINE(C>=O,C,O,1,0),COLOR0000ff;
STICKLINE(C>=O,H,L,0,0),COLORRED;
STICKLINE(C<=O,C,O,7,0),Coloraaaa00;
STICKLINE(C<=O,C,O,6,0),Colorbbbb00;
STICKLINE(C<=O,C,O,5,0),Colorcccc00;
STICKLINE(C<=O,C,O,4,0),Colordddd00;
STICKLINE(C<=O,C,O,3,0),Coloreeee00;
STICKLINE(C<=O,C,O,2,0),COLORffff00;
STICKLINE(C<=O,C,O,1,0),Colorffff00;
STICKLINE(C<=O,H,L,0,0),COLORffff00;
STICKLINE(c/ref(c,1)>1.05,(c+o)/2,c,7,0),color00AAAA;
STICKLINE(c/ref(c,1)>1.05,(c+o)/2,c,5,0),color00CCCC;
STICKLINE(c/ref(c,1)>1.05,(c+o)/2,c,3,0),color00EEEE;
STICKLINE(c/ref(c,1)>1.05,(c+o)/2,c,1,0),coloryellow;//当涨幅大于3--5%,要主图K线的实体的一半变为另一色。
DH:=(((CLOSE - REF(CLOSE,1)) / REF(CLOSE,1)) * 100);
STICKLINE(DH<=-4,(c+o)/2,c,7,0),colorAA0000;
STICKLINE(DH<=-4,(c+o)/2,c,5,0),colorCC0000;
STICKLINE(DH<=-4,(c+o)/2,c,3,0),colorEE0000;
STICKLINE(DH<=-4,(c+o)/2,c,1,0),colorFF0000;//当跌幅大于3-4-5%,要主图K线的实体的一半变为另一色。
Mb5:MA(CLOSE,5),ColorFFFfff,linethick1;
Mb10:MA(CLOSE,10),Color00Ffff,linethick1;
Mb20:MA(CLOSE,20),Color00ff00,linethick1;
Mb30:MA(CLOSE,30),Colorff00ff,linethick1;
VAR1:=(100 - ((90 * (HHV(HIGH,21) - CLOSE)) / (HHV(HIGH,21) - LLV(LOW,21))));
VAR2:=(100 - ((90 * (HHV(HIGH,21) - CLOSE)) / (HHV(HIGH,21) - LLV(LOW,21))));
VAR3:=(100 - MA(((100 * (HHV(HIGH,6) - CLOSE)) / (HHV(HIGH,6) - LLV(LOW,6))),34));
DRAWICON(CROSS(VAR2,MA(VAR3,6)),(LOW * 0.998),4);
DRAWICON(CROSS(MA(VAR3,6),VAR1),(HIGH * 1.013),5);
DRAWTEXT(CROSS(VAR2,MA(VAR3,6)),(LOW * 0.98),'B '),color4440FF;
DRAWTEXT(CROSS(MA(VAR3,6),VAR1),(HIGH * 1.016),'S '),colorFFFF34;
x6:=REF(CLOSE,1);
x7:=SMA(MAX(CLOSE-x6,0),7,1)/SMA(ABS(CLOSE-x6),7,1)*100;
x8:=CROSS(79,x7);
x9:=FILTER(x8,4);
DRAWTEXT(x9,HIGH*1.02,'←出货'),Color9000F5;
{股旁网-股票公式网站 www.gupanG.com}
MTM:=C-REF(C,1);
DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);
买:=IF(LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2)),1,0);
DRAWTEXT(filter(买=1,5),LOW-0.03,'。买'),COLORRED;
均价:=(CLOSE+HIGH+LOW+LOW)/4;
p:=EMA(均价,9);
q:=EMA(REF(p,1),3);
换手:=1000*vol/capital;
close3:=ref(close,3);
close5:=ref(close,5);
close7:=ref(close,7);
close8:=ref(close,8);
close13:=ref(close,13);
close21:=ref(close,21);
jc:=(ref(c,3)+ref(c,5)+ref(c,7)+ref(c,8)+ref(c,13)+ref(c,21))/6;
参考价:=sma(jc,5,1),colorffccff;
aa:=if(c>=ref(c,3),1,0);
bb:=if(c>=ref(c,5),1,0);
cc:=if(c>=ref(c,7),1,0);
dd:=if(c>=ref(c,8),1,0);
ee:=if(c>=ref(c,13),1,0);
ff:=if(c>=ref(c,21),1,0);
gz2:=aa+bb+cc+dd+ee+ff;
s:=ma(c,1);
DRAWNUMBER(c>0,s,gz2,0),colorwhite;{ffccff}

飞狐均线+筹码堆积主图指标公式

 

相关文章