在线检测未来函数

通达信MACD庄家抬轿指标公式

来源:Internet,编辑:股旁网,2010-11-30

JH:=VOL*CLOSE;
JHO:=SUM(JH,2)/SUM(VOL,2);
JH0:=EMA(JHO,10);
AAA:=(JHO-JH0)*20/JHO;
超:=STICKLINE(AAA>0 AND AAA>=REF(AAA,1),0,AAA,3,0),COLORLIRED;
级:=STICKLINE(AAA>0 AND AAA<REF(AAA,1),0,AAA,3,1),COLORLIRED;
好:=STICKLINE(AAA<0 AND AAA>=REF(AAA,1),0,AAA,3,1),COLORGREEN;
的:=STICKLINE(AAA<0 AND AAA<REF(AAA,1),0,AAA,3,0),COLORGREEN;
公:=EMA(IF(AAA>0 AND AAA<REF(AAA,1),0,AAA),3);
式:=CROSS(REF(公,1),公) AND 公>0;
谢:=EMA(IF(AAA<0 AND AAA<REF(AAA,1),0,AAA),3);
了:=CROSS(REF(谢,1),谢) AND 谢<0;
必买:=CROSS(C,DRAWLINE(HIGH>=HHV(HIGH,30),HIGH,LOW<=LLV(LOW,10),HHV(HIGH,6),1));
WY1001:=(2*CLOSE+HIGH+LOW)/4;
WY1002:=EMA(WY1001,4);
WY1003:=EMA(WY1002,4);
WY1004:=EMA(WY1003,4);
X:=(WY1004-REF(WY1004,1))/REF(WY1004,1)*2000;
X1:=IF(X<REF(X,1),X,DRAWNULL),COLORWHITE,LINETHICK2;
XO:=MA(X,2),COLOR9932CD;
SI:=REF(X,1);
STICKLINE(X>SI,X,SI,2.3,0),COLOR0000FF;
STICKLINE(X>SI,X,SI,0.3,0),COLORCC66FF;
STICKLINE(X<SI,X,SI,2.3,0),COLOR00BB00;
STICKLINE(X<SI,X,SI,0.3,0),COLOR00FF00;
STICKLINE(式,X,SI,2.15,0),COLOR545454;
STICKLINE(了,X,SI,2.15,0),COLORDB7093;
VAR1:=EMA(EMA(CLOSE,9),9);
控盘:=(VAR1-REF(VAR1,1))/REF(VAR1,1)*1000;
STICKLINE(控盘<0,控盘,0,3,0),COLORWHITE;
AA1:=CROSS(控盘,0);
无庄控盘:IF(控盘<0,控盘,0),COLORWHITE,NODRAW;
轻度控盘:STICKLINE(控盘<0 AND 0.9*控盘>REF(控盘,1),控盘,0,3,0),COLORYELLOW;
轻度出货:STICKLINE(控盘<0 AND 1.1*控盘<REF(控盘,1),控盘,0,3,0),COLORFFFF79;
开始控盘:=IF(AA1,5,0),LINETHICK1,COLORYELLOW;
有庄控盘:IF(控盘>REF(控盘,1) AND 控盘>0,控盘,0),COLORRED,NODRAW;
STICKLINE(控盘>REF(控盘,1) AND 控盘>0,控盘,0,3,0),COLORRED;
{股旁网-股票公式网站 www.gupanG.com}
VAR2:=100*WINNER(CLOSE*0.95);
高度控盘:IF(VAR2>50 AND COST(85)<CLOSE AND 控盘>0,控盘,0),COLORFF00FF,NODRAW;
STICKLINE(VAR2>50 AND COST(85)<CLOSE AND 控盘>0,控盘,0,3,0),COLORFF00FF;
主力出货:IF(控盘<REF(控盘,1) AND 控盘>0,控盘,0),COLOR00FF00,NODRAW;
STICKLINE(控盘<1.2*REF(控盘,1) AND 控盘>0,控盘,0,3,0),COLOR00FF00;
DIF1:=EMA(DCLOSE,12)-EMA(DCLOSE,26);
DEA1:=EMA(DIF1,9);
{柱状线}
MACD1:=(DIF1-DEA1)*2*60;
MACD上:IF(MACD1>REF(MACD1,1),MACD1,DRAWNULL),
STICK,COLORRED,LINETHICK1;
MACD下:IF(MACD1<REF(MACD1,1),MACD1,DRAWNULL),
STICK,COLORFF9900,LINETHICK1;
{买点提示}
A1:=BARSLAST(REF(CROSS(DIF1,DEA1),1));
BL:=REF(CLOSE,A1+1)>CLOSE AND DIF1>REF(DIF1,A1+1) AND CROSS(DIF1,DEA1);
{STICKLINE(BL,0,1,2,0),COLOR00FF00;}
买点:DRAWICON(BL,DEA1,23);
A2:=BARSLAST(REF(CROSS(DEA1,DIF1),1));
DBL:=REF(CLOSE,A2+1)<CLOSE AND REF(DIF1,A2+1)>DIF1 AND CROSS(DEA1,DIF1);
买点1:DRAWICON(DBL,DEA1,12);
低位金叉:=CROSS(DIF1,DEA1) AND DIF1<-0.1;
DRAWTEXT(低位金叉,-0.36,' 低位金叉');
JCCOUNT:=COUNT(CROSS(DIF1,DEA1),BARSLAST(DEA1>=0));
二次金叉:=CROSS(DIF1,DEA1) AND DEA1<0 AND COUNT(JCCOUNT=2,21)=1;
DRAWICON(二次金叉,DEA1*1.04,13) ;
DRAWTEXT(二次金叉,-0.22,' 二次金叉'),COLORFF00FF;
A10:=BARSLAST(REF(CROSS(DIF1,DEA1),1));
背离:=REF(CLOSE,A10+1)>CLOSE AND DIF1>REF(DIF1,A10+1) AND CROSS(DIF1,DEA1);
DRAWLINE(A10=0,DEA1,底背离,DEA1,0),COLORRED,LINETHICK2;
DRAWTEXT(底背离,-0.50,' 底背离'),COLOR00FF00;
A20:=BARSLAST(REF(CROSS(DEA1,DIF1),1));
顶背离:=REF(CLOSE,A20+1)<CLOSE AND REF(DIF1,A20+1)>DIF1 AND CROSS(DEA1,DIF1);
DRAWLINE(A20=0,DEA1,顶背离,DEA1,0),COLORWHITE,LINETHICK2;
{STICKLINE(底背离,X,SI,1,0),COLORYELLOW;}
STICKLINE(低位金叉,X,SI,1,0),COLORWHITE;
STICKLINE(必买,X,(X+SI)/2,2.3,0),COLORFF9900;
STICKLINE(必买,X,(X+SI)/2,0.1,0),COLORWHITE;
STICKLINE(低位金叉 AND 底背离,X,(X+SI)/2,2.3,0),COLORYELLOW;
STICKLINE(低位金叉 AND 底背离,X,(X+SI)/2,0.1,0),COLORCC66FF;
STICKLINE(二次金叉,X,SI,2.0,0),COLORYELLOW;
{主力进场}
VAR12:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);
VAR13:=SMA(ABS(LOW-VAR12),13,1)/SMA(MAX(LOW-VAR12,0),10,1);
VAR14:=EMA(VAR13,10);
VAR15:=LLV(LOW,33);
VAR16:=EMA(IF(LOW<=VAR15,VAR14,0),3);
主力进场:=IF(VAR16>REF(VAR16,1),VAR16,0),COLORRED,NODRAW;
STICKLINE(主力进场,X,SI,0.1,0),COLORRED;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1),COLORWHITE;
D:=SMA(K,3,1),COLORYELLOW;
J:=3*K-2*D,COLORFF00FF;
X3:=LLV(J,2)=LLV(J,8);
A:=250;
JH1:=HHV(MAX(K,MAX(D,J)),A);
DH:=HHV(MAX(DIF1,DEA1),A);
SH:=INTPART(JH1/DH)/2;
DIFF50:=SH*DIF1+50,COLORFFFF00;
DEA50:=SH*DEA1+50,COLORBLUE;
诱空:=IF(1.5*(DIFF50-DEA50)>0 AND REF(1.5*(DIFF50-DEA50),1)< REF(1.5*(DIFF50-DEA50),2) AND 1.5*(DIFF50-DEA50)>REF(1.5*(DIFF50-DEA50),1),1,0);
低位:=CROSS(J,REF(J+0.01,1)) AND X3 AND J<19;
MTM:=C-REF(C,1);
DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);
值:=LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2));
DRAWTEXT(FILTER(诱空,3) AND 诱空,X,'洗盘'),COLOR00FF00;

通达信MACD庄家抬轿指标公式庄家抬轿指标公式

 

相关文章