在线检测未来函数

通达信台湾力道K线主图指标公式

来源:Internet,编辑:股旁网,2010-11-30

X1:=(CLOSE+LOW+HIGH)/3;
X2:=EMA(X1,6);
X3:=EMA(X2,5);
VAR2:=EMA(EMA(X1,1),13);
VAR3:=EMA(VAR2,21);
XCLOSE:=EMA((OPEN+HIGH+LOW+CLOSE)/4,3);
XOPEN:=EMA((REF(OPEN,1)+REF(XCLOSE,1))/2,3);
TEMPG:=MAX(HIGH,XOPEN);
XHIGH:=EMA(MAX(TEMPG,XCLOSE),3);
TEMP:=MIN(LOW,XOPEN);
XLOW:=EMA(MIN(TEMP,XCLOSE),3);
O1:=IF(XOPEN<XCLOSE,XOPEN,XCLOSE);
C1:=IF(XOPEN<XCLOSE,XCLOSE,XOPEN);
{股旁网-股票公式网站 www.gupanG.com}
{K线}
STICKLINE(XOPEN>=XCLOSE,XHIGH,XLOW,0,0 ),COLORRED;
STICKLINE(XOPEN>=XCLOSE,C1,O1,4,0 ),COLOR000055;
STICKLINE(XOPEN>=XCLOSE,C1,O1,3,0 ),COLOR000077;
STICKLINE(XOPEN>=XCLOSE,C1,O1,2.5,0 ),COLOR000099;
STICKLINE(XOPEN>=XCLOSE,C1,O1,1.5,0 ),COLOR0000BB;
STICKLINE(XOPEN>=XCLOSE,C1,O1,0.9,0 ),COLOR0000DD;
STICKLINE(XOPEN>=XCLOSE,C1,O1,0.3,0 ),COLOR0000FF;
STICKLINE(XOPEN<XCLOSE,XHIGH,XLOW,0,0 ),COLORCYAN;
STICKLINE(XOPEN<XCLOSE,C1,O1,4,0 ),COLOR990000;
STICKLINE(XOPEN<XCLOSE,C1,O1,3,0 ),COLORCC0000;
STICKLINE(XOPEN<XCLOSE,C1,O1,2.5,0 ),COLORFF4400;
STICKLINE(XOPEN<XCLOSE,C1,O1,1.5,0 ),COLORFF8800;
STICKLINE(XOPEN<XCLOSE,C1,O1,0.9,0 ),COLORFFCC00;
STICKLINE(XOPEN<XCLOSE,C1,O1,0.3,0 ),COLORCYAN;
HH:=(6*H+5*REF(H,1)+4*REF(H,2)+3*REF(H,3)+2*REF(H,4)+REF(H,5))/21;
LL:=(6*L+5*REF(L,1)+4*REF(L,2)+3*REF(L,3)+2*REF(L,4)+REF(L,5))/21;
A1:=IF(C>REF(EXPMEMA(H,6),1),1,0);
A2:=IF(C<REF(EXPMEMA(L,6),1),-1,0);
A3:=A1+A2;
A4:=IF(A3=0,REF(A3,BARSLAST(NOT(A3=0))),A3);
转折线:IF(A4=-1,MA(HIGH,6),MA(LOW,6))LINETHICK2,COLORFFFFFF;

通达信台湾力道K线主图指标公式

 

相关文章