在线检测未来函数

飞狐量MACD指标公式

来源:Internet,编辑:股旁网,2010-12-07

画面起点:=SYSPARAM(2); 画面终点:=SYSPARAM(3);画面K线数:=画面终点-画面起点+1;
成交量最高:=HHV(VOL,画面K线数);成交量视高:=成交量最高[画面终点];
交易分钟数:=if(CURRENTTIME>93000 and CURRENTTIME<150000,
if(CURRENTTIME<113000,(TIMETOT0(CURRENTTIME)-34200)/60,
if(CURRENTTIME>130000,(TIMETOT0(CURRENTTIME)-39600)/60,120)),240);
日期差:=DATEDIFF(DATE,CURRENTDATE); 预测量:=IF(BARSTATUS=2 and 日期差=0,VOL/交易分钟数*240,VOL);
{发现主力}
主力1:=REF(LOW,1);主力2:=(SMA(ABS(LOW-主力1),13,1))/(SMA(MAX(LOW-主力1,0),13,1))*10;
主力3:=EMA(主力2,13);主力4:=LLV(LOW,34);主力5:=EMA(IF(LOW<=主力4,主力3,0),3);
主力最高:=HHV(主力5,画面K线数);主力视高:=主力最高[画面终点];
发现主力:主力5*成交量视高/主力视高,color440088,LINETHICK0;
{股旁网-股票公式网站 www.gupAng.com}
STICKLINE(c,(成交量视高-发现主力),成交量视高,10,0),color220055;
{量MACD}
量DIFF1:=EMA(VOL,12) - EMA(VOL,26),color00FFFF,linethick;
量DEA1:=EMA(量DIFF1,9),colorFF8800,linethick;量MACD1:=(量DIFF1-量DEA1)*1.4;
量MACD最高:=HHV(IF(量DIFF1>量MACD1,量DIFF1,量MACD1),画面K线数);量MACD视高:=量MACD最高[画面终点];
量MACD最低:=LLV(IF(量DIFF1<量MACD1,量DIFF1,量MACD1),画面K线数);量MACD视低:=量MACD最低[画面终点];
量DIFF:(量DIFF1-量MACD视低)*成交量视高/(量MACD视高-量MACD视低),color00FFFF,linethick;
量DEA:(量DEA1-量MACD视低)*成交量视高/(量MACD视高-量MACD视低),colorFF8800,linethick;
量MACD:=(量MACD1-量MACD视低)*成交量视高/(量MACD视高-量MACD视低);
量MACD零:=(0-量MACD视低)*成交量视高/(量MACD视高-量MACD视低);
STICKLINE(量DIFF>量DEA,量MACD零,量MACD,8,0),colorAA0088;
STICKLINE(量DIFF<量DEA,量MACD零,量MACD,8,0),color556600;
STICKLINE(BARSTATUS=2,VOL,IF(预测量>=成交量视高,成交量视高,预测量),1,1),COLOR0000FF,LINEDOT;
STICKLINE(C>REF(C,1),0,VOL,1,0),Color0033FF;STICKLINE(C<=REF(C,1),0,VOL,1,0),COLORFF8800;
PARTLINE(C,量DIFF),color00FFFF,linethick2;PARTLINE(C,量DEA),colorFFAA00;

飞狐量MACD指标公式

 

相关文章