在线检测未来函数

通达信统一MACD指标公式

来源:Internet,编辑:股旁网,2010-12-12

SH:=12;LO:=26;M:=9;
DA:=IF(DATE<1070531,1,0);
DJ:=MINUTE-REF(MINUTE,1);
SJ1:=HHV(HOUR-REF(HOUR,1),5);
SJ2:=LLV(HOUR-REF(HOUR,1),5);
KJ:=IF(DJ=5 OR DJ=-55 OR DJ=-25 OR DJ=35,5,
IF(DJ=-15 OR DJ=-45 OR DJ=15 OR DJ=45,15,
IF(LLV(DJ,80)=0 AND SJ1=0,240,
IF((DJ=0 OR DJ=-30 OR DJ=30) AND SJ1<3 AND SJ2<=0,30,
IF(LLV(DJ,3)=1 OR HHV(DJ,3)=1,1,60)))));
DIF:(EMA(CLOSE,SH)-EMA(CLOSE,LO))/EMA(CLOSE,LO)*1000,COLORGREEN;
DEA:EMA(DIF,M);
MACD:(DIF-DEA)*2,COLORSTICK;
JB:=(LO-SH)*KJ/(14*240);
BD:=(MACD-LLV(REF(MACD,1),2))/ABS(REF(DIF,1))/2;
该期增减:IF(BD>10,10,IF(BD<-10,-10,BD)),LINETHICK0;
L1:IF(DA=1 AND DIF>0,PLOYLINE(DIF>0,DIF),DRAWNULL),COLORWHITE;
L2:IF(DA=1 AND DIF>10*JB,PLOYLINE(DIF>10*JB,DIF),DRAWNULL),COLORRED;
L3:IF(DA=1 AND DIF>50*JB,PLOYLINE(DIF>50*JB,DIF),DRAWNULL),COLORMAGENTA;
MD:=MAX(MAX(DIF,DEA),MACD);
MX:=MIN(MIN(DIF,DEA),MACD);
MDC:=HHV(MD,50);
MXC:=LLV(MX,50);
DX:=MDC-MXC;
YS:=IF(DIF>50*JB,'强得发紫',
IF(DIF>10*JB AND DIF<50*JB,'多头区',
IF(DIF>0 AND DIF<10*JB,'多头观望',
IF(DIF<0,'空头区',DRAWNULL))));
DRAWTEXT(DA=1 AND CURRBARSCOUNT=1 AND DIF>50*JB,MXC+0.6*DX,YS),COLORMAGENTA;
DRAWTEXT(DA=1 AND CURRBARSCOUNT=1 AND DIF>10*JB AND DIF<50*JB,MXC+0.6*DX,YS),COLORRED;
DRAWTEXT(DA=1 AND CURRBARSCOUNT=1 AND DIF>0 AND DIF<10*JB,MXC+0.6*DX,YS),COLORWHITE;
DRAWTEXT(DA=1 AND CURRBARSCOUNT=1 AND DIF<0,MXC+0.6*DX,YS),COLORGREEN;
{股旁网-股票公式网站 www.gupAng.com}
DRAWTEXT(DA=1 AND DIF>0 AND DIF>DEA AND CURRBARSCOUNT=1,MXC+0.5*DX,'上升通道持续(参数③周期)');
DRAWTEXT(DA=1 AND DIF>0 AND DIF<DEA AND CURRBARSCOUNT=1,MXC+0.5*DX,'上升通道趋缓(参数③周期)');
DRAWTEXT(DA=1 AND DIF<0 AND DIF>DEA AND CURRBARSCOUNT=1,MXC+0.5*DX,'下降通道趋缓(参数③周期)');
DRAWTEXT(CURRBARSCOUNT=1,MXC+0.8*DX,'MACD庞辉V2.0大众版请阅用法注释'),COLORMAGENTA;
DRAWTEXT(CURRBARSCOUNT=1,MXC+0.4*DX,'SHOP34328852.TAOBAO.COM'),COLORMAGENTA;
{DRAWTEXT(CURRBARSCOUNT=1 AND MACD>=LLV(REF(MACD,1),2),MXC+0.6*DX,
' 增强'),COLORRED;
DRAWTEXT(CURRBARSCOUNT=1 AND MACD<LLV(REF(MACD,1),2),MXC+0.6*DX,
' 减弱'),COLORGREEN;};

通达信统一MACD指标公式

 

相关文章