在线检测未来函数

大智慧擒庄MACD指标公式

来源:Internet,编辑:股旁网,2010-12-14

{空间}
Z:=BARSLAST(DISPSTATUS=1)+1;
HH:=HHV(H,Z);
LL:=LLV(L,Z);
上涨:=BARSSINCE(BACKSET(DISPSTATUS=2,BARSLAST(L=LL)+1));
低:REF(L,上涨),COLOR00FF00,DOTLINE;
VERTLINE(上涨=0,4),COLOR0000FF;{在图形上绘直线}
DRAWTEXT(上涨=0,HHVALL(HH)*0.99,'-最低'),COLOR00ff00;{{求可视范围最低值}
{股旁网-股票公式网站 www.gupAng.com}
DIFf:(EMA(CLOSE,12)-EMA(CLOSE,26))*20000,COLOR00FFFF,LINETHICK1;
DEA:EMA(DIFF,9),COLORGREEN,LINETHICK2;
FILLRGN(DIFF,DEA,DIFF>DEA,(RGB(255,0,255)));
万手:=VOL/10000;
BB:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
主动买:=IF(CLOSE>OPEN,BB*(HIGH-LOW),IF(CLOSE<OPEN,BB*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2));
主买:=主动买/10000;
主动卖:=IF(CLOSE>OPEN,0-BB*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,0-BB*(HIGH-LOW),0-VOL/2));
主卖:=主动卖/10000;
主净额:=(主动买+主动卖)/10000;
dx:=主净额;
YX:=BARSSINCE(DX)+1;
QM:=BARSLAST(dx<=0);
主力强买:IF(QM<0,YX,QM),COLOR00FFFF,LINETHICK0;
QM卖:=BARSLAST(dx>=0);
主力强卖:IF(QM卖<0,YX,QM卖),COLOR00FF00,LINETHICK0;
动力:=(主力强买-主力强卖);
stickline(动力>0,动力,0,4,0),colorred,linethick2;
stickline(动力<0,动力,0,4,0),colorgreen,linethick2;
DIFf买:(EMA(主力强买,12)-EMA(主力强买,26))*20000,COLOR00FFFF,LINETHICK1;
DEA买:EMA(DIFF买,9),COLORGREEN,LINETHICK2;
FILLRGN(DIFF买,DEA买,DIFF买>DEA买,(RGB(255,0,0)));
{FILLRGN(DEA买,DIFF买,DEA买>DIFF买,(RGB(0,0,255)));}
DIFf卖:(EMA(主力强卖,12)-EMA(主力强卖,26))*20000,COLOR00FFFF,LINETHICK1;
DEA卖:EMA(DIFF卖,9),COLORGREEN,LINETHICK2;
FILLRGN(DIFF卖,DEA卖,DIFF卖>DEA卖,(RGB(0,255,0)));
W:=BARSLAST(DISPSTATUS=1);
低涨:(c/LLV(LOW,W)-1)*100,COLOR0000FF,LINETHICK0,PRECIS2;
高跌:(c/HHV(HIGH,W)-1)*100,COLOR0000FF,LINETHICK0,PRECIS2;
天日:BARSLAST(L=LLV(LOW,W)),COLOR00FFFF,LINETHICK0,PRECIS0;
天:BARSLAST(H=HHV(HIGH,W)),COLOR00FFFF,LINETHICK0,PRECIS0;
{以下设置提示文字部分}
DRAWTEXTREL(10,15,'●低点至今日最高点上涨:'+NUMTOSTRN(低涨,2)+'% '+NUMTOSTRN(天日,0)+'天'),COLORFF50FF;
DRAWTEXTREL(250,15,'●高点至今日最低点下跌:'+NUMTOSTRN(高跌,2)+'% '+NUMTOSTRN(天,0)+'天'),COLORFFff00;
DRAWTEXTREL(500,20,'●细心看,分析好,大有益'),COLOR00ffff,LINETHICK3;

大智慧擒庄MACD指标公式

 

相关文章