在线检测未来函数

通达信动能短线指标公式

来源:Internet,编辑:股旁网,2010-12-18

OSC:=C-REF(MA(C,13),5){动能线};分界:=MA(OSC,8);
DIFF:=EMA(OSC,12)-EMA(OSC,26);DEA:=EMA(DIFF,9);MACD:=2*(DIFF-DEA);
ZF:=IF(C>REF(H,1),EMA(L,5),IF(C<REF(EMA(L,5),1),H,EMA(L,5)));
KD:=BARSLAST(C<=ZF);XH:=KD=1 AND BARSLAST(MACD<REF(MACD,1));
{柱线}
STICKLINE(MACD<REF(MACD,1) AND MACD<0,0,MACD*4,0,0),COLORFF6600;
STICKLINE(MACD<REF(MACD,1) AND MACD>0,0,MACD*4,0,0),COLOR0088FF;
STICKLINE(MACD>REF(MACD,1) AND MACD<0,0,MACD*4,0,0),COLORFF88FF;
STICKLINE(MACD>REF(MACD,1) AND MACD>0,0,MACD*4,0,0),COLORFFCCFF;
{K柱}
STICKLINE(OSC<REF(OSC,1)||(AMOUNT/REF(AMOUNT,1)<0.97),OSC,REF(OSC,1),3,0),COLORWHITE;{离场}
STICKLINE(CROSS(REF(MACD,1),MACD) AND MACD<REF(MACD,1),OSC,REF(OSC,1),3,0),COLOR0088FF;{逃顶}
STICKLINE(OSC>=REF(OSC,1),OSC,REF(OSC,1),3,1),COLORRED;{持股}
STICKLINE(BARSLAST(XH)<2,OSC,REF(OSC,1),3,1),COLORRED;{延时}
STICKLINE(XH,OSC,REF(OSC,1),2,0),COLORFF00FF;{启动}
STICKLINE(OSC<分界,OSC,REF(OSC,1),3,1),COLORFFFF00;{空仓}
{动能线:OSC,COLORFFB5FF;加速线:(DEA-DIFF)*9.8,COLORGREEN;}
{字}
{DRAWTEXT(BARPOS=SYSPARAM(3),0,'启动'),COLORMAGENTA;
DRAWTEXT(BARPOS=SYSPARAM(3),0,'持股'),COLORRED;
DRAWTEXT(BARPOS=SYSPARAM(3),0,'逃顶'),COLORYELLOW;
DRAWTEXT(BARPOS=SYSPARAM(3),0,'警惕'),COLORWHITE;
DRAWTEXT(BARPOS=SYSPARAM(3),0,'空仓'),COLORFFA900};
黄逃顶白离场:IF(1=1,DRAWNULL,DRAWNULL),COLORYELLOW;{逃顶}
梅红启动:IF(1=1,DRAWNULL,DRAWNULL),COLORMAGENTA;{启动}
红持股兰空仓:IF(1=1,DRAWNULL,DRAWNULL),COLORFFA900;{空仓};
{【MKR-13E5】【】}
{N:=8};
{DIFF:EMA(C,12)-EMA(C,26);DEA:EMA(DIFF,9);MACD:2*(DIFF-DEA),COLORSTICK;
STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,0,0),COLORFF6666;
STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,0,0),COLORRED;
STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,0,0),COLOR00FFFF;
STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,0,0),COLORFF6666;
DD1:=EMA(C,3)-EMA(C,8);DD2:=EMA(O,3)-EMA(O,8);
DD3:=EMA(H,3)-EMA(H,8);DD4:=EMA(L,3)-EMA(L,8);
DRAWICON(CROSS(DD1,DIFF) AND DIFF<-0.05,DD4-0.5,1);
DRAWICON(CROSS(DIFF,DD1) AND DIFF>0.1,DD3+0.5,2);
STICKLINE(DD1>=DD2,DD1,DD2,4,1),COLOR0099FF;
STICKLINE(DD1<=DD2,DD1,DD2,4,1),COLOR00FF00};
A1:=BARSLAST(REF(CROSS("MACD.DIF"(12,26,9),"MACD.DEA"(12,26,9)),1));
B1:=REF(C,A1+1)>C AND REF("MACD.DIF"(12,26,9),A1+1)<"MACD.DIF"(12,26,9) AND CROSS("MACD.DIF"(12,26,9),"MACD.DEA"(12,26,9));
MACD底背离:=FILTER(B1>0,5);
{股旁网-股票公式网站 www.gupAng.com}
DRAWTEXT(MACD底背离,-1.68,'M底'),COLOR00FF00;
C1:=BARSLAST(REF(CROSS("MACD.DEA"(12,26,9),"MACD.DIF"(12,26,9)),1));
D11:=REF(C,C1+1)<C AND REF("MACD.DIF"(12,26,9),C1+1)>"MACD.DIF"(12,26,9) AND CROSS("MACD.DEA"(12,26,9),"MACD.DIF"(12,26,9));
MACD顶背离:=FILTER(D11>0,5);
DRAWTEXT(MACD顶背离,2.28,'M顶'),COLOR00DD00;
A2:=BARSLAST(REF(CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3)),1));
B2:=REF(C,A2+1)>C AND REF("KDJ.K"(9,3,3),A2+1)<"KDJ.K"(9,3,3) AND CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3));
KDJ底背离:=FILTER(B2>0,5);
DRAWTEXT(KDJ底背离,-1.98,'K底'),COLOR00FFFF;
C2:=BARSLAST(REF(CROSS("KDJ.D"(9,3,3),"KDJ.K"(9,3,3)),1));
D22:=REF(C,C2+1)<C AND REF("KDJ.K"(9,3,3),C2+1)>"KDJ.K"(9,3,3) AND CROSS("KDJ.D"(9,3,3),"KDJ.K"(9,3,3));
KDJ顶背离:=FILTER(D22>0,5);
DRAWTEXT(KDJ顶背离,1.98,'K顶'),COLOR0066FF;
A3:=BARSLAST(REF(CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24)),1));
B3:=REF(C,A3+1)>C AND REF("RSI.RSI1"(6,12,24),A3+1)<"RSI.RSI1"(6,12,24) AND CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24));
RSI底背离:=FILTER(B3>0,5);
DRAWTEXT(RSI底背离,-2.28,'R底'),COLORFFCC66;
C3:=BARSLAST(REF(CROSS("RSI.RSI2"(6,12,24),"RSI.RSI1"(6,12,24)),1));
D3:=REF(C,C3+1)<C AND REF("RSI.RSI1"(6,12,24),C3+1)>"RSI.RSI1"(6,12,24) AND CROSS("RSI.RSI2"(6,12,24),"RSI.RSI1"(6,12,24));
RSI顶背离:=FILTER(D3>0,5);
DRAWTEXT(RSI顶背离,1.68,'R顶'),COLORFF00FF;

通达信动能短线指标公式

 

相关文章