在线检测未来函数

通达信新颖DMI指标公式

来源:Internet,编辑:股旁网,2010-12-22

N:=14;M:=6;
TR1:=EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),N);
HD :=HIGH-REF(HIGH,1);
LD :=REF(LOW,1)-LOW;
DMP:=EXPMEMA(IF(HD>0&&HD>LD,HD,0),N);
DMM:=EXPMEMA(IF(LD>0&&LD>HD,LD,0),N);
PDI:= DMP*100/TR;
MDI:= DMM*100/TR;
{股旁网-股票公式网站 www.gupAng.com}
STICKLINE(PDI>=MDI,PDI-MDI,0,2,1),COLOR9900FF;
STICKLINE(PDI<MDI,PDI-MDI,0,2,1),COLORF69ECE;
ADX:= EXPMEMA(ABS(MDI-PDI)/(MDI+PDI)*100,M);
ADXR:=EXPMEMA(ADX,M);
DRAWBAND(ADX,RGB(200,0,200),ADXR,RGB(150,150,150));
ADX2:EXPMEMA(ABS(MDI-PDI)/(MDI+PDI)*100,M),COLOR00EEEE,LINETHICK1;
ADXR2:EXPMEMA(ADX,M),COLORFFFFFF,LINETHICK1;
关注线:=50,COLORF0F000,POINTDOT;
IF(ADX>=ADXR,85,DRAWNULL),COLORF580F5,LINETHICK8;
IF(ADX<ADXR,85,DRAWNULL),COLORCCDD66,LINETHICK6;
IF(PDI>=MDI,-55,DRAWNULL),COLOR0000EE,LINETHICK8;
IF(PDI<MDI,-55,DRAWNULL),COLOR33AA33,LINETHICK6;

通达信新颖DMI指标公式

 

相关文章