在线检测未来函数

通达信中短期操盘线指标公式

来源:Internet,编辑:股旁网,2010-12-23

V1:=BARSCOUNT(CLOSE)*3.142/180;
A2: SIN(V1*8)*100,LINETHICK1;
A3: COS(V1*8)*100,LINETHICK1;
X1:0,COLORFFFFCC;
VAR1:=MA(CLOSE,5);
VAR2:=MA(CLOSE,10);
VAR3:=MA(CLOSE,20);
VAR4:=MA(CLOSE,30);
VAR5:=(VAR1+VAR2+VAR3+VAR4)/4;
VAR6:=(VAR5-REF(VAR5,5))/REF(VAR5,5)*1500;
VAR7:=(VAR5-REF(VAR5,5))/REF(VAR5,5)*1500;
VAR8:=EMA(VAR6,8);
底部注意: STICKLINE(VAR6>REF(VAR6,1) AND VAR6<0 AND VAR6<VAR8,VAR6,0,1,0),COLORFF00FF;
低位转强: STICKLINE(VAR8>REF(VAR8,1) AND VAR6<0 AND VAR6>VAR8,VAR8,0,1,0),COLORYELLOW;
买点: STICKLINE(VAR6>REF(VAR6,1) AND VAR6>0 AND VAR8<0,VAR6,VAR8,4,0),COLOR0099FF;
{股旁网-股票公式网站 www.gupAng.com}
VAR9:=TROUGHBARS(3,15,1)<10;
VAR10:=PEAKBARS(3,15,1)<10;
VAR11:=IF(VAR9=1,50,0);
VAR12:=IF(VAR10=1,50,0);
底部:= IF(VAR11=50,50,0);
头部:= IF(VAR12=50,100,0);
A:IF( 底部>REF(底部,1),50,0);
AA:IF(头部>REF(头部,1),50,0);
DRAWTEXT(A=50,90,'买进'),COLORRED,LINETHICK1;
DRAWTEXT(AA=50,90,'卖出'),COLOR00FF00,LINETHICK1;
DRAWICON(FILTER(VAR6>REF(VAR6,1) AND VAR6>0 AND VAR8<0,30),-40,1);
DRAWTEXT(FILTER(VAR6>REF(VAR6,1) AND VAR6>0 AND VAR8<0,30),-40,'短买'),COLORFFFFFF;
坚定持股: STICKLINE(VAR8>REF(VAR8,1) AND VAR8>0,VAR6,0,1,0),COLORRED;
谨慎观望: STICKLINE(VAR6<REF(VAR6,1) AND VAR8>REF(VAR8,1) AND VAR6>0,VAR6,VAR8,1,0),COLOR00FF00;
果断持币: STICKLINE(VAR6<REF(VAR6,1) AND VAR6<VAR8,VAR6,VAR8,1,1),COLORFFCC66;

通达信中短期操盘线指标公式

 

相关文章