在线检测未来函数

通达信CCI优化版指标公式

来源:Internet,编辑:股旁网,2010-12-25

n:=14;n1:=3;
TYP:=(HIGH + LOW + CLOSE)/3;
CCI:(TYP-MA(TYP,N))/(0.015*AVEDEV(TYP,N)),LINESTICK,COLORRED,LINETHICK2;
跌:IF(CCI<REF(CCI,1),CCI,DRAWNULL),COLORGREEN,LINETHICK2;
DRAWICON(CROSS(200,CCI),250,27);
DRAWICON( CROSS(CCI,-200),-250,26);
转强:STICKLINE(CCI>0,0,CCI,2,0),COLOR770077;
STICKLINE(CCI>0,0,CCI,1.5,0),COLOR990099;
STICKLINE(CCI>0,0,CCI,0.8,0),COLORBB00BB;
STICKLINE(CCI>0,0,CCI,0.3,0),COLORFF00FF;
转弱:STICKLINE(CCI<0,0,CCI,2,0),COLOR888800;
STICKLINE(CCI<0,0,CCI,1.5,0),COLORAAAA00;
STICKLINE(CCI<0,0,CCI,0.8,0),COLORDDDD00;
STICKLINE(CCI<0,0,CCI,0.3,0),COLORFFFF00;
弱转强:=STICKLINE(CROSS(CCI,-200) AND CCI>REF(CCI,1),CCI,0,2,0),COLOR00DFDF;
STICKLINE(弱转强,-150,0,7,0),COLORYELLOW;
STICKLINE(弱转强,-150,0,4,0),COLOR000099;
STICKLINE(弱转强,-150,0,2,0),COLOR0000BB;
STICKLINE(弱转强,-150,0,1,0),COLOR0000DD;
STICKLINE(弱转强,-210,0,0.9,0),COLOR0000FF;
DRAWTEXT(弱转强,-210,'买'),COLORYELLOW;
{股旁网-股票公式网站 www.gupAng.com}
强转弱:=STICKLINE(CROSS(200,CCI) AND CCI<REF(CCI,1),0,CCI,2,0),COLORGREEN;
STICKLINE(强转弱,150,0,7,0)COLORWHITE;
STICKLINE(强转弱,150,0,4,0),COLOR009900;
STICKLINE(强转弱,150,0,2,0),COLOR00BB00;
STICKLINE(强转弱,150,0,1,0),COLOR00DD00;
STICKLINE(强转弱,210,0,0.9,0),COLOR00FF00;
DRAWTEXT(强转弱,210,'卖'),COLORGREEN;
天顶线:=200,COLORRED;
地底线:-200,COLORCYAN;
牛熊线:100,POINTDOT,LINETHICK3,COLORWHITE;
BIAS1W :=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
BIAS2W :=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;
BIAS3W :=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
MM:=(BIAS1W+2*BIAS2W+3*BIAS3W)/6;
MN:=MA(MM,3);
VAR24:=LLV(LOW,36);
VAR25:=HHV(HIGH,30);
VAR26:=EMA((CLOSE-VAR24)/(VAR25-VAR24)*4,4)*25;
{底背离:= IF((VAR26<10),-100,-150), COLORYELLOW,LINETHICK1;}
底背离:IF(MN<-4 ,-100,-150),COLORYELLOW,LINETHICK1;
顶背离: IF((VAR26>90),150,200), COLORGREEN,LINETHICK1;
量能:MA(100*(CLOSE- LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N)),N1),COLORYELLOW,LINETHICK1;

通达信CCI优化版指标公式

 

相关文章