在线检测未来函数

大智慧人性化设计DMI指标公式

来源:Internet,编辑:股旁网,2011-01-01

n:=14;m:=6;
TR := SUM(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),N);
HD := HIGH-REF(HIGH,1);
LD := REF(LOW,1)-LOW;
DMP:= SUM(IF(HD>0 AND HD>LD,HD,0),N);
DMM:= SUM(IF(LD>0 AND LD>HD,LD,0),N);
PDI: DMP*100/TR;
MDI: DMM*100/TR;
ADX: MA(ABS(MDI-PDI)/(MDI+PDI)*100,M),LINETHICK4,COLORff0000;
PARTLINE(adx,(adx>=REF(adx,1) and pdi>mdi),RGB(255,0,0)),LINETHICK4;
{股旁网-股票公式网站 www.gupAng.com}
ADXR:(ADX+REF(ADX,M))/2,COLOR888888;
PARTLINE(adxr,(adxr>=REF(adxr,1) and pdi>mdi),RGB(255,0,255)),LINETHICK2;
FILLRGN(pdi,mdi,pdi>mdi,RGB(150,0,150),pdi<mdi,RGB(0,125,0)),PRECIS0,LAYER6;

大智慧人性化设计DMI指标公式

 

相关文章