在线检测未来函数

通达信KDJ+MACD+抢反弹主图指标公式

来源:Internet,编辑:股旁网,2011-01-04

EMA5:MA(C,5),COLORFF00FF,LINETHICK2;
EMA10:MA(C,10),COLOR00FFFF,LINETHICK2;
EMA21:MA(C,21),COLORC0FF7F,LINETHICK1;
EMA55:MA(C,55),COLORFFFFFF,LINETHICK1;
VAR1:=1;
VAR2:=((((2*CLOSE)+HIGH)+LOW) / 4);
VAR4:=LLV(LOW,5);
VAR5:=HHV(HIGH,4);
C1:=(EMA((((VAR2-VAR4)/(VAR5-VAR4))*100),4)*VAR1),COLORRED,LINETHICK2;
C2:=(EMA(((0.667*REF(C1,1))+(0.333*C1)),2)*VAR1),COLORFFFFFF,LINETHICK2;
AA:=C1>=C2 ;
BB:=C2>C1 ;
{股旁网-股票公式网站 www.gupAng.com}
买入:DRAWICON(CROSS(AA,BB),L-0.1,1);
卖出:DRAWICON(CROSS(BB,AA),H+0.1,2);
STICKLINE(AA,C,O,3,0),COLOR000099;
STICKLINE(AA,H,L,0.5,0),COLOR000099;
STICKLINE(BB,C,O,3,0),COLORFF0099;
STICKLINE(BB,H,L,0.5,0),COLOR660099;
STICKLINE(AA,CLOSE,OPEN,3.0,0),COLOR9900CC;
STICKLINE(AA,CLOSE,OPEN,2.5,0),COLORFF00CC;
STICKLINE(AA,CLOSE,OPEN,1.9,0),COLORFF00FF;
STICKLINE(AA,CLOSE,OPEN,1.0,0),COLORFF33FF;
STICKLINE(AA,CLOSE,OPEN,0.5,0),COLORFF66FF;
STICKLINE(AA,CLOSE,OPEN,0.2,0),COLORFF99FF;
STICKLINE(BB,CLOSE,OPEN,3,0),COLOR006633;
STICKLINE(BB,CLOSE,OPEN,2.5,0),COLOR339933;
STICKLINE(BB,CLOSE,OPEN,1.9,0),COLOR669933;
STICKLINE(BB,CLOSE,OPEN,1.5,0),COLOR33CC33;
STICKLINE(BB,CLOSE,OPEN,1.0,0),COLOR66CC33;
STICKLINE(BB,CLOSE,OPEN,0.2,0),COLORCCFF33;
STICKLINE(买入,O,(C-O)/2+O,3,0),COLOR335555;
STICKLINE(买入,O,(C-O)/2+O,2.2,0),COLOR338888;
STICKLINE(买入,O,(C-O)/2+O,1.5,0),COLOR33AAAA;
STICKLINE(买入,O,(C-O)/2+O,1,0),COLOR33CCCC;
STICKLINE(买入,O,(C-O)/2+O,0,0),COLOR33EEEE;
STICKLINE(卖出,O,(C-O)/2+O,3,0),COLOR550055;
STICKLINE(卖出,O,(C-O)/2+O,2.2,0),COLOR880088;
STICKLINE(卖出,O,(C-O)/2+O,1.5,0),COLORAA00AA;
STICKLINE(卖出,O,(C-O)/2+O,1,0),COLORCC00CC;
STICKLINE(卖出,O,(C-O)/2+O,0.5,0),COLOREE00EE;
HH0:=CONST(HHV(H,75));
LL0:=CONST(LLV(L,75));
MM0:=CONST((HH0+LL0)/2);
HL0:=CONST(IF(CONST(C)>=MM0,LL0-(HH0-LL0)*0.2,HH0+(HH0-LL0)*0.2));
HH1:=IF(CONST(C)<MM0,HH0*1.01,HL0);
LL1:=IF(CONST(C)>=MM0,LL0*0.99,HL0);
HL1:=(HH1+LL1)/2,COLORFFFFFF;
STICKLINE("MACD.MACD">0,"MACD.MACD"+HL1,HL1,2,1),COLOR00FFFF;
STICKLINE("MACD.MACD">0 AND "MACD.MACD">REF("MACD.MACD",1),
"MACD.MACD"+HL1,HL1,2,0),COLORFF00FF;
STICKLINE("MACD.MACD"<0,"MACD.MACD"+HL1,HL1,2,0),COLOR00FFFF;
STICKLINE("MACD.MACD"<0 AND "MACD.MACD">REF("MACD.MACD",1),
"MACD.MACD"+HL1,HL1,2,1),COLORFF00FF;
RSV1:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9));
RSVK:=SMA(RSV1,3,1);
RSVD:=SMA(RSVK,3,1);
RSVJ:=RSVK*3-RSVD*2;
K:RSVK*3+HL1,COLORWHITE;
D:RSVD*3+HL1,COLORYELLOW;
J:RSVJ*3+HL1,COLORRED,LINETHICK2;
DRAWBAND(K,RGB(150,0,150),D,RGB(150,150,150));

通达信KDJ+MACD+抢反弹指标公式

 

相关文章