在线检测未来函数

通达信短线快攻指标公式

来源:Internet,编辑:股旁网,2011-01-05

VAR1:=(HIGH+LOW+OPEN+CLOSE*2)/5;
VAR2:=EMA(VAR1,21);
VAR3:=STD(VAR1,23);
VAR4:=EMA(VAR1,2);
VARA:=(VAR1-VAR2)*100/VAR3;
K:(EMA(VARA,23)+100)/2-3,LINETHICK2,COLORFF0000;
D:SMA(K,5,1),LINETHICK2,COLORFFFF00;
J:4*K-3*D,LINETHICK2,COLORFF00FF;
{股旁网-股票公式网站 www.GupAng.com}
DRAWICON(FILTER(J>REF(J,1) AND J<REF(J,3) AND J<K AND VAR4>REF(VAR4,1)
AND K>=REF(K,1) AND J<40 OR CROSS(J,K) AND CROSS(J,D) AND J<40 OR J>REF
(J,1) AND J<-20,7),J*0.8,6);
DRAWICON(FILTER(J<=REF(J,1) AND J>80,8),J*1.2,5);
AA:=CROSS(J,D);
DRAWICON(AA,LOW,1);
VAR1M:=REF(CLOSE,1);
VAR2M:=(SMA(MAX(CLOSE-VAR1M,0),6,1))/(SMA(ABS(CLOSE-VAR1M),6,1))*100;
短期顶部:CROSS(80,VAR2M)*100,COLORFF0000;
DRAWTEXT(CROSS(80,VAR2M),100,'★顶'),COLORFFFF00;
VAR3M:=(SMA(MAX(CLOSE-VAR1M,0),7,1))/(SMA(ABS(CLOSE-VAR1M),7,1))*100;
VAR4M:=(SMA(MAX(CLOSE-VAR1M,0),13,1))/(SMA(ABS(CLOSE-VAR1M),13,1))*100;
VAR5M:=BARSCOUNT(CLOSE);
短期底部:=VAR3M<20 AND VAR4M<25 AND VAR5M>50*100;
DRAWTEXT(CROSS(100,短期底部),100,'短 '),COLORFFFF00;
AAM:=CLOSE/REF(CLOSE,1)>=1.099;
AB:=VOL/REF(VOL,1);
涨停预警:IF(CLOSE/REF(CLOSE,1)>=1.03 AND AB<1,33,0),COLORFF0000;
目标出现:(IF(AAM AND AB<1,55,0)),LINETHICK2,COLORFFFF00;

通达信短线快攻指标公式

 

相关文章