在线检测未来函数

通达信买股均线主图指标公式

来源:Internet,编辑:股旁网,2011-01-09

M5: MA(CLOSE,5);
M10: MA(CLOSE,10);
M20: MA(CLOSE,20);
M30: MA(CLOSE,30);
M60: MA(CLOSE,60);
M125: MA(CLOSE,125);
M250: MA(CLOSE,250), , COLORRED;
VAR2:=REF(CLOSE,1);
VAR3:=SMA(MAX(CLOSE-VAR2,0),6,1)/SMA(ABS(CLOSE-VAR2),6,1)*100;
DRAWTEXT(CROSS(84,VAR3),HIGH,'见顶↓'), , COLORYELLOW;
VAR4:=SMA(MAX(CLOSE-VAR2,0),12,1)/SMA(ABS(CLOSE-VAR2),12,1)*100;
DRAWTEXT(CROSS(VAR4,20),LOW-(HIGH-LOW),'见底↑'), , COLORRED;
VAR8:=MA(CLOSE,12);
VAR9:=MA(CLOSE,26);
VARA:=REF(VAR8,1);
VARB:=REF(VAR9,1);
VARC:=(VAR8-VAR9)/VAR8*100;
VARD:=ABS(VAR8-VARA)/VAR8*100;
VARE:=REF(VAR9,1);
VARF:=REF(VARD,1);
VAR10:=REF(M5,1);
VAR11:=REF(M10,1);
VAR12:=REF(CLOSE,1);
VAR13:=COUNT(CLOSE>REF(CLOSE,1),5)/5*100;
VAR14:=(HHV(HIGH,36)-CLOSE)/(HHV(HIGH,36)-LLV(LOW,36))*100;
VAR15:=SMA(VAR14,5,1);
VAR16:=(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100;
VAR17:=SMA(VAR16,2,1);
VAR18:=MA(VOL/CAPITAL,30)*MA(VOL,60)/10000+MA(CLOSE,30)*8;
VAR19:=REF(VAR15,1);
VAR1A:=REF(VAR17,1);
VAR1B:=REF(VAR18,1);
VAR1C:=MA(VAR17,5);
VAR1D:=MA(VAR17,12);
VAR1E:=MA(VAR17,26);
VAR1F:=REF(VAR13,1);
VAR20:=(VAR18-VAR1B)/VAR18*100;
VAR21:=SMA(VAR14,5,1);
VAR22:=REF(VAR21,1);
VAR23:=SMA(VAR16,2,1);
VAR24:=REF(VAR23,1);
VAR25:=IF(CLOSE>OPEN,1,0);
VAR26:=IF(M5>VAR10,1,0);
VAR27:=IF(M10>VAR11,1,0);
VAR28:=IF(VARD>VARF,1,0);
VAR29:=IF(VAR17>VAR1A,5,0);
VAR2A:=IF(VAR19>VAR15,5,0);
VAR2B:=IF(VAR18>VAR1B,2,0);
VAR2C:=IF(VARC>2.25,10,0);
VAR2D:=IF(VAR17>60,6,0);
VAR2E:=IF(VAR17>80,8,0);
VAR2F:=IF(VAR17>VAR15,10,0);
VAR30:=IF(VAR17>VAR15,VAR1D-VAR1E,0);
VAR31:=IF(VAR17>VAR15 AND VAR15<20,5,0);
VAR32:=IF(CLOSE>VAR8 AND VAR8>VAR9,5,0);
VAR33:=IF(VAR8>VAR9,5,0);
VAR34:=IF(VAR9>VARE,5,0);
VAR35:=IF(VAR15<18,VAR1C-VAR15,0);
{股旁网-股票公式网站 www.GupAng.com}
VAR36:=IF(VAR15>VAR17 AND VAR15>50,8,0);
VAR37:=(VAR25+VAR26+VAR27+VAR28+VAR29+VAR2A+VAR2B+VAR2C+VAR2D+VAR2E+VAR2F+VAR30+VAR31+VAR32+VAR33+VAR34+VAR35-VAR36);
VAR38:=REF(VAR37,1);
VAR39:=MA(VAR37,6);
VAR3A:=MA(VAR37,12);
VAR3B:=MA(VAR37,26);
VAR3C:=MA(VAR37,13);
VAR3D:=REF(VAR3A,1);
VAR3E:=REF(VAR3A,2);
DRAWTEXT(VAR19>VAR1B AND VAR15<VAR18 AND VAR3A<25 AND VAR17>VAR15,M5,'最佳时机 '), , COLORRED;
DRAWTEXT(VAR18>30 AND VAR17>VAR18 AND VAR3A>30 AND VAR3A<60 AND CROSS(VAR18,VAR15),M5,'追涨 '), , COLORYELLOW;
DRAWTEXT(VAR3A>60 AND CROSS(VAR3C,VAR3A) AND VAR17<60 AND VAR15>20,M5,'等死吗? '), , COLORGREEN;
DRAWTEXT(VAR3A>60 AND VAR3E<VAR3D AND VAR3D>VAR3A,M5,'逃命! '), , COLORGREEN;
DRAWTEXT(VAR18>66 AND CROSS(VAR15,VAR18) OR VAR13=0 AND VAR1F>0 AND VAR17<15 OR VAR13=0 AND VAR1F=0 AND VAR1A>15,LOW-(HIGH-LOW)/2,'还要跌'), , COLORGREEN;
DRAWTEXT(VAR20>0.4 AND VAR18>97 AND VAR17>86 AND VAR15<10,M5,'还要涨'), , COLORRED;
DRAWTEXT(VAR20>0.65 AND VAR15<9,M5,'还要涨'), , COLORRED;

通达信买股均线主图指标公式

 

相关文章