在线检测未来函数

大智慧最新发现黑马指标公式

来源:Internet,编辑:股旁网,2011-01-09

a1:=1;
a2:=(5);
a3:=(((2 * CLOSE) + HIGH) + LOW) / 4;
a4:=LLV(LOW,34);
a5:=HHV(HIGH,34);
a6:=EMA((((a3 - a4) / (a5 - a4)) * 100),13);
a7:=(EMA(((0.667 * (REF(a6,1))) + (0.333 * a6)),2)) * a1;
决策线:(EMA(a7,a2)) * a1,colorRed;
a8:=(HHV(HIGH,9)) - (LLV(LOW,9));
a9:=(HHV(HIGH,9)) - CLOSE;
a10:=CLOSE - (LLV(LOW,9));
a11:=((a9 / a8) * 100) - 70;
a12:=((CLOSE - (LLV(LOW,60))) / ((HHV(HIGH,60)) - (LLV(LOW,60)))) * 100;
a13:=SMA(((a10 / a8) * 100),3,1);
a14:=(SMA(a13,3,1)) - (SMA(a11,9,1));
a15:=IF((a14 > 100),(a14 - 100),0);
a16:=(EMA((((a3 - a4) / (a5 - a4)) * 100),8)) * a1;
a17:=(EMA(a16,5)) * a1;
{股旁网-股票公式网站 www.GupAng.com}
STICKLINE(((a16 - a17) > 0),a16,a17,4,0),ColorFFAA18;
STICKLINE(((a16 - a17) < 0),a16,a17,4,0),ColorFFAA18;
a18:=(EMA(CLOSE,2)) * a1;
a19:=(EMA((((SLOPE(CLOSE,21)) * 20) + CLOSE),42)) * a1;
a20:=(HHV((MA(HIGH,13)),13)) * a1;
a21:=(LLV((MA(HIGH,13)),1)) * a1;
a22:=(EMA(CLOSE,4)) * a1;
a23:=((((a18 >= a19) AND (a21 = a20)) AND (a18 > a22)) AND (CLOSE > a21)) AND ((REF(a21,1)) < (REF(a20,1)));
a24:=BARSLAST(a23) + 1;
a25:=(LLV(LOW,a24)) * 1.3;
a26:=(LLV(LOW,20)) * 1.418;
a27:=(((((a18 >= a19) AND (a21 = a20)) AND ((CLOSE / (REF(CLOSE,1))) >= 1.07)) AND (a24 <= 30)) AND (CLOSE <= a25)) AND (CLOSE <= a26);
a28:=a27 AND (FILTER(a27,a24));
a29:=(STRFIND(STKNAME,'ST',1)) > 0;
a30:=((((((a18 >= a19) AND (a21 = a20)) AND ((CLOSE / (REF(CLOSE,1))) >= 1.035)) AND (a24 <= 30)) AND (CLOSE <= a25)) AND (CLOSE <= a26)) AND a29;
a31:=a30 AND (FILTER(a30,20));
DRAWICON((a28 OR a31),决策线,7),ALIGN1;
DRAWTEXT((a28 OR a31),决策线,'←黑马'),colorRed;
DRAWTEXTREL(3,30,'XXXX:XXXXXXXXX'),colorWhite;
DRAWTEXTREL(3,880,'说明:蓝柱在红线上逢低介入,蓝柱在红线下逢高离场。'),colorWhite;

大智慧最新发现黑马指标公式

 

相关文章