在线检测未来函数

通达信爆发能量指标公式

来源:Internet,编辑:股旁网,2011-01-06

N:=15;
SAT:=IF((AMOUNT/C)/(HHV(AMOUNT,N)/HHV(C,N))*100>100,100,(AMOUNT/C)/(HHV(AMOUNT,N)/HHV(C,N))*100);
能量:SAT,VOLSTICK;
压力:HHV((AMOUNT/C)/HHV(AMOUNT,N)/HHV(C,N)*100*C,N);
STICKLINE(((CLOSE > 0) AND ISLASTBAR),20,121,5.5,1),COLORFFFFFF;
{股旁网-股票公式网站 www.GupAng.com}
STICKLINE(((SAT <= 5) AND ISLASTBAR),21,(20 + SAT),5,0),COLORFFFFFF;
STICKLINE((((SAT > 5) AND (SAT <= 20)) AND ISLASTBAR),21,(20 + SAT),5,0),COLORCCFF88;
STICKLINE((((SAT > 20) AND (SAT <= 40)) AND ISLASTBAR),21,(20 + SAT),5,0),COLORFF00FF;
STICKLINE(((SAT > 40) AND ISLASTBAR),21,(20 + SAT),5,0),COLOR0000FF;
{下面崔先生加}
STICKLINE(SAT>=100,30,SAT,1,0),COLOR0000FF,LINETHICK9;
DRAWTEXT(SAT>=100,SAT*1.05,'*'),COLOR00FFFF,LINETHICK3;
DRAWTEXT(FILTER(SAT>=100,100),10+SAT,'【爆发量】'),COLORCCFFCC;
DRAWTEXT(SAT=100 AND ISLASTBAR,28+SAT,'爆发'),COLORYELLOW;
能量值%:IF(SAT>0,SAT,DRAWNULL),COLORYELLOW,LINETHICK0;

通达信爆发能量指标公式

 

相关文章