在线检测未来函数

通达信五彩量能指标公式

来源:Internet,编辑:股旁网,2011-01-08

VAR2:=HIGH-LOW;
VAR3:=ABS(OPEN-CLOSE);
VAR4:=HIGH-IF(CLOSE>OPEN,CLOSE,OPEN);
VAR5:=IF(CLOSE>OPEN,OPEN,CLOSE)-LOW;
VAR6:=VAR3/VAR2*VOL;
VAR7:=VAR4/VAR2*VOL;
VAR8:=VAR5/VAR2*VOL;
VAR9:=IF(VOL/CAPITAL>0.001,1,EXP(ABS(LOG(VOL/CAPITAL*100))));
VARA:=(CLOSE-MA(CLOSE,5))/MA(CLOSE,5)*100;
VARB:=MA(CLOSE,5)>MA(CLOSE,10) AND MA(CLOSE,10)>MA(CLOSE,30) AND MA(CLOSE,30)>MA(CLOSE,60);
VARC:=MA(CLOSE,5)<MA(CLOSE,10) AND MA(CLOSE,10)<MA(CLOSE,30);
多头成交: STICKLINE(CLOSE>MA(CLOSE,30),0,VOL,2.5,1), , COLORRED;
空头成交: STICKLINE(CLOSE<MA(CLOSE,30),0,VOL,2.5,1), , COLORGREEN;
{股旁网-股票公式网站 www.GupAng.com}
向上攻击量: STICKLINE(VAR6>=VAR7 AND VAR6>=VAR8 AND CLOSE>OPEN,0,VAR6,2.5,0), , COLORRED;
向下攻击量: STICKLINE(VAR6>=VAR7 AND VAR6>=VAR8 AND CLOSE<OPEN,0,VAR6,2.5,0), , COLORGREEN;
上探量: STICKLINE(VAR7>VAR6 AND VAR7>VAR8,0,VAR7,2.5,0), , COLORCCCC66;
下探量: STICKLINE(VAR8>VAR6 AND VAR8>VAR7,0,VAR8,2.5,0), , COLORFF6633;
相对地量: STICKLINE(VAR9>2 AND VOL<MA(VOL,5)/2,0,VOL,2.5,0), , COLORYELLOW;
地量: DRAWTEXT(VAR9>2 AND VOL<MA(VOL,5)/2,VOL,'地量'), , COLORYELLOW;
放量: STICKLINE(VOL>MA(VOL,5)*2.5,0,VOL,2.5,0), , COLORWHITE;
逢高出货: DRAWTEXT(VAR7>VAR6 AND VARA>2 AND VAR7>VAR8 AND CLOSE>MA(CLOSE,5) AND CLOSE>MA(CLOSE,30) AND HIGH>MA(CLOSE,60) AND VOL>MA(VOL,5) AND VAR7>=MA(VOL,5),VOL,'逢高出货'), , COLORGREEN;
逢低跟进: DRAWTEXT(VAR8>VAR6 AND VAR8>VAR7 AND VARA<-2 AND CLOSE<MA(CLOSE,30) AND VAR8<MA(VOL,5)/2 AND MA(VOL,5)<MA(VOL,10),VOL,'逢低跟进'), , COLORWHITE;
强势参与: DRAWTEXT(VAR6>MA(VOL,5)*2 AND VAR6>=VAR7 AND VAR6>=VAR8 AND CLOSE>OPEN OR VOL>MA(VOL,5)*3 AND VARB,VOL,'强势参与'), , COLORCC99CC;
空头释放: DRAWTEXT(VAR6>=VAR7 AND VAR6>=VAR8 AND CLOSE<OPEN AND VAR6/VOL>0.7 AND VARC AND VAR6>MA(VOL,5),VAR6*2,'空头释放'), , COLORGREEN;
{MA5:MA(VOL,5), , COLORRED;
MA10: MA(VOL,10), , COLORGREEN;
MA20:MA(VOL,20), , COLORYELLOW;}
MA5:MA(VOL,5),COLORYELLOW;
MA13:MA(VOL,13),COLORWHITE;
DRAWTEXT(CROSS(MA5,MA13),CROSS(MA5,MA13),'注意'),COLORWHITE;

通达信五彩量能指标公式

 

相关文章