在线检测未来函数

通达信机构洗盘指标公式

来源:Internet,编辑:股旁网,2011-01-18

VAR01:=LLV(L,10); VAR02:=HHV(H,25);
趋势线:=EMA((C-VAR01)/(VAR02-VAR01)*4,4);
价:=EMA(MA((((C-REF(C,1))+(H-REF(H,1))+(L-REF(L,1)))/3)/C,5),1);
价5:=MA(价,5);
量:=EMA(MA((V-REF(V,1))/V,5),1);
量5:=MA(量,5);
角:=1>(ATAN((C/REF(C,1)-1)*100)*180/3.14115926)>-1;
W:=(C/REF(C,1))>1.01;
横盘:=REF(((HHV(价,3)-LLV(价,3))/LLV(价,3)),1)<=(0.00/100) AND REF(((HHV(价5,3)-LLV(价5,3))/LLV(价5,3)),1)<=(0.00/100);
量横盘:=REF(((HHV(量,3)-LLV(量,3))/LLV(量,3)),1)<=(0.00/100) AND REF(((HHV(量5,3)-LLV(量5,3))/LLV(量5,3)),1)<=(0.00/100);
量比:=((量+REF(量,1)+REF(量,2))/(量5+REF(量5,1)+REF(量5,2)))>0.5;
A:=COUNT(0.00<=价<=0.02 AND 0.00<=价5<=0.02,CROSS(价,价5))=1 AND W ,COLORYELLOW;
ABB:=COUNT(0.00<=价<=0.02 AND 0.00<=价5<=0.02,横盘 AND 量比 AND 量横盘 AND 角)=1 AND W ,COLORRED;
逃顶高手:=A AND ABB;
地量一:=MA(V,3)/MA(V,20)<0.4;
地量二:=COUNT(V/(V,20)<0.4,3)=3;
地量三:=V/MA(V,30)<0.5 AND V/HHV(V,30)<0.2;
AA:=SUMBARS(VOL,CAPITAL);
地量四:=VOL<MA(VOL,AA)/3;
地量选股:=(地量一 OR 地量二 OR 地量三 OR 地量四)=1 AND (REF(地量一,1) OR REF(地量二,1) OR REF(地量三,1) OR REF(地量四,1))=0;
P1:=5;
P2:=4;
VARAB:=LLV(LOW,P1);
VARBB:=HHV(HIGH,P1);
KA1:=MA((CLOSE-VARAB)/(VARBB-VARAB)*100,P2),COLORRED;
DA1:=MA(0.667*REF(KA1,1)+0.333*KA1,2),COLORWHITE;
庄家:=KA1;
散户:=DA1;
低吸:=CROSS(庄家,散户) AND 庄家<30;
VAR2D:=(2*CLOSE+HIGH+LOW)/4;
VAR03:=IF(YEAR>=2099 AND MONTH>2,0,1);
VAR04:=LLV(LOW,5);
VAR05:=HHV(HIGH,4);
庄家1:= EMA((VAR2D-VAR04)/(VAR05-VAR04)*100,4)*VAR03;
散户1:= EMA(0.667*REF(庄家1,1)+0.333*庄家1,2)*VAR03;
短进1:=CROSS(庄家1,散户1) AND 庄家1<50 AND 29<庄家1;
低吸1:=CROSS(庄家1,散户1) AND 庄家1<30;
买入:=逃顶高手 AND 低吸 AND (短进1 OR 低吸1) AND 趋势线>REF(趋势线,1);
{短线买入立柱图}
STICKLINE(买入,0,6,3,0),COLORRED;
DRAWICON(买入,5,5)COLORFF00FF ;
DRAWTEXT(逃顶高手 AND 地量选股,2,'地量'),COLORYELLOW;
DRAWTEXT(买入,4.5,'短线买入'),COLORYELLOW; VAR21:=REF(CLOSE,1);
VAR22:=((SMA(MAX((CLOSE - VAR21),0),6,1) / SMA(ABS((CLOSE - VAR21)),6,1) * 100));
短期顶部:CROSS(+80,VAR22) *8,COLORWHITE,LINETHICK2,STICK;
LC:=REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
卖点:=CROSS(85,RSI1)*30,COLOR00FF00,LINETHICK2;
卖:IF(卖点,6.5,0),STICK,COLORGREEN,LINETHICK4;
洗钱A:=(CLOSE-LLV(LOW,32))/(HHV(HIGH,32)-LLV(LOW,32))*1.2*CLOSE;
量1:=EMA(洗钱A,3);
量2:=EMA(洗钱A,5);
量3:=EMA(洗钱A,7);
STICKLINE(量1>量2,量3,量1,3,1),COLORRED;
STICKLINE(量1<量2,量3,量1,2,0),COLORCYAN;
T1:=量2>量3 AND 量1<REF(量1,1);
T2:=量2<量3 AND 量1>REF(量1,1);
STICKLINE(T1,量1,量3,2,0),COLORYELLOW;
STICKLINE(T2,量1,量3,3,1),COLORFF00FF;
洗钱B:=SMA(洗钱A,13,1);
分水岭:SMA(洗钱B,2.5,1.5),LINETHICK2,COLORWHITE;
牛线:3*洗钱B-2*分水岭,LINETHICK2,COLORFF00FF ;
熊线:4*分水岭-3*洗钱B,LINETHICK2,COLORFF6633;
DIF1:=EMA(C,12)-EMA(C,26);
DEA1:=EMA(DIF1,9);
MACD1:=2*(DIF1-DEA1);
QZQ:=BARSLAST(REF(MACD,1)<0 AND MACD>0);
QM:=LLVBARS(MACD1,QZQ+20);
MQDZ:=IF(QM>QZQ,REF(MACD1,QM),0);
QF:=LLVBARS(DIF1,QZQ+20);
DQDZ:=IF(QF>QZQ,REF(DIF1,QF),0);
XG1:=MACD1<0 AND MACD1>MQDZ AND DIF1<0 AND DIF1>DQDZ AND C=LLV(C,QZQ+20) AND MQDZ<0 AND DQDZ<0;
XG:REF(XG1,1)=1 AND MACD1>REF(MACD1,1);
VAR21A:=(REF(HIGH,1)+REF(LOW,1))/2;
VAR61:=REF(CLOSE,1); VAR70A:=SMA(MAX(CLOSE-VAR61,0),6,1)/SMA(ABS(CLOSE-VAR61),6,1)*100;
{股旁网-股票公式网站 www.GupAng.com}
DRAWICON(CROSS(90,VAR70A),H*0.8.04,9); MTM1:=C-REF(C,1);
A013:=HHV(HIGH,34);
A014:=(2*CLOSE+HIGH+LOW)/4;
A015:=LLV(LOW,34);
A016:=EMA(((A014-A015)/(A013-A015))*100,13);
A017:=EMA(0.667*REF(A016,1)+0.333*A016,2);
KKMD:=A016-A017>1 AND A016<30 AND A017<30;
DRAWTEXT(FILTER(KKMD,30),L*0.05,'▲短买'),COLOR00FFFF;
VAR06:=REF(C,1);
VAR07:=SMA(MAX(C-VAR06,0),6,1)/SMA(ABS(C-VAR06),6,1)*100;
DRAWTEXT(CROSS(82,VAR07),H*0.9,'◤减仓'),COLORGREEN;
RSVB:=(C-LLV(L,25))/(HHV(HIGH,25)-LLV(L,25))*100;
K:=SMA(RSVB,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
VARA6:=(2*C+H+L)/3;
VARA7:=EMA(EMA(EMA(VARA6,4),4),4);
VARA8:=(VARA7-REF(VARA7,1))/REF(VARA7,1)*100;
VARA9:=MA(VARA8,3)+0.03;
VARA10:=MA(VARA8,1);
DRAWICON(CROSS(VARA9,VARA10) AND J>90,H*0.96,12),COLORGREEN;
DRAWTEXT(CROSS(VARA9,VARA10) AND J>90,H*1.02,'卖'),COLORCYAN;
LCD:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LCD,0),4.1,1)/SMA(ABS(CLOSE-LCD),4.1,1)*100;
建仓:CROSS(RSI,11)*10,COLORRED;

通达信机构洗盘指标公式

 

相关文章