在线检测未来函数

飞狐KDJ双循环指标公式

来源:Internet,编辑:股旁网,2011-01-23

50,coloryellow,pointdot;
fVar2:=REF(LOW,1);
fVar3:=SMA(ABS(LOW-fVar2),13,1)/SMA(MAX(LOW-fVar2,0),13,1)*100;
fVar4:=EMA(fVar3,13);
fVar5:=LLV(LOW,34);
fVar8:=EMA(IF(LOW<=fVar5,fVar4,0),3);
fVar9:=EMA(CLOSE,5);
fVar10:=(CLOSE-MA(CLOSE,34))/MA(CLOSE,34)*(-10);
STICKLINE(fVar9>REF(fVar9,1),90,(90-fVar9*0.08/6),5,1),color10E410;
减仓:IF(fVar9>REF(fVar9,1),fVar9,0),color10E410,linethick0;
STICKLINE(fVar9<REF(fVar9,1),90,(90-fVar9*0.08/6),5,1),color1010FF;
增仓:IF(fVar9<REF(fVar9,1),fVar9,0),color1010FF,linethick0;
STICKLINE(fVar8>REF(fVar8,1),90,(90-fVar8/6),7,1),color10FFFF;
主力进埸c:IF(fVar8>REF(fVar8,1),fVar8*8,0),color10FFFF,linethick0;
STICKLINE(fVar8<REF(fVar8,1),90,(90-fVar8/6),7,1),colorFFF810;
洗緩:IF(fVar8<REF(fVar8,1),fVar8*10,0),colorFFF810,linethick0;
主力持仓:=(LOW*5);
增仓力度:=fVar10;
XL1:=MA(LOW,2)*0.96;
XL2:=MA(LOW,26)*0.85;
XL3:=REF(XL1,1)<XL2 AND REF(XL1,1)<XL1 AND REF(XL1,1)<REF(XL1,2);
STICKLINE(XL3,90,(90-fVar8*3/6),7,0),Color006EFF;
DRAWTEXT(XL3,fVar8*2/7,'?'),Color006EFF;
↑买:DRAWICON(XL3,0,4),COLORRED;
SVar4:=LLV(LOW,83);
SVar5:=HHV(HIGH,83);
SVar6:=(SVar5-SVar4)/90;
SVar7:=SMA((CLOSE-SVar4)/SVar6,20,1);
SVar8:=SMA((OPEN-SVar4)/SVar6,20,1);
SVar9:=3*SVar7-2*SMA(SVar7,15,1);
SVar9a:=3*SVar7-2*SMA(SVar7,15,1);
STICKLINE(svar9>ref(svar9,1) ,svar9,ref(ma(svar9,3),1),8 ,1),colorred;
STICKLINE(svar9<ref(svar9,1) ,svar9,ref(ma(svar9,3),1),8 ,0),colorff9900;
Var1:=1/WINNER(CLOSE);
Var2:=MA(CLOSE,13);
Var3:=100-ABS((CLOSE-Var2)/Var2*100);
Var4:=LLV(LOW,20);
Var5:=HHV(HIGH,20);
Var6:=(Var5-Var4)/95;
Var7:=SMA((CLOSE-Var4)/Var6,20,1);
Var8:=SMA((OPEN-Var4)/Var6,20,1);
Var9:=2.5*Var7-1.5*SMA(Var7,15,1);
Var9a:=2.5*Var7-1.5*SMA(Var7,15,1);
STICKLINE(var9>ref(var9,1) ,var9,ref(ma(var9,3),1),8 ,1),colormagenta;
STICKLINE(var9<ref(var9,1) ,var9,ref(ma(var9,3),1),8 ,0),color00cc33;
VarA:=3*Var8-2*SMA(Var8,15,1);
VarB:=100-VarA;
进場系數:=(100-Var9);
出貨量:= MA(WINNER(CLOSE*0.95)*100,3);
进貨量:= (100-IF(Var1>5,IF(Var1<100,Var1,Var3-10),0));
VarD:=出貨量>Var3;
VarE:=REF(LOW,1)*0.9;
VarF:=LOW*0.9;
Var10:=(VarF*VOL+VarE*(CAPITAL-VOL))/CAPITAL;
Var11:=EMA(Var10,30);
Var12:=CLOSE-REF(CLOSE,1);
Var13:=MAX(Var12,0);
Var14:=ABS(Var12);
Var15:=SMA(Var13,7,1)/SMA(Var14,7,1)*100;
Var16:=SMA(Var13,13,1)/SMA(Var14,13,1)*100;
Var17:=BARSCOUNT(CLOSE);
Var18:=SMA(MAX(Var12,0),6,1)/SMA(ABS(Var12),6,1)*100;
Var19:=(-200)*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))+100;
Var1A:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;
{股旁网-股票公式网站 www.GupAng.com}
Var1B:=SMA((SMA(Var1A,4,1)-50)*2,3,1);
Var1C:=(INDEXC-LLV(INDEXL,14))/(HHV(INDEXH,14)-LLV(INDEXL,14))*100;
Var1D:=SMA(Var1C,4,1);
Var1E:=SMA(Var1D,3,1);
Var1F:=(HHV(HIGH,30)-CLOSE)/CLOSE*100;
Var20:=Var18<=25 AND Var19<-95 AND Var1F>20 AND Var1B<-30 AND Var1E<30 AND Var11-CLOSE>=-0.25 AND Var15<22 AND Var16<28 AND Var17>50;
Var21:=(HIGH+LOW+CLOSE)/3;
Var22:=(Var21-MA(Var21,14))/(0.015*AVEDEV(Var21,14));
Var23:=(Var21-MA(Var21,70))/(0.015*AVEDEV(Var21,70));
Var24:=IF(Var22>=150 AND Var22<200 AND Var23>=150 AND Var23<200,10,0);
Var25:=IF(Var22<=-150 AND Var22>-200 AND Var23<=-150 AND Var23>-200,-10,Var24);
Var26:=((CLOSE-HHV(LOW,15))/(HHV(HIGH,15)-HHV(LOW,15))*75+400)/5;
Var27:=REVERSE(Var26);
Var28:=SMA(Var26,3,1);
Var29:=SMA(Var28,3,1);
var30:var28*1.5-0.5*var29,colorff9999;
var30a:var30,color3300ff,linethick3,pointdot;
散戶:SMA(Var28,3,1)*1,color0066ff;
散戶a:散戶,colorwhite ,linethick3,pointdot ;
庄家:= SMA(散戶,3,1);
见頂: IF(CROSS(散戶,庄家) AND 散戶<30,庄家-庄家*0.3,0),coloryellow;
见底: IF(CROSS(庄家,散戶) AND 庄家>75,庄家,100)*1,colorwhite ;
DRAWicon(CROSS(var30,散戶) AND 散戶<30,散戶*0.95,8);
DRAWicon(CROSS(散戶,var30) AND 庄家>75,庄家+15,5);
预警:= (IF(Var23>=200 AND Var22>=150,15,IF(Var23<=-200 AND Var22<=-150,-15,Var25))+50);
DRAWTEXT(CROSS(Var20,0.5) AND COUNT(Var20=1,10)=1,35,' BOTM');
DRAWTEXT(CROSS(VarD,0.5) AND COUNT(VarD=1,10)=1,65,' TOP');

飞狐KDJ双循环指标公式

 

相关文章