在线检测未来函数

飞狐RSI划线指标公式

来源:Internet,编辑:股旁网,2011-01-23

LC :=REF(CLOSE,1);
RSI1:SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100-100,COLORFFFFFF;
RSI2:SMA(MAX(CLOSE-LC,0),12,1)/SMA(ABS(CLOSE-LC),12,1)*100-100,COLOR00FFFF;
RSI3:SMA(MAX(CLOSE-LC,0),24,1)/SMA(ABS(CLOSE-LC),24,1)*100-100,COLORGREEN;
GC:=(RSI1+2*RSI2+3*RSI3)/6+50;
GCD:=EMA(GC,3);
GMCD:=GCD-50;
GMCDA:=if(GCD<ref(GCD,1)and GCD>0,1,0);
GMCDB:=IF(GCD>=ref(GCD,1)and GCD>0,1,0);
GMCDC:=IF(GCD>ref(GCD,1)and GCD<0,1,0);
GMCDD:=IF(GCD<=ref(GCD,1)and GCD<0,1,0);
STICKLINE(GMCDA=1,-50,GMCD,6,0),COLOR00AAFF;{黄色段}
STICKLINE(GMCDA=1,-50,GMCD,6.6,0),COLOR00BBFF;
STICKLINE(GMCDA=1,-50,GMCD,4.4,0),COLOR00CCFF;
STICKLINE(GMCDA=1,-50,GMCD,3.3,0),COLOR00DDFF;
STICKLINE(GMCDA=1,-50,GMCD,2.2,0),COLOR00EEFF;
STICKLINE(GMCDA=1,-50,GMCD,1.1,0),COLOR00FFFF;
STICKLINE(GMCDB=1,-50,GMCD,6,0),COLOR0000AA; {红色段}
STICKLINE(GMCDB=1,-50,GMCD,6.6,0),COLOR0011BB;
STICKLINE(GMCDB=1,-50,GMCD,4.4,0),COLOr0022CC;
STICKLINE(GMCDB=1,-50,GMCD,3.3,0),COLOR0033DD;
STICKLINE(GMCDB=1,-50,GMCD,2.2,0),COLOR0044EE;
STICKLINE(GMCDB=1,-50,GMCD,1.1,0),COLOR0055FF;
STICKLINE(GMCDC=1,-50,GMCD,6,0),COLORAA00BB;{向上粉红}
STICKLINE(GMCDC=1,-50,GMCD,6.6,0),COLORBB11BB;
STICKLINE(GMCDC=1,-50,GMCD,4.4,0),COLORCC22BB;
STICKLINE(GMCDC=1,-50,GMCD,3.3,0),COLORDD33BB;
STICKLINE(GMCDC=1,-50,GMCD,2.2,0),COLOREE44BB;
STICKLINE(GMCDC=1,-50,GMCD,1.1,0),COLORFF55BB;
STICKLINE(GMCDD=1,-50,GMCD,6,0),COLORFF7700;
STICKLINE(GMCDD=1,-50,GMCD,6.6,0),COLORFF8811;
STICKLINE(GMCDD=1,-50,GMCD,4.4,0),COLORFFAA22;
STICKLINE(GMCDD=1,-50,GMCD,3.3,0),COLORFFBB33;
STICKLINE(GMCDD=1,-50,GMCD,2.2,0),COLORFFDD44;
STICKLINE(GMCDD=1,-50,GMCD,1.1,0),COLORFFFF55;
TY:=RSI1;
AA:=REF(TY,3)=HHV(TY,2*3+1);
BB:=BACKSET(AA,3+1);
CC:=FILTER(BB,3) AND TY=HHV(TY,3+1);
AA2:=REF(TY,3)=LLV(TY,2*3+1);
BB2:=BACKSET(AA2,3+1);
CC2:=FILTER(BB2,3) AND TY=LLV(TY,3+1);
GG:=BARSTATUS=2 AND REF(CC,BARSLAST(CC));
HH:=BACKSET(GG,BARSLAST(CC)+1);
{股旁网-股票公式网站 www.GupAng.com}
II:=HH>REF(HH,1);
JJ:=REF(BARSLAST(CC),1);
KK:=BACKSET(II,JJ+2);
LL:=KK>REF(KK,1);
DRAWLINE(LL,TY,II,TY,1),POINTDOT,COLORMAGENTA;
CS:=(REF(TY,BARSLAST(II))-REF(TY,BARSLAST(LL)))/(BARSLAST(LL)-BARSLAST(II));
阻力线:=REF(TY,BARSLAST(II))+BARSLAST(II)*CS;
阻力值:阻力线,LINETHICK0;
GG2:=BARSTATUS=2 AND REF(CC2,BARSLAST(CC2));
HH2:=BACKSET(GG2,BARSLAST(CC2)+1);
II2:=HH2>REF(HH2,1);
JJ2:=REF(BARSLAST(CC2),1);
KK2:=BACKSET(II2,JJ2+2);
LL2:=KK2>REF(KK2,1);
DRAWLINE(LL2,TY,II2,TY,1),POINTDOT,COLORGREEN;
阻力线:=REF(TY,BARSLAST(II))+BARSLAST(II)*CS;
DRAWICON(CROSS(TY,阻力线),RSI1*0.8,6);{上涨阻力降低三角符}
DRAWICON(CC2,RSI1*0.96,8);{下三角形}
DRAWICON(CC,RSI1*0.6,5);{上三角形}

飞狐RSI划线指标公式

 

相关文章