在线检测未来函数

通达信筹码堆积+机构割肉线主图指标公式

来源:Internet,编辑:股旁网,2011-01-24

DA1:=IF(130>TOTALBARSCOUNT,TOTALBARSCOUNT,130);
DA:=IF(CURRBARSCOUNT>DA1,0,DA1);
HI:=REFDATE(HHV(H,DA),DATE);
LO:=REFDATE(LLV(L,DA),DATE);
C1:=IF(CURRBARSCOUNT<=DA,C,DRAWNULL);
GZ:=EXP(LN(HI/LO)/10);
LH1:=SUM(IF(C1>=(HI/GZ),V,0),DA);
LH2:=SUM(IF(C1>=(HI/POW(GZ,2)) AND C1<(HI/GZ),V,0),DA);
LH3:=SUM(IF(C1>=(HI/POW(GZ,3)) AND C1<(HI/POW(GZ,2)),V,0),DA);
LH4:=SUM(IF(C1>=(HI/POW(GZ,4)) AND C1<(HI/POW(GZ,3)),V,0),DA);
LH5:=SUM(IF(C1>=(HI/POW(GZ,5)) AND C1<(HI/POW(GZ,4)),V,0),DA);
LH6:=SUM(IF(C1>=(HI/POW(GZ,6)) AND C1<(HI/POW(GZ,5)),V,0),DA);
LH7:=SUM(IF(C1>=(HI/POW(GZ,7)) AND C1<(HI/POW(GZ,6)),V,0),DA);
LH8:=SUM(IF(C1>=(HI/POW(GZ,8)) AND C1<(HI/POW(GZ,7)),V,0),DA);
LH9:=SUM(IF(C1>=(LO*GZ) AND C1<LO*POW(GZ,2),V,0),DA);
LH10:=SUM(IF(C1>=LO AND C1<LO*GZ,V,0),DA);
L1:=REFDATE(HHV(LH1,DA),DATE),LINETHICK0;
L2:=REFDATE(HHV(LH2,DA),DATE),LINETHICK0;
L3:=REFDATE(HHV(LH3,DA),DATE),LINETHICK0;
L4:=REFDATE(HHV(LH4,DA),DATE);
L5:=REFDATE(HHV(LH5,DA),DATE);
L6:=REFDATE(HHV(LH6,DA),DATE);
L7:=REFDATE(HHV(LH7,DA),DATE);
L8:=REFDATE(HHV(LH8,DA),DATE);
L9:=REFDATE(HHV(LH9,DA),DATE);
L10:=REFDATE(HHV(LH10,DA),DATE);
SS:=(L1+L2+L3+L4+L5+L6+L7+L8+L9+L10);
STICKLINE(CEILING(DA*L1/SS)*3>=CURRBARSCOUNT,HI*99/100,HI/GZ,9,0)COLOR3C3C3A,LINETHICK3;
STICKLINE(CEILING(DA*L2/SS)*3>=CURRBARSCOUNT,HI/POW(GZ,1)*99/100,HI/POW(GZ,2),9,0)COLOR3C3C3A,LINETHICK3;
STICKLINE(CEILING(DA*L3/SS)*3>=CURRBARSCOUNT,HI/POW(GZ,2)*99/100,HI/POW(GZ,3),9,0)COLOR3C3C3A,LINETHICK3;
STICKLINE(CEILING(DA*L4/SS)*3>=CURRBARSCOUNT,HI/POW(GZ,3)*99/100,HI/POW(GZ,4),9,0)COLOR3C3C3A,LINETHICK3;
STICKLINE(CEILING(DA*L5/SS)*3>=CURRBARSCOUNT,HI/POW(GZ,4)*99/100,HI/POW(GZ,5),9,0)COLOR3C3C3A,LINETHICK3;
STICKLINE(CEILING(DA*L6/SS)*3>=CURRBARSCOUNT,HI/POW(GZ,5)*99/100,HI/POW(GZ,6),9,0)COLOR3C3C3A,LINETHICK3;
STICKLINE(CEILING(DA*L7/SS)*3>=CURRBARSCOUNT,HI/POW(GZ,6)*99/100,HI/POW(GZ,7),9,0)COLOR3C3C3A,LINETHICK3;
STICKLINE(CEILING(DA*L8/SS)*3>=CURRBARSCOUNT,LO*POW(GZ,2),LO*POW(GZ,3)*99/100,9,0)COLOR3C3C3A,LINETHICK3;
STICKLINE(CEILING(DA*L9/SS)*3>=CURRBARSCOUNT,LO*POW(GZ,1),LO*POW(GZ,2)*99/100,9,0)COLOR3C3C3A,LINETHICK3;
STICKLINE(CEILING(DA*L10/SS)*3>=CURRBARSCOUNT,LO,LO*POW(GZ,1)*99/100,9,0)COLOR3C3C3A,LINETHICK3;
DRAWKLINE(H,O,L,C);
{股旁网-股票公式网站 www.GupAng.com}
起始线:MA(CLOSE,9),COLORGRAY;
二九线:MA(CLOSE,18),COLORRED;
三九线:MA(C,27),LINETHICK2,COLORYELLOW;
神奇数字线:MA(C,73),LINETHICK2,COLOR000999;
季度线:MA(C,91.25),LINETHICK3,COLORGREEN;
割肉线:MA(C,160),COLORGREEN;
地球公转线:MA(C,365),COLOR0000FF,LINETHICK3;
金星绕太阳线:MA(C,584.92),LINETHICK3,COLORFFCC66;
地量:=FILTER(LLV(AMOUNT,120)=AMOUNT,10);
STICKLINE(地量,CLOSE,OPEN,8,0),COLORFFFFFF;
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);
DRAWTEXT(地量,LOW,' ↖地量'),COLOR999999;
预测量:=IF(CURRBARSCOUNT=1 AND PERIOD=5,VOL*240/FROMOPEN,DRAWNULL),NODRAW;
放量阴柱:=IF(FROMOPEN<220,预测量,VOL)>2*REF(VOL,1) AND C<O;
STICKLINE(放量阴柱,CLOSE,OPEN,6,0),COLOR004400;
STICKLINE(放量阴柱,CLOSE,OPEN,4,0),COLOR006600;
STICKLINE(放量阴柱,CLOSE,OPEN,2,0),COLOR008800;
STICKLINE(放量阴柱,CLOSE,OPEN,1,0),COLOR009900;
STICKLINE(放量阴柱,CLOSE,OPEN,0,0),COLOR00FF00;
放量阳柱:=FILTER(IF(FROMOPEN<220,预测量,VOL)>2*((REF(VOL,1)+REF(VOL,2)+REF(VOL,3)+REF(VOL,4))/4) AND C>O,5);
STICKLINE(放量阳柱,CLOSE,OPEN,6,0),COLOR004444;
STICKLINE(放量阳柱,CLOSE,OPEN,4,0),COLOR006666;
STICKLINE(放量阳柱,CLOSE,OPEN,2,0),COLOR008888;
STICKLINE(放量阳柱,CLOSE,OPEN,1,0),COLOR009999;
STICKLINE(放量阳柱,CLOSE,OPEN,0,0),COLOR00FFFF;

通达信筹码堆积+机构割肉线主图指标公式

 

相关文章