在线检测未来函数

通达信CCIKD指标公式

来源:Internet,编辑:股旁网,2011-02-15

N:=14;
TYP:=(H+L+C)/3;
CCI0:=(TYP-MA(TYP,N))/(0.015*AVEDEV(TYP,N));
K:=SMA(CCI0,3,1);
D:=SMA(K,3,1);
指数TYP:=(INDEXH+INDEXL+INDEXC)/3;
指数CCI:=(指数TYP-MA(指数TYP,N))/(0.015*AVEDEV(指数TYP,N));
{股旁网-股票公式网站 www.GupaNg.com}
DRAWBAND(K,RGB(175,0,0),D,RGB(0,150,0));
DRAWBAND(指数CCI,RGB(0,80,0),指数CCI,RGB(0,80,0));
CCI:CCI0,COLORWHITE;
K线:K,NODRAW,COLORYELLOW;
D线:D,NODRAW,COLORMAGENTA;
MKDD:K-D,COLORSTICK,COLORCYAN;
大盘CCI:指数CCI,COLORGREEN,NODRAW;
STICKLINE(MKDD>=REF(MKDD,1) && MKDD<=0,0,MKDD,0.5,0),COLORCYAN;
STICKLINE(MKDD>=REF(MKDD,1) && MKDD>0,0,MKDD,1,0),COLORRED;
AA:=IF(CROSS(CCI,MAX(K,D)),CCI,DRAWNULL);
DRAWBAND(AA,RGB(150,150,0),AA,RGB(150,150,0)),POINTDOT,LINETHICK4,COLORYELLOW;

通达信CCIKD指标公式

 

相关文章