在线检测未来函数

大智慧新不求人指标公式

来源:Internet,编辑:股旁网,2011-02-19

{背景}
DRAWRECTREL(0,10,200,1000,rgb(0,0,255)),layer0;
{DRAWGBKLAST(CLOSE>0,STRIP(RGB(55,75,55),RGB(10,10,20),0));}
{公式程式}
DRAWTEXTREL(230,20,'● 应用在底部选股 ●'),COLORyellow,linethick2;
VAR1:=(EMA(C,12)-EMA(C,26))*100+50;
VAR2:=EMA(VAR1,9);
VAR3:=((HHV(H,21)-C)/(HHV(H,21)-LLV(L,21)))*100-10;
VAR4:=((C-LLV(L,21))/(HHV(H,21)-LLV(L,21)))*100;
VAR5:=SMA(VAR4,13,8);
VAR6:=SMA(VAR3,21,8);
VAR7:=MA(C,80)-MA(C,10)/7;
VAR8:=EMA(C,5);
VAR9:=MA((LLV(C,9))*1.1,14);
VAR10:=2*VAR9-VAR8-C*0.1;
VAR11:=IF(((VAR8-VAR10)*5>0),(POW((VAR8-VAR10)*5,2))/10,(-1*(POW((VAR8-VAR10)*(5),2)))/(10));
VAR12:=IF((VAR11>0),VAR11-0,12);
VAR13:=SMA(MAX(C-REF(C,2),0),7,1)/SMA(ABS(C-REF(C,2)),7,1)*100;
VAR14:=(HHV(C,10)-C)/HHV(C,10)>0.05;
DRAWTEXTABS(5,5,'股旁网 www.gupang.com'),linethick1,COLOR00EEff;
趋势:CEILING(SMA(VAR5,13,8)),LINETHICK2,COLOR0000FF;
看底:IF((趋势-VAR6<(-65)),1,6),COLOR00FF00;
顶峰:IF((趋势-VAR6>85),95,100),COLORF0F000;
黄金区:IF(VAR13<15,15,0),COLORF0F000,linethick0;
DRAWICON(IF(VAR13<15,15,0),13,12),COLORYELLOW;
DRAWTEXT((趋势-VAR6<(-65)),5,'底'),COLORffffff;
DRAWTEXT((趋势-VAR6>85),90,'顶'),COLORgreen;
DRAWTEXT(if(VAR13<15,15,0),20,'黄金区'),COLORyellow;
操盘线: MA(3*SMA((C-LLV(L,27))/(HHV(H,27)-LLV(L,27))*100,5,1)-2*SMA(SMA((C-LLV(L,27))/(HHV(H,27)-LLV(L,27))*100,5,1),3,1),5),LINETHICK2,COLORBLUE;
DRAWICON(cross(趋势,操盘线),趋势,7),COLORyellow,ALIGN1;
STICKLINE(FILTER(趋势<REF(趋势,1)AND 趋势>75 OR CROSS(趋势,操盘线)AND 趋势<REF(趋势,1)AND 操盘线>60,5),100,60,8,1),COLORFFFF00;
{STICKLINE(FILTER(CROSS(趋势,VAR12)AND 趋势<REF(趋势,2)AND C>REF(C,1) OR 趋势>REF(趋势,1)AND 趋势<35 AND C>REF(C,1),5),5,50,9,2),COLOR00FF00;}
VAR15:FILTER(CROSS(趋势,VAR12)AND 趋势<REF(趋势,2)AND C>REF(C,1) OR 趋势>REF(趋势,1)AND 趋势<35 AND VAR14 AND C>REF(C,1),5);
STICKLINE(VAR15,50,0,4,0),COLOR00ff00;
DRAWTEXT(看底<6 AND VAR15,50,'●全仓'),colorred;
选股:看底<6 AND VAR15;
{当日及时行情}
DRAWTEXTREL(5,70,'今 趋势线:'+NUMTOSTRN(趋势,0)),COLORffffff,linethick1,layer0;
DRAWTEXTREL(5,250,'日 黄金区:'+NUMTOSTRN(黄金区,0)),COLORYELLOW,linethick1,layer0;
DRAWTEXTREL(5,430,'行 看 底:'+NUMTOSTRN(看底,0)),COLORFFFFFF,linethick1,layer0;
DRAWTEXTREL(5,610,'情 VAR 15:'+NUMTOSTRN(VAR15,0)),COLORffffff,linethick1,layer0;
DRAWTEXTREL(5,790,'表 选 股:'+NUMTOSTRN(选股,0)),COLORyellow,linethick1,layer0;
QS0:=趋势>操盘线 AND 顶峰=100;
QS1:=趋势<操盘线;
QS2:=趋势>操盘线 AND 顶峰=95;
IF BARSTATUS=2 AND QS0 THEN BEGIN
DRAWTEXTREL(25,70,' ● 趋势上 有钱!'),colorred,layer0;
END
ELSE
IF BARSTATUS=2 AND QS1 THEN BEGIN
DRAWTEXTREL(25,70,' ● 趋势下 快走!'),colorgreen,layer0;
END
ELSE
IF BARSTATUS=2 AND QS2 THEN BEGIN
DRAWTEXTREL(25,70,' ● 见顶 小心!'),colorgreen,layer0;
END
HJQ0:=黄金区=15;
HJQ1:=黄金区=0 AND 选股=0;
HJQ2:=黄金区=0 AND 选股=1;
IF BARSTATUS=2 AND HJQ0 THEN BEGIN
DRAWTEXTREL(25,250,' ● 佳 看底'),colorred,layer0;
END
ELSE
IF BARSTATUS=2 AND HJQ1 THEN BEGIN
DRAWTEXTREL(25,250,' ● 打80分?'),colorgreen,layer0;
END
ELSE
IF BARSTATUS=2 AND HJQ2 THEN BEGIN
DRAWTEXTREL(25,250,' ● 机会来了!'),colorred,layer0;
END
KD1:=看底<6;
KD2:=看底=6 AND 选股=0;
KD3:=看底=6 AND 选股=1;
IF BARSTATUS=2 AND KD1 THEN BEGIN
DRAWTEXTREL(25,430,' ● 见底了'),colorred,layer0;
END
ELSE
IF BARSTATUS=2 AND KD2 THEN BEGIN
DRAWTEXTREL(25,430,' ● 斗地主了!'),colorgreen,layer0;
END
ELSE
IF BARSTATUS=2 AND KD3 THEN BEGIN
DRAWTEXTREL(25,430,' ● 机会来了!'),colorred,layer0;
END
VA1:VAR15=1;
VA2:VAR15=0 AND 选股=0;
VA3:VAR15=0 AND 选股=1;
IF BARSTATUS=2 AND VA1 THEN BEGIN
DRAWTEXTREL(25,610,' ● 佳 可买进'),colorred,layer0;
END
ELSE
IF BARSTATUS=2 AND VA2 THEN BEGIN
DRAWTEXTREL(25,610,' ● 打麻将了'),colorgreen,layer0;
END
ELSE
IF BARSTATUS=2 AND VA3 THEN BEGIN
DRAWTEXTREL(25,610,' ● 机会来了!'),colorred,layer0;
END
xgg0:=选股=1;
xgg1:=选股=0;
IF BARSTATUS=2 AND xgg0 THEN BEGIN
DRAWTEXTREL(25,790,' ● 见底势强 买入'),colorred,layer0;
END
ELSE
IF BARSTATUS=2 AND xgg1 THEN BEGIN
DRAWTEXTREL(25,790,' ● 逛街去了'),colorgreen,layer0;
END;

大智慧新不求人指标公式

大智慧新不求人指标公式

 

相关文章