在线检测未来函数

飞狐筹码空间主图指标公式

来源:Internet,编辑:股旁网,2011-02-16

DRAWGBK(DATE>900101,COLORRGB(15,50,90),COLORRGB(0,0,0),1);//蓝色
{}
VARR1:=SMA(MAX(CLOSE-REF(C,1),0),6,1)/SMA(ABS(CLOSE-REF(C,1)),6,1)*100;
DRAWICON(CROSS(82,VARR1),HIGH,2);
DRAWTEXT(CROSS(82,VARR1),HIGH,' 短空'),COLORYELLOW;
{公式名称:筹码空间--主图}
input:n(156,0,1300);
A:=BARPOS;
A1:=SYSPARAM(1);
A2:=SYSPARAM(2);
A3:=SYSPARAM(3);
B:=DATACOUNT;
KB:B-A+1,LINETHICK0,colorFFFFFF;
HM:=A3-A2;
VERTLINE(N=KB),POINTDOT,colorFFFFFF;
MM:=(A3-A2)/100;
DW1:=A=A2+ROUND(MM*98);
DW2:=A=A2+ROUND(MM*46);
DW3:=A=A2+ROUND(MM*67);
ZQ:=DATATYPE;
BK1:=INBLOCK('A股板块');
BK2:=INBLOCK('深圳权证');
BK3:=INBLOCK('上海权证');
BK4:=INBLOCK('上海指数');
BK5:=INBLOCK('深圳指数');
流通:=IF((BK1 OR BK2 OR BK3)=1,CAPITAL,IF(BK4=1,ESTDATA(8),IF(BK5=1,ESTDATA(8),0)));
SOU:=VOL/CAPITAL*100;
JJ:=IF(BK1=1,AMOUNT/VOL/100,IF((BK3 OR BK2)=1,AMOUNT/VOL/100,CLOSE));
HQ:=HHV(HIGH,HM);
LQ:=LLV(LOW,HM);
ZH:=HQ;
ZL:=LQ;
Q:=(ZH-ZL)/10;
PC:=CLOSE;
SPJ:=PC;
Q1:=(SUM(IF(JJ>=ZH-1*Q,VOL,0),N))/流通*100;
Q2:=(SUM(IF(JJ<ZH-1*Q AND JJ>=ZH-2*Q,VOL,0),N))/流通*100;
Q3:=(SUM(IF(JJ<ZH-2*Q AND JJ>=ZH-3*Q,VOL,0),N))/流通*100;
Q4:=(SUM(IF(JJ<ZH-3*Q AND JJ>=ZH-4*Q,VOL,0),N))/流通*100;
Q5:=(SUM(IF(JJ<ZH-4*Q AND JJ>=ZH-5*Q,VOL,0),N))/流通*100;
Q6:=(SUM(IF(JJ<ZH-5*Q AND JJ>=ZH-6*Q,VOL,0),N))/流通*100;
Q7:=(SUM(IF(JJ<ZH-6*Q AND JJ>=ZH-7*Q,VOL,0),N))/流通*100;
Q8:=(SUM(IF(JJ<ZH-7*Q AND JJ>=ZH-8*Q,VOL,0),N))/流通*100;
Q9:=(SUM(IF(JJ<ZH-8*Q AND JJ>=ZH-9*Q,VOL,0),N))/流通*100;
Q10:=(SUM(IF(JJ<ZH-9*Q,VOL,0),N))/流通*100;
W:=A=SYSPARAM(3);
W2:=A=SYSPARAM(2);
STICKLINE(BACKSET(W,Q1[A1]/2)>0,ZH-0*Q,ZH-1*Q,10,0),color8F;
STICKLINE(BACKSET(W,Q2[A1]/2)>0,ZH-1*Q,ZH-2*Q,10,0),color8F;
STICKLINE(BACKSET(W,Q3[A1]/2)>0,ZH-2*Q,ZH-3*Q,10,0),colorFF;
STICKLINE(BACKSET(W,Q4[A1]/2)>0,ZH-3*Q,ZH-4*Q,10,0),colorFF;
STICKLINE(BACKSET(W,Q5[A1]/2)>0,ZH-4*Q,ZH-5*Q,10,0),colorAADD;
STICKLINE(BACKSET(W,Q6[A1]/2)>0,ZH-5*Q,ZH-6*Q,10,0),colorAADD;
STICKLINE(BACKSET(W,Q7[A1]/2)>0,ZH-6*Q,ZH-7*Q,10,0),color8C8EB5;
STICKLINE(BACKSET(W,Q8[A1]/2)>0,ZH-7*Q,ZH-8*Q,10,0),color8C8EB5;
STICKLINE(BACKSET(W,Q9[A1]/2)>0,ZH-8*Q,ZH-9*Q,10,0),color387C7C;
STICKLINE(BACKSET(W,Q10[A1]/2)>0,ZH-9*Q,ZH-10*Q,10,0),color387C7C;
POLYLINE(1,ZH-2*Q),color555555;
POLYLINE(1,ZH-4*Q),color555555;
POLYLINE(1,ZH-6*Q),color555555;
POLYLINE(1,ZH-8*Q),color555555;
STICKLINE(C>O,h,l,0,0),colorFF;
STICKLINE(C>O,C,O,6,0),colorFF;
STICKLINE(C<O,h,l,0,0),colorFFFF00;
STICKLINE(C<O,C,O,6,0),colorFFFF00;
总手:SUM(SOU,N),LINETHICK0,PRECISION0,colorFFFFFF;
套:(SUM(IF(CLOSE>=SPJ,VOL,0),N))/FINANCE(7),LINETHICK0,PRECISION0,colorFF00;
获利:(1-套/总手)*100,LINETHICK0,colorFF55FF;
均手:SUM(SOU,N)/N,LINETHICK0,colorFFFF;
顶部:=Q1+Q2;
中上:=Q3+Q4;
中部:=Q5+Q6;
中下:=Q7+Q8;
底部:=Q9+Q10;
ZC:=顶部+中上+中部+中下+底部;
顶比:=顶部/ZC*100;
上比:=中上/ZC*100;
中比:=中部/ZC*100;
下比:=中下/ZC*100;
底比:=底部/ZC*100;
DRAWTEXT(DW1,ZH-0.5*Q*-1,' 比重'),colorFFFFFF;
DRAWNUMBER(DW1,ZH-1*Q,顶比[A1],2),colorFFFFFF;
DRAWNUMBER(DW1,ZH-3*Q,上比[A1],2),colorFFFFFF;
DRAWNUMBER(DW1,ZH-5*Q,中比[A1],2),colorFFFFFF;
DRAWNUMBER(DW1,ZH-7*Q,下比[A1],2),colorFFFFFF;
DRAWNUMBER(DW1,ZH-8.8*Q,底比[A1],2),colorFFFFFF;
DRAWTEXT(DW2,ZH-0.5*Q*-1,'换手'),colorFFFFFF;
DRAWTEXTEX(CLOSE,1,450,130,NUMTOSTR(Q1[A1],0)+'/'+NUMTOSTR(Q2[A1],0)),colorFFFFFF;
DRAWTEXTEX(CLOSE,1,450,330,NUMTOSTR(Q3[A1],0)+'/'+NUMTOSTR(Q4[A1],0)),colorFFFFFF;
DRAWTEXTEX(CLOSE,1,450,520,NUMTOSTR(Q5[A1],0)+'/'+NUMTOSTR(Q6[A1],0)),colorFFFFFF;
DRAWTEXTEX(CLOSE,1,450,710,NUMTOSTR(Q7[A1],0)+'/'+NUMTOSTR(Q8[A1],0)),colorFFFFFF;
DRAWTEXTEX(CLOSE,1,450,880,NUMTOSTR(Q9[A1],0)+'/'+NUMTOSTR(Q10[A1],0)),colorFFFFFF;
DRAWTEXT(DW3 AND (BK1 OR BK2 OR BK3)=1,ZH-0.5*Q*-1,'价 '),ALIGN2,colorFFFFFF;
DRAWTEXT(DW3 AND (BK4 OR BK5)=1,ZH-0.5*Q*-1,'指数 '),ALIGN2,colorFFFFFF;
DRAWNUMBER(DW3,ZH-1*Q,ZH-2*Q,2),ALIGN2,colorFFFFFF;
DRAWNUMBER(DW3,ZH-3*Q,ZH-4*Q,2),ALIGN2,colorFFFFFF;
DRAWNUMBER(DW3,ZH-5*Q,ZH-6*Q,2),ALIGN2,colorFFFFFF;
DRAWNUMBER(DW3,ZH-7*Q,ZH-8*Q,2),ALIGN2,colorFFFFFF;
DRAWNUMBER(DW3,ZH-8.8*Q,ZH-10*Q,2),ALIGN2,colorFFFFFF;
{}
HZC:=(2*CLOSE+LOW+HIGH)/4;
HZE:=EMA(HZC,2);
HZD:=EMA(HZE,2);
HD1:=EMA(HZC,3);
//18线开花
a1:=EMA(CLOSE,5)>EMA(CLOSE,6) and EMA(CLOSE,6)>EMA(CLOSE,7) and EMA(CLOSE,7)>EMA(CLOSE,8) and EMA(CLOSE,8)>EMA(CLOSE,9)
and EMA(CLOSE,9)>EMA(CLOSE,10) and EMA(CLOSE,10)>EMA(CLOSE,11) and EMA(CLOSE,11)>EMA(CLOSE,12)
and EMA(CLOSE,12)>EMA(CLOSE,13) and EMA(CLOSE,13)>EMA(CLOSE,14) and EMA(CLOSE,14)>EMA(CLOSE,15)
and EMA(CLOSE,15)>EMA(CLOSE,20) and EMA(CLOSE,20)>EMA(CLOSE,30) and EMA(CLOSE,30)>EMA(CLOSE,60) and EMA(CLOSE,60)>EMA(CLOSE,90)
and EMA(CLOSE,90)>EMA(CLOSE,120) and EMA(CLOSE,120)>EMA(CLOSE,250);
a2:=EMA(CLOSE,5)>EMA(CLOSE,6) and EMA(CLOSE,6)>EMA(CLOSE,7) and EMA(CLOSE,7)>EMA(CLOSE,8) and EMA(CLOSE,8)>EMA(CLOSE,9)
and EMA(CLOSE,9)>EMA(CLOSE,10) and EMA(CLOSE,10)>EMA(CLOSE,11) and EMA(CLOSE,11)>EMA(CLOSE,12)
and EMA(CLOSE,12)>EMA(CLOSE,13) and EMA(CLOSE,13)>EMA(CLOSE,14);
b1:=IF(a1,1,2);
//DD=HD1:=EMA(HZC,3);
PARTLINE(b1=2,EMA(HD1,14)),ColorBLUE;PARTLINE(b1=2,EMA(HD1,15)),ColorBLUE;PARTLINE(b1=2,EMA(HD1,16)),ColorBLUE;
PARTLINE(b1=2,EMA(HD1,17)),ColorBLUE;PARTLINE(b1=2,EMA(HD1,18)),ColorBLUE;PARTLINE(b1=2,EMA(HD1,19)),ColorBLUE;
PARTLINE(b1=2,EMA(HD1,20)),ColorBLUE;PARTLINE(b1=2,EMA(HD1,21)),ColorBLUE;PARTLINE(b1=2,EMA(HD1,22)),ColorBLUE;
PARTLINE(b1=2,EMA(HD1,23)),ColorBLUE;PARTLINE(b1=2,EMA(HD1,24)),ColorBLUE;PARTLINE(b1=2,EMA(HD1,25)),ColorBLUE;
PARTLINE(a2,EMA(HD1,14)),Color2277ee; PARTLINE(a2,EMA(HD1,15)),Color2277ee; PARTLINE(a2,EMA(HD1,16)),Color2277ee;
PARTLINE(a2,EMA(HD1,17)),Color2277ee; PARTLINE(a2,EMA(HD1,18)),Color2277ee; PARTLINE(a2,EMA(HD1,19)),Color2277ee;
PARTLINE(a2,EMA(HD1,20)),Color2277ee; PARTLINE(a2,EMA(HD1,21)),Color2277ee; PARTLINE(a2,EMA(HD1,22)),Color2277ee;
PARTLINE(a2,EMA(HD1,23)),Color2277ee; PARTLINE(a2,EMA(HD1,24)),Color2277ee; PARTLINE(a2,EMA(HD1,25)),Color2277ee;
PARTLINE(a1,EMA(HD1,14)),ColorRED; PARTLINE(a1,EMA(HD1,15)),ColorRED; PARTLINE(a1,EMA(HD1,16)),ColorRED;
PARTLINE(a1,EMA(HD1,17)),ColorRED; PARTLINE(a1,EMA(HD1,18)),ColorRED; PARTLINE(a1,EMA(HD1,19)),ColorRED;
PARTLINE(a1,EMA(HD1,20)),ColorRED; PARTLINE(a1,EMA(HD1,21)),ColorRED; PARTLINE(a1,EMA(HD1,22)),ColorRED;
PARTLINE(a1,EMA(HD1,23)),ColorRED; PARTLINE(a1,EMA(HD1,24)),ColorRED; PARTLINE(a1,EMA(HD1,25)),ColorRED;
//HH
PARTLINE(b1=2,EMA(HZD,2)),COLORCYAN; PARTLINE(b1=2,EMA(HZD,3)),COLORCYAN;
PARTLINE(b1=2,EMA(HZD,4)),COLORCYAN; PARTLINE(b1=2,EMA(HZD,5)),COLORCYAN;
PARTLINE(b1=2,EMA(HZD,6)),COLORCYAN; PARTLINE(b1=2,EMA(HZD,7)),COLORCYAN;
PARTLINE(b1=2,EMA(HZD,8)),COLORCYAN; PARTLINE(b1=2,EMA(HZD,9)),COLORCYAN;
PARTLINE(b1=2,EMA(HZD,10)),COLORCYAN; PARTLINE(b1=2,EMA(HZD,11)),COLORCYAN;
PARTLINE(b1=2,EMA(HZD,12)),COLORCYAN; PARTLINE(b1=2,EMA(HZD,13)),COLORCYAN;
PARTLINE(EMA(HZD,2)>REF(EMA(HZD,2),1),EMA(HZD,2)),COLORFFFFFF;
PARTLINE(EMA(HZD,3)>REF(EMA(HZD,3),1),EMA(HZD,3)),COLORFFFFFF;
PARTLINE(EMA(HZD,4)>REF(EMA(HZD,4),1),EMA(HZD,4)),COLORFFFFFF;
PARTLINE(EMA(HZD,5)>REF(EMA(HZD,5),1),EMA(HZD,5)),COLORFFFFFF;
PARTLINE(EMA(HZD,6)>REF(EMA(HZD,6),1),EMA(HZD,6)),COLORFFFFFF;
PARTLINE(EMA(HZD,7)>REF(EMA(HZD,7),1),EMA(HZD,7)),COLORFFFFFF;
PARTLINE(EMA(HZD,8)>REF(EMA(HZD,8),1),EMA(HZD,8)),COLORFFFFFF;
PARTLINE(EMA(HZD,9)>REF(EMA(HZD,9),1),EMA(HZD,9)),COLORFFFFFF;
PARTLINE(EMA(HZD,10)>REF(EMA(HZD,10),1),EMA(HZD,10)),COLORFFFFFF;
PARTLINE(EMA(HZD,11)>REF(EMA(HZD,11),1),EMA(HZD,11)),COLORFFFFFF;
PARTLINE(EMA(HZD,12)>REF(EMA(HZD,12),1),EMA(HZD,12)),COLORFFFFFF;
PARTLINE(EMA(HZD,13)>REF(EMA(HZD,13),1),EMA(HZD,13)),COLORFFFFFF;
PARTLINE(a2,EMA(HZD,2)),ColorYELLOW; PARTLINE(a2,EMA(HZD,3)),ColorYELLOW;
PARTLINE(a2,EMA(HZD,4)),ColorYELLOW; PARTLINE(a2,EMA(HZD,5)),ColorYELLOW;
PARTLINE(a2,EMA(HZD,6)),ColorYELLOW; PARTLINE(a2,EMA(HZD,7)),ColorYELLOW;
PARTLINE(a2,EMA(HZD,8)),ColorYELLOW; PARTLINE(a2,EMA(HZD,9)),ColorYELLOW;
PARTLINE(a2,EMA(HZD,10)),ColorYELLOW; PARTLINE(a2,EMA(HZD,11)),ColorYELLOW;
PARTLINE(a2,EMA(HZD,12)),ColorYELLOW; PARTLINE(a2,EMA(HZD,13)),ColorYELLOW;
PARTLINE(a1,EMA(HZD,2)),ColorMAGENTA; PARTLINE(a1,EMA(HZD,3)),ColorMAGENTA;
PARTLINE(a1,EMA(HZD,4)),ColorMAGENTA; PARTLINE(a1,EMA(HZD,5)),ColorMAGENTA;
PARTLINE(a1,EMA(HZD,6)),ColorMAGENTA; PARTLINE(a1,EMA(HZD,7)),ColorMAGENTA;
PARTLINE(a1,EMA(HZD,8)),ColorMAGENTA; PARTLINE(a1,EMA(HZD,9)),ColorMAGENTA;
PARTLINE(a1,EMA(HZD,10)),ColorMAGENTA; PARTLINE(a1,EMA(HZD,11)),ColorMAGENTA;
PARTLINE(a1,EMA(HZD,12)),ColorMAGENTA; PARTLINE(a1,EMA(HZD,13)),ColorMAGENTA;
{牛市95%,熊市60%;双剑合壁最准}
A:MA(CLOSE,15),COLORBLUE,linethick0;
B:MA(CLOSE,5),COLORRED,linethick0;
CC:=LLV(LOW,36);
DD:=HHV(HIGH,30);
EE:=(EMA(((CLOSE-CC)/(DD-CC))*(4),4))*(25);
STICKLINE(C>=A AND C>=O,C,O,7,0),COLORRED;
STICKLINE(C>=A AND C>=O,H,L,0,0),COLORRED;
STICKLINE(C>=A AND C<O,C,O,7,1),COLORRED;
STICKLINE(C>=A AND C<O,O,H,0,0),COLORRED;
STICKLINE(C>=A AND C<O,C,L,0,0),COLORRED;
DRAWTEXT(CROSS(B,A),B,''),color00ff00,linethick2;
DRAWTEXT(CROSS(A,B),A,''),COLORWHITE,linethick2;
STICKLINE(C<A AND C>O,C,O,7,1),,COLORGREEN;;
STICKLINE(C<A AND C<=O,C,O,7,0),,COLORGREEN;
STICKLINE(C<A AND C<=O,H,L,0,0),,COLORGREEN;
STICKLINE(C<A AND C>O,C,H,0,0),,COLORGREEN;
STICKLINE(C<A AND C>O,O,L,0,0),,COLORGREEN;
山水:=(((EE-LLV(EE,21))/(HHV(EE,21)-LLV(EE,21)))*(4))*(25);
{祝福宝贝}
Var1A:=DMA(AMOUNT/VOL/100,VOL/CAPITAL);
VAR4aa:=C/(REF(C,1))>1.05 AND (H/C<1.01);
DRAWTEXT(FILTER(VAR4aa>0,34),L*0.94,'加仓'),Color00FFFF;
DRAWTEXT(FILTER(VAR4aa>0,34),L*0.99,'★'),Color00FFFF;
A2aa:=REF(C,10)<C;
DRAWTEXT(FILTER(A2aa>0,34),H*1.02,'谨慎'),ColorFFFFFF;
LOCK:=IF(CURRENTDATE<2081223,1,0);
{主图指标}
AA05:MA(C,5),COLOR0099CC,LINETHICK0;
五日乖离率:(C-AA05)/AA05*100,LINETHICK0;
BB05:=ATAN((AA05/REF(AA05,1)-1)*100)*180/3.1416;
速度5:=SMA(EMA((AA05-REF(AA05,1))/REF(AA05,1),3)*100,3,1);
加速度5:EMA((速度5-REF(速度5,1)),3),LINETHICK0;
AA10:MA(C,10),LINETHICK0;
AA20:=MA(C,20),LINETHICK0;
BB10:=ATAN((AA10/REF(AA10,1)-1)*100)*180/3.1416,LINETHICK0;
AA30:MA(C,30),LINETHICK0;
三拾日乖离率:(C-AA30)/AA30*100,LINETHICK0;
VAR1:=(AA20-AA30)>REF((AA20-AA30),1) AND AA20>REF(AA20,1) AND AA30>REF(AA30,1);
VAR2:=(AA30-AA20)<REF((AA30-AA20),1) AND AA20<REF(AA20,1) AND AA30<REF(AA30,1);
BB30:=ATAN((AA30/REF(AA30,1)-1)*100)*180/3.1416;
强势狙击:=FILTER(BB30>30 AND BB10>45 AND CROSS(BB05,60),10);
加仓:=FILTER(COUNT(CROSS(BB05,30),5)>=1 AND AA05>REF(AA05,1) AND 三拾日乖离率>REF(三拾日乖离率,1) AND AA10>REF(AA10,1)
AND 加速度5>REF(加速度5,1) AND 速度5>REF(速度5,1) ,10) ;
清仓:=FILTER(COUNT(CROSS(30,BB05),5)>=1 AND (C>AA30 OR O>AA30) AND AA05<REF(AA05,1) AND 三拾日乖离率<REF(三拾日乖离率,1) AND AA10<REF(AA10,1),10);
DRAWTEXT(加仓 ,LOW*0.98,'←加仓'),COLORRED;
JC:=CROSS(0,五日乖离率) AND 三拾日乖离率<REF(三拾日乖离率,1) AND AA10>REF(AA10,1) ;
减仓:=FILTER(JC,10);
MR:=COUNT(CROSS(五日乖离率,0),3)>=1 AND 三拾日乖离率>REF(三拾日乖离率,1) AND AA05>REF(AA05,1) AND (C/REF(C,1)-1)*100>5 AND REF(C,1)<AA30;
买入:=FILTER(MR,10);
DRAWTEXT(减仓,HIGH*1.02,'←减仓'),COLORCYAN;
DRAWTEXT(买入,LOW*0.98,'←买入'),COLORYELLOW;
DRAWTEXT(清仓 ,HIGH*1.02,'←清仓'),COLORGREEN;
DRAWTEXT(强势狙击,LOW*0.98,'←强势狙击'),COLORYELLOW;
{逃}
上:=(MA(HIGH,30) * 1.15);
中1:=(MA(HIGH,3) * 1.03);
中2:=(MA(LOW,3) * 0.97);
下:=(MA(LOW,30) * 0.85);
上通道:=(EMA(EMA(EMA(HIGH,5),5),5) * 1.05);
DRAWTEXT(FILTER(((HIGH > 上通道) AND (CLOSE < 上通道)),3),(HIGH * 1.04),'●逃'),colorEE00FF;
{底部}
XL1:=((LLV(LOW,3) = LLV(LOW,60)) AND ((CLOSE / REF(CLOSE,1)) >= 1.04));
XL2:=(((CLOSE - EMA(CLOSE,21)) / EMA(CLOSE,21)) * 100);
XL3:=CROSS(XL2,(0 - 20));
DRAWTEXT(FILTER(((XL1 > 0) AND LOW),5),(LOW - 0.4),'●买点'),COLORYELLOW;
DRAWTEXT((XL3 > 0),(LOW - 0.2),'●底部'),colorFFFFFF;
X6:=REF(CLOSE,1);
X7:=((SMA(MAX((CLOSE - X6),0),7,1) / SMA(ABS((CLOSE - X6)),7,1)) * 100);
X8:=CROSS(79,X7);
X9:=FILTER(X8,4);
DRAWTEXT(X9,(HIGH * 1.02),'●出货'),color9000F5;
{}
VAR7:=REF(CLOSE,1);
VAR8:=((SMA(MAX((CLOSE - VAR7),0),7,1) / SMA(ABS((CLOSE - VAR7)),7,1)) * 100);
VAR9:=CROSS(69,VAR8);
VARA:=FILTER(VAR9,4);
DRAWICON(VARA,(HIGH * 1.035),2);
DRAWTEXT(VARA,(HIGH * 1.04),' 绝卖出'),colorFFFF00;
VAR3:=REF(CLOSE,1);
VAR4:=SMA(MAX(CLOSE-VAR3,0),6,1)/SMA(ABS(CLOSE-VAR3),6,1)*100;
DRAWTEXT(CROSS(84,VAR4),H*1.03,'逃顶'),COLORYELLOW ;
{动能线}
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1),COLORWHITE;
D:=SMA(K,3,1),COLORYELLOW;
j1:=-(3*K-2*D)+100;
j2:=if(j1<0 ,0 ,j1);
j:=if(j2>100,100,j2),COLORBLUE;
a4:=hhv(h,13);
a40:=if(a4>ref(a4,30),a4,ref(a4,30));
收盘:WMA(C,9),PRECISION2,colorwhite;
超短:=SMA(AMOUNT,3,1)/100000000;
中线:=SMA(AMOUNT,13,1)/100000000;
动能阻力线:if(j<k and 超短>中线,收盘,a40),PRECISION2,COLORCYAN,linethick1;
PARTLINE(收盘=动能阻力线,收盘),COLORRED,linethick1;
{}
RSV:=(CLOSE-LLV(LOW,10))/(HHV(HIGH,10)-LLV(LOW,10))*100;
K:=SMA(RSV,5,1);
D:=SMA(K,5,1);
J:=3*K-2*D;
X:=REF(J,1)<10 AND H>REF(H,1) AND C>REF(C,1) AND C>REF(O,1) AND L>REF(L,1);
STICKLINE(X,L ,L,20,0),COLOR008888;
STICKLINE(X,L ,H,0,0),colorFFFFFF;
STICKLINE(X,C ,O,5,0),colorFFFFFF;
{时间之窗}
P:=SYSPARAM(1);
P2:=SYSPARAM(3);
当前月:=MONTH;
转折日:=IF(当前月[P]=1,'6、15、21、*25',IF(当前月[P]=2,'6、15、21',IF(当前月[P]=3,'6、15、*20、21',
IF(当前月[P]=4,'6、15、21',IF(当前月[P]=5,'6、*12、15、21',IF(当前月[P]=6,'6、*14、21',
IF(当前月[P]=7,'8、15、*19、23',IF(当前月[P]=8,'*6、8、15、23',IF(当前月[P]=9,'8、15、*1 8、23',
IF(当前月[P]=11,'8、15、23、*28','8、15、23、*31'))))))))));
{时间窗}
DRAWTEXTEX(P2=BARPOS,0,6,2,'【时间窗提示】'),Color00D6FF;
DRAWTEXTEX(P2=BARPOS,0,11,18,NUMTOSTR(当前月[P],0)+'月 转折日:'),COLORCYAN;
DRAWTEXTEX(P2=BARPOS,0,10,32,转折日),COLORCYAN;
{}
A1:=COST(0.33);A2:=COST(5);A3:=COST(15);A4:=COST(55);A5:=COST(97);
成本90%:=COST(90);成本70%:=COST(70);成本30%:=COST(30);成本10%:=COST(10);
获利:=WINNER(CLOSE)*100;套牢:=100-WINNER(CLOSE)*100;
DRAWTEXTEX(CLOSE,1,350,0,'90成本:'+NUMTOSTR(成本90%,2)),Color00DD00;
DRAWTEXTEX(CLOSE,1,350,60,'70成本:'+NUMTOSTR(成本70%,2)),Color00DDFF;
DRAWTEXTEX(CLOSE,1,200,0,'30成本:'+NUMTOSTR(成本30%,2)),Color00DD00;
DRAWTEXTEX(CLOSE,1,200,60,'10成本:'+NUMTOSTR(成本10%,2)),Color00DDFF;
DRAWTEXTEX(CLOSE,1,700,120,'底出击:'+NUMTOSTR(A1,2)),ColorDDDDDD;DRAWTEXTEX(CLOSE,1,540,0,'建仓:'+NUMTOSTR(A2,2)),Color00DDFF;
DRAWTEXTEX(CLOSE,1,700,0,'快刀:'+NUMTOSTR(A3,2)),Colorff00FF;DRAWTEXTEX(CLOSE,1,860,0,'升浪:'+NUMTOSTR(A4,2)),Color0000FF;
DRAWTEXTEX(CLOSE,1,860,60,'预测:'+NUMTOSTR(A5,2)),ColorffFF00;DRAWTEXTEX(CLOSE,1,540,60,'获利:'+NUMTOSTR(获利,2)),ColorFF00FF;
DRAWTEXTEX(CLOSE,1,700,60,'套牢:'+NUMTOSTR(套牢,2)),Color00DD00;
{}
A4:=MA(CLOSE,20);
A5:=(CLOSE > MA(CLOSE,5));
A6:=(MA(CLOSE,5) > MA(CLOSE,10));
A7:=(CLOSE > MA(CLOSE,10));
A8:=(MA(CLOSE,5) > MA(CLOSE,20));
A9:=(CLOSE > MA(CLOSE,20));
A10:=REF(A4,1);
A11:=(A4 > A10);
AVX:=(((((IF(A5,10,(0 - 10)) + IF(A6,10,(0 - 10))) + IF(A7,10,(0 - 10))) + IF(A8,10,(0 - 10))) + IF(A9,10,(0 - 10))) + IF(A11,10,(0 - 10)));
DSLX:=(CLOSE / INDEXC);
DSLX1:=MA(DSLX,5);
DSLX2:=MA(DSLX,10);
V1:=MA(VOL,5);
V2:=MA(VOL,10);
T := BARSLAST(BARSTATUS=1)+1;
HHg := HHV(H, T);
ddg := LLV(L, T);
{Hk := LL-HH; G12 := LL-HK*1.55; }
a001:=BARSTATUS=2 and c<200 and ((CROSS(AVX,1) AND (V1 >= V2)) AND (DSLX >= DSLX1));
DRAWTEXTEX(a001,0,12,100,'该股的量能理想,有明显走强迹象,可以考虑中线进场参与,仓位在2/3左右。 '),color0000FF,LINETHICK3;
a002:=BARSTATUS=2 and c<200 and ((CROSS(AVX,1) AND (V1 < V2)) AND (DSLX >= DSLX1));
DRAWTEXTEX(a002,0,12,100,'该股虽然走势趋强,但量能还显不足,可以考虑短线进场,仓位在1/2左右。 '),color0000FF,LINETHICK3;
a003:=BARSTATUS=2 and c<200 and ((CROSS(AVX,1) AND (V1 > V2)) AND (DSLX < DSLX1));
DRAWTEXTEX(a003,0,12,100,'该股量价配合良好,但相对其它股票并没有明显走强,可以考虑短线进场,仓位1/2左右。 '),color0000FF,LINETHICK3;
a004:=BARSTATUS=2 and c<200 and ((CROSS(AVX,1) AND (V1 <= V2)) AND (DSLX < DSLX1));
DRAWTEXTEX(a004,0,12,100,'该股形态尚可,但量能不足,股票也未完全走强,可以短线参与,仓位1/3左右。 '),color0000FF,LINETHICK3;
a005:=BARSTATUS=2 and c<200 and ((CROSS(1,AVX) AND (V1 >= V2)) AND (DSLX >= DSLX1));
DRAWTEXTEX(a005,0,12,100,'该股形态变坏,但走势相对其它股票尚可,重仓者减持大半,清仓者可以观望。 '),color00FF00,LINETHICK3;
a006:=BARSTATUS=2 and c<200 and ((CROSS(1,AVX) AND (V1 < V2)) AND (DSLX >= DSLX1));
DRAWTEXTEX(a006,0,12,100,'该股随大盘一起下跌,呈明显缩量走势,考虑到大盘风险,减持或清仓。 '),color00FF00,LINETHICK3;
a007:=BARSTATUS=2 and c<200 and ((CROSS(1,AVX) AND (V1 >= V2)) AND (DSLX < DSLX1));
DRAWTEXTEX(a007,0,12,100,'该股放量下跌,走势明显偏弱,离场观望。 '),color00FF00,LINETHICK3;
a0071:=BARSTATUS=2 and c<200 and ((CROSS(1,AVX) AND (V1 < V2)) AND (DSLX < DSLX1));
DRAWTEXTEX(a0071,0,12,100,'该股缩量下跌,走势偏弱,离场观望。 '),color00FF00,LINETHICK3;
a008:=BARSTATUS=2 and c<200 and ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 >= V2)) AND (DSLX >= DSLX1));
DRAWTEXTEX(a008,0,12,100,'该股形态良好,强势明显,量能充足,可以继续持有。 '),color00FFFF,LINETHICK3;
a009:=BARSTATUS=2 and c<200 and ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 < V2)) AND (DSLX >= DSLX1));
DRAWTEXTEX(a009,0,12,100,'该股上行趋势不变,强势依然,但量能开始转弱,注意风险。 '),color00FFFF,LINETHICK3;
a010:=BARSTATUS=2 and c<200 and ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 >= V2)) AND (DSLX < DSLX1));
DRAWTEXTEX(a010,0,12,100,'该股仍然具备上涨潜力,但股性偏弱,可考虑减仓。 '),color00FFFF,LINETHICK3;
a011:=BARSTATUS=2 and c<200 and ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 < V2)) AND (DSLX < DSLX1));
DRAWTEXTEX(a011,0,12,100,'该股走势趋弱,量能不足,减持大部分筹码。 '),color00FFFF,LINETHICK3;
a012:=BARSTATUS=2 and c<200 and ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 >= V2)) AND (DSLX >= DSLX1));
DRAWTEXTEX(a012,0,12,100,'该股形态不佳,注意成交量的变化,但目前不适合参与。 '),COLOR00FF00,LINETHICK3;
a013:=BARSTATUS=2 and c<200 and ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 < V2)) AND (DSLX >= DSLX1));
DRAWTEXTEX(a013,0,12,100,'该股趋势不明,股价偏弱,注意量能变化,目前不宜参与。 '),COLOR00FF00,LINETHICK3;
a014:=BARSTATUS=2 and c<200 and ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 >= V2)) AND (DSLX < DSLX1));
DRAWTEXTEX(a014,0,12,100,'该股有走强迹象,但量能不足,趋势不明,不适合操作。 '),COLOR00FF00,LINETHICK3;
a015:=BARSTATUS=2 and c<200 and ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 < V2)) AND (DSLX < DSLX1));
DRAWTEXTEX(a015,0,12,100,'该股走势太弱,没有参与价值。 '),COLOR00FF00,LINETHICK3;
a016:=BARSTATUS=2 and c>200 and (CROSS(AVX,1) AND (V1 >= V2));
DRAWTEXTEX(a016,0,12,100,'大盘量能理想,有明显走强迹象,可以考虑中线进场参与,仓位在2/3左右, '),color0000FF,LINETHICK3;
a017:=BARSTATUS=2 and c>200 and (CROSS(AVX,1) AND (V1 >= V2));
DRAWTEXTEX(a017,0,12,100,'如前期经过一轮下跌,此时为最佳买点,但如果前期有过一段涨幅则介入需谨慎。 '),color0000FF,LINETHICK3;
a018:=BARSTATUS=2 and c>200 and (CROSS(AVX,1) AND (V1 < V2));
DRAWTEXTEX(a018,0,12,100,'大盘虽然走势趋强,但量能还显不足,如果前期经过一轮下跌, '),color0000FF,LINETHICK3;
a019:=BARSTATUS=2 and c>200 and (CROSS(AVX,1) AND (V1 < V2));
DRAWTEXTEX(a019,0,12,100,'可以考虑短线进场,仓位在1/2左右,一旦量能放大可以加仓买入。 '),color0000FF,LINETHICK3;
a020:=BARSTATUS=2 and c>200 and (CROSS(1,AVX) AND (V1 >= V2));
DRAWTEXTEX(a020,0,12,100,'大盘形态走坏,重仓者可以减去大部分仓位。 '),color00FF00,LINETHICK3;
a021:=BARSTATUS=2 and c>200 and (CROSS(1,AVX) AND (V1 < V2));
DRAWTEXTEX(a021,0,12,100,'大盘缩量调整,注意风险,短线清仓观望。 '),color00FF00,LINETHICK3;
a022:=BARSTATUS=2 and c>200 and (((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 >= V2));
DRAWTEXTEX(a022,0,12,100,'大盘走势良好,量能理想,可以继续持有强势股。 '),color00FFFF,LINETHICK3;
a023:=BARSTATUS=2 and c>200 and (((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 < V2));
DRAWTEXTEX(a023,0,12,100,'大盘形态良好,但量能稍显不足,随时准备减仓。 '),color00FFFF,LINETHICK3;
a024:=BARSTATUS=2 and c>200 and (((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 >= V2));
DRAWTEXTEX(a024,0,12,100,'大盘趋势不明,注意成交量变化,目前不适宜进场。 '),COLOR00FF00,LINETHICK3;
a025:=BARSTATUS=2 and c>200 and (((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 < V2));
DRAWTEXTEX(a025,0,12,100,'大盘趋势向下,量能萎缩,不适合进场。 '),COLOR00FF00,LINETHICK3;
{}
TJTS:=BACKSET(ISLASTBAR,5);//条件天数.可以显示最近5日内的K线形态
早晨之星:=REF(CLOSE,2)/REF(OPEN,2) < 0.95 AND REF(OPEN,1) < REF(CLOSE,2) AND ABS(REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<0.03 AND
CLOSE/OPEN>1.05 AND CLOSE>REF(CLOSE,2);
黄昏之星:=REF(CLOSE,2)/REF(OPEN,2) > 1.03 AND REF(OPEN,1) > REF(CLOSE,2) AND ABS(REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<0.02 AND CLOSE/OPEN<0.97 AND CLOSE<REF(CLOSE,2);
长十字:=CLOSE=OPEN AND HIGH/LOW >1.03;
垂死十字:=CLOSE=OPEN AND CLOSE=LOW AND CLOSE<>HIGH;
早晨十字星:=REF(CLOSE,2)/REF(OPEN,2) < 0.95 AND REF(OPEN,1) < REF(CLOSE,2) AND REF(OPEN,1)=REF(CLOSE,1) AND
CLOSE/OPEN>1.05 AND CLOSE>REF(CLOSE,2);
黄昏十字星:=REF(CLOSE,2)/REF(OPEN,2) > 1.05 AND REF(OPEN,1) > REF(CLOSE,2) AND REF(OPEN,1)=REF(CLOSE,1) AND
CLOSE/OPEN<0.95 AND CLOSE<REF(CLOSE,2);
射击之星:=MIN(OPEN,CLOSE)=LOW AND HIGH-LOW > 3*(MAX(OPEN,CLOSE)-LOW) AND CLOSE > MA(CLOSE,5);
倒转锤头:=MIN(OPEN,CLOSE)=LOW AND HIGH-LOW > 3*(MAX(OPEN,CLOSE)-LOW) AND CLOSE < MA(CLOSE,5);
锤头:=HIGH = MAX(OPEN,CLOSE) AND HIGH-LOW > 3*(HIGH-MIN(OPEN,CLOSE)) AND CLOSE < MA(CLOSE,5);
吊颈:=HIGH = MAX(OPEN,CLOSE) AND HIGH-LOW > 3*(HIGH-MIN(OPEN,CLOSE)) AND CLOSE>MA(CLOSE,5);
穿头破脚:=(REF(CLOSE,1)/REF(OPEN,1)>1.03 AND CLOSE/OPEN<0.96 AND CLOSE<REF(OPEN,1) AND OPEN>REF(CLOSE,1))
OR (REF(CLOSE,1)/REF(OPEN,1)<0.97 AND CLOSE/OPEN>1.04 AND CLOSE>REF(OPEN,1) AND OPEN<REF(CLOSE,1));
乌云盖顶:=REF(CLOSE,1)/REF(OPEN,1)>1.03 AND CLOSE/OPEN<0.97 AND OPEN>REF(CLOSE,1) AND CLOSE<REF(CLOSE,1);
曙光初现:=REF(CLOSE,1)/REF(OPEN,1)<0.97 AND CLOSE/OPEN>1.03 AND OPEN<REF(CLOSE,1) AND CLOSE>REF(CLOSE,1);
身怀六甲:=ABS(REF(CLOSE,1)-REF(OPEN,1))/REF(CLOSE,1) > 0.04 AND ABS(CLOSE-OPEN)/CLOSE<0.005 AND
MAX(CLOSE,OPEN) < MAX(REF(CLOSE,1),REF(OPEN,1)) AND MIN(CLOSE,OPEN) > MIN(REF(CLOSE,1),REF(OPEN,1));
十字胎:=ABS(REF(CLOSE,1)-REF(OPEN,1))/REF(CLOSE,1) > 0.04 AND CLOSE=OPEN AND
CLOSE < MAX(REF(CLOSE,1),REF(OPEN,1)) AND CLOSE > MIN(REF(CLOSE,1),REF(OPEN,1));
平顶:=ABS(HIGH-REF(HIGH,1))/HIGH<0.001;
平底:=(ABS(LOW-REF(LOW,1))/LOW<0.001 and abs(ref(low,1)-ref(low,2))/ref(low,1)<=0.001);
大阳烛:=CLOSE/OPEN>1.05 AND HIGH/LOW < CLOSE/OPEN+0.018;
三个白武士:=REF(CLOSE,2)>REF(OPEN,2) AND REF(CLOSE,1)>REF(OPEN,1) AND CLOSE>OPEN
AND REF(CLOSE,1)>REF(CLOSE,2) AND CLOSE>REF(CLOSE,1);
双飞乌鸦:=REF(CLOSE,1)<REF(OPEN,1) AND CLOSE<OPEN AND CLOSE/OPEN<0.98;
孕育线:=REF(CLOSE,2)>REF(OPEN,2) AND (REF(CLOSE,2)-REF(OPEN,2))/REF(OPEN,2)>=2/100 AND REF(OPEN,1)>=REF(CLOSE,1) AND (REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<=2/100 AND REF(OPEN,1)<=REF(CLOSE,2) AND REF(CLOSE,1)>=REF(OPEN,2) AND C>=OPEN AND (CLOSE-OPEN)/OPEN>=2/100 AND CLOSE>=REF(OPEN,1) AND OPEN<=REF(CLOSE,1) AND (MAX(CLOSE,REF(C,2))-MIN(CLOSE,REF(CLOSE,2)))/MIN(CLOSE,REF(CLOSE,2))<=1/100;
多方炮:=REF(CLOSE,2)>REF(OPEN,2) AND REF(CLOSE,1)<REF(OPEN,1) AND CLOSE>OPEN;
出水芙蓉:=(OPEN<EMA(C,20) OR OPEN<EMA(C,40) OR OPEN<EMA(C,60)) AND (C>MAX(EMA(C,20),MAX(EMA(C,40),EMA(C,60))))
AND (V/MA(V,30)>1.2 AND C/REF(C,1)>1.049);
上升三部曲:=REF(CLOSE,4)/REF(OPEN,4)>1.03 AND REF(CLOSE,3)<REF(OPEN,3) AND REF(CLOSE,2)<REF(OPEN,2) AND REF(CLOSE,1)<REF(OPEN,1) AND REF(LOW,4)<REF(LOW,3) AND REF(LOW,4)<REF(LOW,2) AND REF(LOW,4)<REF(LOW,1) AND REF(HIGH,4)>REF(HIGH,3) AND REF(HIGH,4)>REF(HIGH,2) AND
REF(HIGH,4)>REF(HIGH,1) AND CLOSE/OPEN>1.03 AND CLOSE>REF(CLOSE,4);
下跌三部曲:= REF(CLOSE,4)/REF(OPEN,4)<0.97 AND REF(CLOSE,3)>REF(OPEN,3) AND REF(CLOSE,2)>REF(OPEN,2) AND REF(CLOSE,1)>REF(OPEN,1) AND REF(LOW,4)<REF(LOW,3) AND
REF(LOW,4)<REF(LOW,2) AND REF(LOW,4)<REF(LOW,1) AND REF(HIGH,4)>REF(HIGH,3) AND REF(HIGH,4)>REF(HIGH,2) AND REF(HIGH,4)>REF(HIGH,1) AND CLOSE/OPEN<0.97 AND
CLOSE<REF(CLOSE,4);
跳空缺口:=HIGH<REF(LOW,1) OR LOW>REF(HIGH,1);
三只乌鸦:=REF(CLOSE,2)<REF(OPEN,2) AND REF(CLOSE,1)<REF(OPEN,1) AND CLOSE<OPEN AND REF(CLOSE,1)<REF(CLOSE,2) AND CLOSE<REF(CLOSE,1);
光脚阴线:=LOW=CLOSE AND HIGH<>LOW;
光头阳线:=HIGH=CLOSE AND HIGH<>LOW;
分离:=OPEN=REF(OPEN,1) AND (CLOSE-OPEN)*(REF(CLOSE,1)-REF(OPEN,1))<0;
长下影:=(MIN(CLOSE,OPEN)-LOW)/(HIGH-LOW)>0.667;
长上影:=(HIGH-MAX(CLOSE,OPEN))/(HIGH-LOW)>0.667;
十字星:=CLOSE=OPEN AND HIGH<>LOW;
大阴烛:=OPEN/CLOSE > 1.05 AND HIGH/LOW < OPEN/CLOSE+0.018;
好友反攻:=(REF(CLOSE,1)<REF(OPEN,1) AND CLOSE>OPEN AND ABS(CLOSE-REF(CLOSE,1))/CLOSE<0.002)
OR (REF(CLOSE,1)>REF(OPEN,1) AND CLOSE<OPEN AND ABS(CLOSE-REF(CLOSE,1))/CLOSE<0.002);
倾盆大雨:=REF(C,1)/REF(O,1)>=1.03 AND O<REF(C,1) AND O>REF(O,1) AND C<REF(O,1);
//EXPLAIN(倾盆大雨,'倾盆大雨,见顶信号;'),COLORCYAN;
TJ1:=IF(倾盆大雨 AND TJTS,'倾盆大雨,见顶信号‖','');
TJ2:=IF(大阴烛 AND TJTS,'大阴烛,后市向淡,发生逆转‖',''),COLORCYAN,ALIGN4;
TJ3:=IF(好友反攻 AND TJTS,'好友反攻,跌势已尽,要展开一段反弹行情‖',''),COLORRED,ALIGN5;
TJ4:=IF(跳空缺口 AND TJTS,'跳空缺口,突破长期盘整,向上跳空,上涨行情开始;向下跳空,下跌行情开始‖',''),COLORWHITE,ALIGN5;
TJ5:=IF(光脚阴线 AND TJTS,'光脚阴线,下跌信号‖',''),COLORCYAN,ALIGN4;
TJ6:=IF(光头阳线 AND TJTS,'光头阳线,多方积极上攻态势,后市看涨‖',''),COLORRED,ALIGN5;
TJ7:=IF(三只乌鸦 AND TJTS,'三只乌鸦站枝头,可能见顶回落‖',''),COLORCYAN,ALIGN4;
TJ8:=IF(分离 AND TJTS,'分离,注意看涨分离和看跌分离‖',''),COLORWHITE,ALIGN5;
TJ9:=IF(长下影 AND TJTS,'长下影,持续下跌后出现,有可能止跌回升;在升势末期出现,须多加留意‖',''),COLORRED,ALIGN5;
TJ10:=IF(长上影 AND TJTS,'长上影,表明行情上档压力沉重,升势受阻‖',''),COLORCYAN,ALIGN4;
TJ11:=IF(下跌三部曲 AND TJTS,'下跌三部曲,下跌信号‖',''),COLORRED,ALIGN4;
TJ12:=IF(上升三部曲 AND TJTS,'上升三部曲,上涨信号‖',''),COLORCYAN,ALIGN5;
TJ13:=IF(早晨之星 AND TJTS,'早晨之星,见底回升‖',''),COLORRED,ALIGN5;
TJ14:=IF(黄昏之星 AND TJTS,'黄昏之星,见顶回落‖',''),COLORCYAN,ALIGN4;
TJ15:=IF(十字星 AND TJTS,'十字星,重要的警告信号,原趋势停顿或反转‖',''),COLORWHITE,ALIGN5;
TJ16:=IF(长十字 AND TJTS,'长十字,重要的警告信号,原趋势停顿或反转‖',''),COLORWHITE,ALIGN5;
TJ17:=IF(垂死十字 AND TJTS,'垂死十字,下跌信号‖',''),COLORCYAN,ALIGN4;
TJ18:=IF(早晨十字星 AND TJTS,'早晨十字星,上涨信号,见底回升‖',''),COLORRED,ALIGN5;
TJ19:=IF(黄昏十字星 AND TJTS,'黄昏十字星,趋势停顿或反转,下跌信号,见顶回落‖',''),COLORCYAN,ALIGN5;
TJ20:=IF(射击之星 AND TJTS,'射击之星,出现在短期的上升趋势,表明市场顶部就在眼前,可能见顶回落,可靠性低‖',''),COLORCYAN,ALIGN5;
TJ21:=IF(倒转锤头 AND TJTS,'倒转锤头构成一个看涨信号,可能见底回升‖',''),COLORRED,ALIGN4;
TJ22:=IF(锤头 AND TJTS,'锤头,可能见底回升,如有量配合,信号强烈‖',''),COLORRED,ALIGN5;
TJ23:=IF(吊颈 AND TJTS,'吊颈,上升行情中见顶回落,顶部出现,见顶信号‖',''),COLORCYAN,ALIGN4;
TJ24:=IF(平顶 AND TJTS,'平顶,意味行情摸高见顶,股价行将反转。但反转下跌力度较小‖',''),COLORCYAN,ALIGN4;
TJ25:=IF(穿头破脚 AND TJTS,'穿头破脚,顶部出现,见顶回落信号‖',''),COLORCYAN,ALIGN4;
TJ26:=IF(乌云盖顶 AND TJTS,'乌云盖顶,见顶回落信号‖',''),COLORCYAN,ALIGN4;
TJ27:=IF(曙光初现 AND TJTS,'曙光初现,行情将演化为V型反转或止跌横盘趋势。后市见底回升‖',''),COLORRED,ALIGN5;
TJ28:=IF(身怀六甲 AND TJTS,'身怀六甲,出现在底部,是见底回升信号;出现在顶部,是见顶回落信号‖',''),COLORRED,ALIGN5;
TJ29:=IF(十字胎 AND TJTS,'十字胎‖',''),COLORRED,ALIGN5;
TJ30:=IF(平底 AND TJTS,'平底,行情探低见底,股价行将反转上升,但力度较小‖',''),COLORRED,ALIGN5;
TJ31:=IF(大阳烛 AND TJTS,'大阳烛,在上升行情中出现,则意味着行情剧烈地向上攀升。在下跌行情中出现,则意味着行情剧烈地向上反弹‖',''),COLORRED,ALIGN5;
TJ32:=IF(三个白武士 AND TJTS,'三个白武士,每日收盘价上移,表示可能见底回升‖',''),COLORRED,ALIGN5;
TJ33:=IF(双飞乌鸦 AND TJTS,'双飞乌鸦,行情开始疲软将见顶回落‖',''),COLORCYAN,ALIGN5;
TJ34:=IF(孕育线 AND TJTS,'孕育线,注意股价位置‖',''),COLORWHITE,ALIGN5;
TJ35:=IF(多方炮 AND TJTS,'多方炮,在底部出现有上涨可能,在中间出现有可能是上涨中继,顶部出现是复合见顶信号‖',''),COLORRED,ALIGN5;
TJ36:=IF(出水芙蓉 AND TJTS,'出水芙蓉,阳线穿过20、40、60日季均线,上攻势头初现‖',''),COLORRED,ALIGN5;
TJ:='【K线形态】 '+TJ1+TJ2+TJ3+TJ4+TJ5+TJ6+TJ7+TJ8+TJ9+TJ10+TJ11+TJ12+TJ13+TJ14+TJ15+TJ16+TJ17+TJ18+TJ19+TJ20+TJ21+TJ22+TJ23+TJ24+TJ25+TJ26+TJ27+TJ28+TJ29+TJ30+TJ31+TJ32+TJ33+TJ34+TJ35+TJ36;
DRAWTEXT(sysparam(2)=BARSCOUNT(CLOSE),C,TJ),COLORCYAN,ALIGN5;
{股旁网-股票公式网站 www.GupaNg.com}
EXPLAIN(1=1,' 【技术分析】'),colorFFFF;
DIFF:=EMA(CLOSE,3)-EMA(CLOSE,13);
DEA:=EMA(DIFF,7);
TJ:=DIFF>DEA;
TJ1:=DIFF>-0.1;
MACD:=2*(DIFF-DEA);
JC:=CROSS(DIFF,DEA);
SC:=CROSS(DEA,DIFF);
DCJC:=JC AND DEA>0;
EXPLAIN(JC AND DEA>0,'MACD在0轴上金叉提示加仓;'),colorFF;
EXPLAIN(JC AND DEA<0,'MACD在0轴下金叉酌情买入;'),colorFF;
EXPLAIN(SC AND DEA>0,'MACD在0轴上多次死叉;'),colorFF00;
EXPLAIN(SC AND DEA<0,'MACD在0轴下多次死叉;'),colorFF00;
EXPLAIN(MACD<0 AND ABS(MACD)>REF(ABS(MACD),1),'MACD绿柱增长提示卖出;'),colorFF00;
EXPLAIN(MACD<0 AND ABS(MACD)<REF(ABS(MACD),1),'MACD绿柱缩短提示买入;'),colorFF;
EXPLAIN(LLV(LOW,60)=LOW AND NOT(LLV("MACD.DEA",60)="MACD.DEA"),'MACD底背离提示示买入;'),colorFF;
EXPLAIN(HHV(HIGH,60)=HIGH AND NOT(HHV("MACD.DEA",60)="MACD.DEA"),'MACD顶背离提示卖出;'),colorFF00;
EXPLAIN(CROSS("MACD.DIFF","MACD.DEA") AND BARSLAST(CROSS("MACD.DIFF","MACD.DEA"))>=3,'MACD二次金叉提示买入,股价上涨幅度会较大。'),colorFF;
EXPLAIN(CROSS("MACD.DEA","MACD.DIFF") AND BARSLAST(CROSS("MACD.DEA","MACD.DIFF"))>=3,'MACD二次死叉提示卖出,股价下跌幅度会较大。'),colorFF00;
EXPLAIN((COUNT(CLOSE<REF(CLOSE,1),30))>18 AND (COUNT(CLOSE<REF(CLOSE,1),3))=3 AND (COUNT("MACD.MACD">REF("MACD.MACD",1),30))>18,'MACD反转--股价将可能反转向上。 '),colorFF;
EXPLAIN((COUNT(CLOSE>REF(CLOSE,1),30))>18 AND (COUNT(CLOSE>REF(CLOSE,1),3))=3 AND (COUNT("MACD.MACD"<REF("MACD.MACD",1),30))>18,'MACD反转--股价将可能反转向下。 '),colorFF00;
EXPLAIN(COUNT(DCJC,20)=2 AND JC AND DEA>0,'MACD在0轴上2金叉;'),color1;
EXPLAIN(COUNT(DCJC,20)=3 AND JC AND DEA>0,'MACD在0轴上3金叉;');
EXPLAIN(COUNT(DCJC,20)=4 AND JC AND DEA>0,'MACD在轴上4金叉;');
LC:=REF(CLOSE,1);
RSI1:=(SMA(MAX(CLOSE-LC,0),7,1))/(SMA(ABS(CLOSE-LC),7,1))*100;
RSI2:=(SMA(MAX(CLOSE-LC,0),14,1))/(SMA(ABS(CLOSE-LC),14,1))*100;
EXPLAIN("RSI.RSI1"<15 AND (BARSLAST("RSI.RSI1"<15))>=1,'RSI相对强弱指标超卖,属买入信号。'),colorFF;
EXPLAIN("RSI.RSI1">85 AND (BARSLAST("RSI.RSI1">85))>=1,'RSI相对强弱指标超买,属卖出信号。'),colorFF00;
EXPLAIN((LLV(LOW,20)=LOW AND NOT(LLV("RSI.RSI1",20)="RSI.RSI1") OR (COUNT(CLOSE<REF(CLOSE,1),30))>18 AND (COUNT("RSI.RSI1">REF("RSI.RSI1",1),30))>18) AND "RSI.RSI1"<20,'RSI相对强弱指标底背离,股价在低位时属买入信号。'),colorFF;
EXPLAIN((HHV(HIGH,20)=HIGH AND NOT(HHV("RSI.RSI1",20)="RSI.RSI1") OR (COUNT(CLOSE>REF(CLOSE,1),30))>18 AND (COUNT("RSI.RSI1"<REF("RSI.RSI1",1),30))>18) AND "RSI.RSI1">80,'RSI相对强弱指标顶背离,股价在高位时属卖出信号。'),colorFF00;
EXPLAIN(CROSS("RSI.RSI1","RSI.RSI2") AND "RSI.RSI1"<50,'RSI相对强弱指标金叉属买入信号。'),colorFF;
EXPLAIN(CROSS("RSI.RSI2","RSI.RSI1") AND "RSI.RSI1">50,'RSI相对强弱指标死叉,属卖出信号。'),colorFF00;
EXPLAIN("RSI.RSI1"<5,'RSI相对强弱指标极低位,强烈买入信号。'),colorFF;
EXPLAIN("RSI.RSI1">93,'RSI相对强弱指标极高位,强烈卖出信号。'),colorFF00;
EXPLAIN(RSI1<35,'RSI顶背离提示买入;'),colorFF;
EXPLAIN(CROSS(74,RSI1),'RSI顶背离提示卖出;'),colorFF00;
EXPLAIN("KDJ.K"<=20 AND "KDJ.D"<=20,'KD超卖指示买入;'),colorFF;
EXPLAIN("KDJ.K">=80 AND "KDJ.D">=80,'KD超买逢高卖出;'),colorFF00;
EXPLAIN(CROSS("KDJ.K","KDJ.D") AND (COUNT(VOL>REF(VOL,1),30))>3 AND VOL/CAPITAL<=10/100 AND "KDJ.K"<=20 AND "KDJ.D"<=20,'KD金叉买入,低市值或成交清淡个股应忽略此信号。'),colorFF;
EXPLAIN(CROSS("KDJ.D","KDJ.K") AND "KDJ.K">=60 AND "KDJ.D">=60 AND (BARSLAST(CROSS("KDJ.D","KDJ.K") AND "KDJ.K">=60 AND "KDJ.D">=60))>=1 AND (BARSLAST(CROSS("KDJ.D","KDJ.K") AND "KDJ.K">=60 AND "KDJ.D">=60))<=7,'KD二次死叉提示卖出;'),colorFF00;
EXPLAIN("KDJ.J"<0,'KDJ异常逢低买入'),colorFF;
EXPLAIN(HHV(HIGH,20)=HIGH AND (NOT(HHV("KDJ.K",20)="KDJ.K" OR HHV("KDJ.D",20)="KDJ.D")) OR (COUNT(CLOSE>REF(CLOSE,1),30))>18 AND ((COUNT("KDJ.K"<REF("KDJ.K",1),30))>18 OR (COUNT("KDJ.D"<REF("KDJ.D",1),30))>18),'KD顶背离提示卖出;'),colorFF00;
EXPLAIN(LLV(LOW,20)=LOW AND (NOT(LLV("KDJ.K",20)="KDJ.K" OR LLV("KDJ.D",20)="KDJ.D")) OR (COUNT(CLOSE<REF(CLOSE,1),30))>18 AND ((COUNT("KDJ.K">REF("KDJ.K",1),30))>18 OR (COUNT("KDJ.D">REF("KDJ.D",1),30))>18),'KD底背离提示买入;'),colorFF;
日K:="KDJ.K#day"(20,5,5);
日D:="KDJ.D#day"(20,5,5);
周K:="KDJ.K#week"(9,3,3);
周D:="KDJ.D#week"(9,3,3);
EXPLAIN(CROSS(日K,日D),'日KD金叉且底背离买入;'),colorFF;
EXPLAIN(CROSS(日D,日K),'日KD死叉且顶背离必须卖出;'),colorFF00;
EXPLAIN(CROSS(周K,周D),'周KD金叉且底背离买入;'),colorFF;
EXPLAIN(CROSS(周D,周K),'周KD死叉且顶背离必须卖出;'),colorFF00;
BBI:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;
UPR:=BBI+3*STD(BBI,10);
DWN:=BBI-3*STD(BBI,10);
VAR55:=(UPR-DWN)/UPR<0.03;
VAR56:=(UPR-DWN)/UPR>0.18;
VAR57:=(MA(CLOSE,60)-MA(CLOSE,5))/MA(CLOSE,60)>0.15;
VAR58:=(MA(CLOSE,5)-MA(CLOSE,60))/MA(CLOSE,5)>0.15;
EXPLAIN(VAR55,'布林线收窄可能变盘;'),colorFF00FF;
EXPLAIN(VAR57 AND VAR56 AND CLOSE>OPEN,'布林上下乖离太大可能反弹;'),colorFF00FF;
EXPLAIN(VAR58 AND VAR56 AND CLOSE<OPEN,'布林上下乖离太大可能回落;'),colorFF00;
EXPLAIN(CROSS(CLOSE,"SAR") AND (ABS(CLOSE-"SAR"))/CLOSE>=0.01,'SAR向上突破提示买入;'),colorFF;
EXPLAIN(CROSS("SAR",CLOSE) AND (ABS(CLOSE-"SAR"))/CLOSE>=0.01,'SAR向下突破提示卖出;'),colorFF00;
TYP:=(HIGH+LOW+CLOSE)/3;
CCI:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14));
EXPLAIN(CCI<-100,'CCI指标底位,买入机会。'),colorFF;
EXPLAIN(CCI>100,'CCI指标高位,卖出机会。'),colorFF00;
EXPLAIN(VOL/CAPITAL>0.075,'换手过大,小心主力出逃,短期头部。'),colorFFFF;
WR:=-100*(HHV(HIGH,14)-CLOSE)/(HHV(HIGH,14)-LLV(LOW,14));
EXPLAIN(WR>-20,'W&R超买,即将见顶,应及时卖出。'),colorFF00;
EXPLAIN(WR<-80,'W&R超卖,即将见底,应伺机买进。'),colorFF;
MTM:=CLOSE-REF(CLOSE,6);
MTMMA:=MA(MTM,6);
EXPLAIN(CROSS(MTM,MTMMA),'MTM从下向上突破MTMMA,买入信号。'),colorFF;
EXPLAIN(CROSS(MTMMA,MTM),'MTM从上向下跌破MTMMA,卖出信号。'),colorFF00;
EXPLAIN("ARBR.AR"<50,'ARBR人气指标超卖,属买入信号。'),colorFF;
EXPLAIN("ARBR.AR">200,'ARBR人气指标超买,属卖出信号。'),colorFF00;
EXPLAIN((HHV("ARBR.AR",10)-"ARBR.AR")/HHV("ARBR.AR",10)>=0.5,'ARBR人气指标异常,若股价从高价下跌,属买入信号。'),colorFF;
EXPLAIN(("ARBR.AR"-LLV("ARBR.AR",10))/LLV("ARBR.AR",10)>=0.5,'ARBR人气指标异常,若股价从低价上升,属卖出信号。'),colorFF00;
EXPLAIN("ARBR.BR"<50,'ARBR意愿指标显示股价随时反弹考虑买入。'),colorFF;
EXPLAIN("ARBR.BR">300,'ARBR意愿指标显示股价随时下挫考虑卖出。'),colorFF00FF;
EXPLAIN(CROSS("ARBR.AR","ARBR.BR") AND ("ARBR.AR"<50 OR "ARBR.BR"<50),'ARBR人气意愿指标金叉,属买入信号。'),colorFF;
EXPLAIN(CROSS("ARBR.BR","ARBR.AR") AND ("ARBR.AR">180 OR "ARBR.BR">300),'ARBR人气意愿指标死叉,属卖出信号。'),colorFF00;
EXPLAIN((COUNT(CLOSE<REF(CLOSE,1),30))>18 AND (COUNT(CLOSE<REF(CLOSE,1),3))=3 AND (COUNT("OBV.OBV">REF("OBV.OBV",1),30))>18 AND (COUNT("OBV.OBV">REF("OBV.OBV",1),3))=3 AND (COUNT(VOL>REF(VOL,1),30))>3 AND VOL/CAPITAL<=10/100,'OBV能量潮显示买盘较强属买入信号。'),colorFF;
EXPLAIN((COUNT(CLOSE>REF(CLOSE,1),30))>18 AND (COUNT(CLOSE>REF(CLOSE,1),3))=3 AND (COUNT("OBV.OBV">REF("OBV.OBV",1),30))>18 AND (COUNT("OBV.OBV">REF("OBV.OBV",1),3))=3 AND (COUNT(VOL>REF(VOL,1),30))>3 AND VOL/CAPITAL<=10/100,'OBV能量潮显示买盘逐渐加强属买入信号。'),colorFF;
EXPLAIN((COUNT(CLOSE>REF(CLOSE,1),30))>18 AND (COUNT(CLOSE>REF(CLOSE,1),3))=3 AND ((COUNT("OBV.OBV"<REF("OBV.OBV",1),30))>18 OR (COUNT("OBV.OBV"<REF("OBV.OBV",1),3))=3),'OBV能量潮显示买盘无力属卖出信号。 '),colorFF00;
EXPLAIN(CROSS("OBV.OBV",0) AND (COUNT(REF("OBV.OBV",1)<0,3))=3,'OBV能量潮由负转正属买入信号。'),colorFF;
EXPLAIN(CROSS(0,"OBV.OBV") AND (COUNT(REF("OBV.OBV",1)>0,3))=3,'OBV能量潮由正转负属卖出信号。'),colorFF00;
EXPLAIN(HHV(HIGH,20)=HIGH AND NOT(HHV("OBV.OBV",20)="OBV.OBV"),'OBV能量潮顶背离属卖出信号。'),colorFF00;
EXPLAIN(LLV(LOW,20)=LOW AND NOT(LLV("OBV.OBV",20)="OBV.OBV"),'OBV能量潮底背离属买入信号。'),colorFF;
EXPLAIN((ABS("OBV.OBV"-REF("OBV.OBV",1)))/ABS(MA("OBV.OBV",5))>0.07 AND "OBV.OBV">REF("OBV.OBV",1),'OBV能量潮异常。若股价在高位属卖出信号,若OBV能量线在低位长时间横向整理后出现,属买入信号。'),colorFF00FF;
EXPLAIN("CR.CR"<40,'CR能量指标超卖,提示股价形成底部,属买入信号。'),colorFF;
EXPLAIN("CR.CR"<=400 AND "CR.CR">=300,'CR能量指标超买,属卖出信号。'),colorFF00;
EXPLAIN(LLV(LOW,20)=LOW AND NOT(LLV("CR.CR",20)="CR.CR"),'CR能量指标底背离,属买入信号。'),colorFF;
EXPLAIN(HHV(HIGH,20)=HIGH AND NOT(HHV("CR.CR",20)="CR.CR"),'CR能量指标顶背离,属卖出信号。'),colorFF00;
EXPLAIN(ABS("CR.MA1"-"CR.MA2")<5 AND ABS("CR.MA1"-"CR.MA3")<5 AND ABS("CR.MA2"-"CR.MA3")<5 OR ABS("CR.MA1"-"CR.CR")<5 AND ABS("CR.MA1"-"CR.MA3")<5 AND ABS("CR.CR"-"CR.MA3")<5,'CR能量指标异常,一波或长或短的上升或下跌行情即将展开。'),colorFF00FF;
EXPLAIN("PSY"<10,'PSY心理线指标低位超卖区,属买入信号。'),colorFF;
EXPLAIN(BETWEEN("PSY","PSY">10,"PSY"<25),'PSY心理线指标超卖,属买入信号。'),colorFF;
EXPLAIN("PSY">75,'PSY心理线指标超买,属卖出信号。'),colorFF00;
EXPLAIN(CROSS("ROC.ROC",0),'ROC变动速率指标向上突破,属买入信号。'),colorFF;
EXPLAIN(CROSS(0,"ROC.ROC"),'ROC变动速率指标向下突破,属卖出信号。'),colorFF00;
EXPLAIN(LLV(LOW,20)=LOW AND NOT((COUNT("ROC.ROC"<REF("ROC.ROC",1),30))>18 AND (COUNT("ROC.ROC"<REF("ROC.ROC",1),3))=3),'ROC变动速率指标,显示下跌动力减弱,属买入信号。 '),colorFF;
EXPLAIN(HHV(HIGH,20)=HIGH AND NOT((COUNT("ROC.ROC">REF("ROC.ROC",1),30))>18 AND (COUNT("ROC.ROC">REF("ROC.ROC",1),3))=3),'ROC变动速率指标,显示上涨动力减弱,属卖出信号。 '),colorFF00;
EXPLAIN((COUNT(CLOSE>REF(CLOSE,1),30))>18 AND (COUNT(CLOSE>REF(CLOSE,1),3))=3 AND (COUNT("ROC.ROC">REF("ROC.ROC",1),30))>18 AND (COUNT("ROC.ROC">REF("ROC.ROC",1),3))=3,'ROC变动速率指标显示短期反弹有望,属买入信号。 '),colorFF;
EXPLAIN((COUNT(CLOSE<REF(CLOSE,1),30))>18 AND (COUNT(CLOSE<REF(CLOSE,1),3))=3 AND (COUNT("ROC.ROC"<REF("ROC.ROC",1),30))>18 AND (COUNT("ROC.ROC"<REF("ROC.ROC",1),3))=3,'ROC变动速率指标显示短期警惕回落,属卖出信号。 '),colorFF00;
EXPLAIN("VR"<20,'VR容量比率指标显示股价即将涨升,建议积极买入。'),colorFF;
EXPLAIN("VR">400,'VR容量比率指标显示后续资金枯竭,股价将可能高位下跌,属卖出信号。'),colorFF00;
EXPLAIN(("VR"/REF("VR",1)>=2 OR "VR"/REF("VR",2)>=2) AND (COUNT(CLOSE<=REF(CLOSE,1),5))>=3,'VR容量比率指标异常,显示股价即将涨升,属买入信号。 '),colorFF;
EXPLAIN("VR">300 AND (COUNT("VR"<REF("VR",1),5))>=3 AND (COUNT(CLOSE>REF(CLOSE,1),5))>=3,'VR容量比率指标显示涨势耗尽,建议卖出。 '),colorFF00;
VV6:=(2*CLOSE+HIGH+LOW)/4;
VV7:=LLV(LOW,27);
VV8:=HHV(HIGH,27);
攀:=EMA((VV6-VV7)/(VV8-VV7)*100,13)-50;
金:=EMA(0.618*REF(攀,1)+0.382*攀,3);
起攀:=CROSS(攀,金) AND CLOSE>OPEN;
EXPLAIN(CROSS(攀,金) AND CLOSE>OPEN,'起攀指标发出起攀买入信号。'),colorFF;
EXPLAIN(1=1,' 【均线系统分析】'),colorFFFF;
MA5:=MA(CLOSE,5);
MA10:=MA(CLOSE,10);
MA30:=MA(CLOSE,30);
MA60:=MA(CLOSE,60);
MA125:=MA(CLOSE,125);
MA250:=MA(CLOSE,250);
EXPLAIN(MA5>MA10 AND MA10>MA30 AND MA5>MA30,'短期均线多头排列;'),colorFF;
EXPLAIN(MA5<MA10 AND MA10<MA30 AND MA5<MA30,'短期均线空头排列;'),colorFF00;
EXPLAIN(MA30>MA60 AND MA30>MA125 AND MA60>MA125,'中期均线多头排列;'),colorFF;
EXPLAIN(MA30<MA60 AND MA30<MA125 AND MA60<MA125,'中期均线空头列排;'),colorFF00;
EXPLAIN(MA60>MA125 AND MA125>MA250 AND MA60>MA250,'长期均线多头排列;'),colorFF;
EXPLAIN(MA60<MA125 AND MA125<MA250 AND MA60<MA250,'长期均线空头排列;'),colorFF00;
EXPLAIN(CROSS(MA5,MA10),'短期5日10日均线金叉;'),colorFF;
EXPLAIN(CROSS(MA10,MA5),'短期5日10日均线死叉;'),colorFF00;
EXPLAIN(CROSS(CLOSE,MA125),'今日股价上穿半年线;'),colorFF00FF;
EXPLAIN(CROSS(MA125,CLOSE),'今日股价跌破半年线;'),colorFF00;
EXPLAIN(CROSS(CLOSE,MA250),'今日股价上穿一年线;'),colorFF00FF;
EXPLAIN(CROSS(MA250,CLOSE),'今日股价跌破一年线;'),colorFF00;
EXPLAIN(CROSS(CLOSE,MA60) AND CROSS(CLOSE,MA125) AND CROSS(CLOSE,MA250),'股价一阳穿三线;'),colorFF;
EXPLAIN(MA30>REF(MA30,1),'30日均线趋势向上;'),colorFF;
EXPLAIN(MA30>REF(MA30,1) AND MA30<REF(MA30,1)*1.001,'30日均线趋势走平;'),colorFFCC66;
EXPLAIN(MA30<REF(MA30,1),'30日均线趋势向下;'),colorFF00;
EXPLAIN(MA5>REF(MA5,1)*1.015,'5日均线强劲向上;'),colorFF;
EXPLAIN(MA5>REF(MA5,1) AND MA5<REF(MA5,1)*1.005,'5日均线方向不明;'),colorFFFF;
EXPLAIN(MA5<REF(MA5,1)*0.985,'5日均线快速向下;'),colorFF00;
EXPLAIN(1=1,' 【形态分析】'),colorFFFF;
早晨之星:=REF(CLOSE,2)/REF(OPEN,2)<0.95 AND REF(OPEN,1)<REF(CLOSE,2) AND (ABS(REF(OPEN,1)-REF(CLOSE,1)))/REF(CLOSE,1)<0.03 AND CLOSE/OPEN>1.05 AND CLOSE>REF(CLOSE,2);
黄昏之星:=REF(CLOSE,2)/REF(OPEN,2)>1.03 AND REF(OPEN,1)>REF(CLOSE,2) AND (ABS(REF(OPEN,1)-REF(CLOSE,1)))/REF(CLOSE,1)<0.02 AND CLOSE/OPEN<0.97 AND CLOSE<REF(CLOSE,2);
长十字:=CLOSE=OPEN AND HIGH/LOW>1.03;
垂死十字:=CLOSE=OPEN AND CLOSE=LOW AND CLOSE<>HIGH;
早晨十字星:=REF(CLOSE,2)/REF(OPEN,2)<0.95 AND REF(OPEN,1)<REF(CLOSE,2) AND REF(OPEN,1)=REF(CLOSE,1) AND CLOSE/OPEN>1.05 AND CLOSE>REF(CLOSE,2);
黄昏十字星:=REF(CLOSE,2)/REF(OPEN,2)>1.05 AND REF(OPEN,1)>REF(CLOSE,2) AND REF(OPEN,1)=REF(CLOSE,1) AND CLOSE/OPEN<0.95 AND CLOSE<REF(CLOSE,2);
射击之星:=MIN(OPEN,CLOSE)=LOW AND HIGH-LOW>3*(MAX(OPEN,CLOSE)-LOW) AND CLOSE>MA(CLOSE,5);
倒转锤头:=MIN(OPEN,CLOSE)=LOW AND HIGH-LOW>3*(MAX(OPEN,CLOSE)-LOW) AND CLOSE<MA(CLOSE,5);
锤头:=HIGH=MAX(OPEN,CLOSE) AND HIGH-LOW>3*(HIGH-MIN(OPEN,CLOSE)) AND CLOSE<MA(CLOSE,5);
吊颈:=HIGH=MAX(OPEN,CLOSE) AND HIGH-LOW>3*(HIGH-MIN(OPEN,CLOSE)) AND CLOSE>MA(CLOSE,5);
穿头破脚:=REF(CLOSE,1)/REF(OPEN,1)>1.03 AND CLOSE/OPEN<0.96 AND CLOSE<REF(OPEN,1) AND OPEN>REF(CLOSE,1) OR REF(CLOSE,1)/REF(OPEN,1)<0.97 AND CLOSE/OPEN>1.04 AND CLOSE>REF(OPEN,1) AND OPEN<REF(CLOSE,1);
乌云盖顶:=REF(CLOSE,1)/REF(OPEN,1)>1.03 AND CLOSE/OPEN<0.97 AND OPEN>REF(CLOSE,1) AND CLOSE<REF(CLOSE,1);
曙光初现:=REF(CLOSE,1)/REF(OPEN,1)<0.97 AND CLOSE/OPEN>1.03 AND OPEN<REF(CLOSE,1) AND CLOSE>REF(CLOSE,1);
身怀六甲:=(ABS(REF(CLOSE,1)-REF(OPEN,1)))/REF(CLOSE,1)>0.04 AND (ABS(CLOSE-OPEN))/CLOSE<0.005 AND MAX(CLOSE,OPEN)<MAX(REF(CLOSE,1),REF(OPEN,1)) AND MIN(CLOSE,OPEN)>MIN(REF(CLOSE,1),REF(OPEN,1));
十字胎:=(ABS(REF(CLOSE,1)-REF(OPEN,1)))/REF(CLOSE,1)>0.04 AND CLOSE=OPEN AND CLOSE<MAX(REF(CLOSE,1),REF(OPEN,1)) AND CLOSE>MIN(REF(CLOSE,1),REF(OPEN,1));
平顶:=(ABS(HIGH-REF(HIGH,1)))/HIGH<0.001;
平底:=(ABS(LOW-REF(LOW,1)))/LOW<0.001 AND (ABS(REF(LOW,1)-REF(LOW,2)))/REF(LOW,1)<=0.001;
大阳烛:=CLOSE/OPEN>1.05 AND HIGH/LOW<CLOSE/OPEN+0.018;
三个白武士:=REF(CLOSE,2)>REF(OPEN,2) AND REF(CLOSE,1)>REF(OPEN,1) AND CLOSE>OPEN AND REF(CLOSE,1)>REF(CLOSE,2) AND CLOSE>REF(CLOSE,1);
双飞乌鸦:=REF(CLOSE,1)<REF(OPEN,1) AND CLOSE<OPEN AND CLOSE/OPEN<0.98;
孕育线:=REF(CLOSE,2)>REF(OPEN,2) AND (REF(CLOSE,2)-REF(OPEN,2))/REF(OPEN,2)>=2/100 AND REF(OPEN,1)>=REF(CLOSE,1) AND (REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<=2/100 AND REF(OPEN,1)<=REF(CLOSE,2) AND REF(CLOSE,1)>=REF(OPEN,2) AND CLOSE>=OPEN AND (CLOSE-OPEN)/OPEN>=2/100 AND CLOSE>=REF(OPEN,1) AND OPEN<=REF(CLOSE,1) AND (MAX(CLOSE,REF(CLOSE,2))-MIN(CLOSE,REF(CLOSE,2)))/MIN(CLOSE,REF(CLOSE,2))<=1/100;
多方炮:=REF(CLOSE,2)>REF(OPEN,2) AND REF(CLOSE,1)<REF(OPEN,1) AND CLOSE>OPEN;
出水芙蓉:=(OPEN<EMA(CLOSE,20) OR OPEN<EMA(CLOSE,40) OR OPEN<EMA(CLOSE,60)) AND CLOSE>MAX(EMA(CLOSE,20),MAX(EMA(CLOSE,40),EMA(CLOSE,60))) AND VOL/MA(VOL,30)>1.2 AND CLOSE/REF(CLOSE,1)>1.049;
上升三部曲:=REF(CLOSE,4)/REF(OPEN,4)>1.03 AND REF(CLOSE,3)<REF(OPEN,3) AND REF(CLOSE,2)<REF(OPEN,2) AND REF(CLOSE,1)<REF(OPEN,1) AND REF(LOW,4)<REF(LOW,3) AND REF(LOW,4)<REF(LOW,2) AND REF(LOW,4)<REF(LOW,1) AND REF(HIGH,4)>REF(HIGH,3) AND REF(HIGH,4)>REF(HIGH,2) AND REF(HIGH,4)>REF(HIGH,1) AND CLOSE/OPEN>1.03 AND CLOSE>REF(CLOSE,4);
下跌三部曲:=REF(CLOSE,4)/REF(OPEN,4)<0.97 AND REF(CLOSE,3)>REF(OPEN,3) AND REF(CLOSE,2)>REF(OPEN,2) AND REF(CLOSE,1)>REF(OPEN,1) AND REF(LOW,4)<REF(LOW,3) AND REF(LOW,4)<REF(LOW,2) AND REF(LOW,4)<REF(LOW,1) AND REF(HIGH,4)>REF(HIGH,3) AND REF(HIGH,4)>REF(HIGH,2) AND REF(HIGH,4)>REF(HIGH,1) AND CLOSE/OPEN<0.97 AND CLOSE<REF(CLOSE,4);
跳空缺口:=HIGH<REF(LOW,1) OR LOW>REF(HIGH,1);
三只乌鸦:=REF(CLOSE,2)<REF(OPEN,2) AND REF(CLOSE,1)<REF(OPEN,1) AND CLOSE<OPEN AND REF(CLOSE,1)<REF(CLOSE,2) AND CLOSE<REF(CLOSE,1);
光脚阴线:=LOW=CLOSE AND HIGH<>LOW;
光头阳线:=HIGH=CLOSE AND HIGH<>LOW;
分离:=OPEN=REF(OPEN,1) AND (CLOSE-OPEN)*(REF(CLOSE,1)-REF(OPEN,1))<0;
长下影:=(MIN(CLOSE,OPEN)-LOW)/(HIGH-LOW)>0.667;
长上影:=(HIGH-MAX(CLOSE,OPEN))/(HIGH-LOW)>0.667;
十字星:=CLOSE=OPEN AND HIGH<>LOW;
大阴烛:=OPEN/CLOSE>1.05 AND HIGH/LOW<OPEN/CLOSE+0.018;
好友反攻:=REF(CLOSE,1)<REF(OPEN,1) AND CLOSE>OPEN AND (ABS(CLOSE-REF(CLOSE,1)))/CLOSE<0.002 OR REF(CLOSE,1)>REF(OPEN,1) AND CLOSE<OPEN AND (ABS(CLOSE-REF(CLOSE,1)))/CLOSE<0.002;
倾盆大雨:=REF(CLOSE,1)/REF(OPEN,1)>=1.03 AND OPEN<REF(CLOSE,1) AND OPEN>REF(OPEN,1) AND CLOSE<REF(OPEN,1);
EXPLAIN(倾盆大雨,'倾盆大雨,见顶信号;'),colorFFFF00;
EXPLAIN(大阴烛,'大阴烛,后市向淡,发生逆转;'),colorFFFF00;
EXPLAIN(好友反攻,'好友反攻,跌势已尽,要展开一段反弹行情;'),colorFF;
EXPLAIN(跳空缺口,'跳空缺口,突破长期盘整,向上跳空,上涨行情开始;向下跳空,下跌行情开始;'),colorFFFFFF;
EXPLAIN(光脚阴线,'光脚阴线,下跌信号;'),colorFFFF00;
EXPLAIN(光头阳线,'光头阳线,多方积极上攻态势,后市看涨;'),colorFF;
EXPLAIN(三只乌鸦,'三只乌鸦站枝头,可能见顶回落;'),colorFFFF00;
EXPLAIN(分离,'分离,注意看涨分离和看跌分离;'),colorFFFFFF;
EXPLAIN(长下影,'长下影,持续下跌后出现,有可能止跌回升;在升势末期出现,须多加留意;'),colorFF;
EXPLAIN(长上影,'长上影,表明行情上档压力沉重,升势受阻;'),colorFFFF00;
EXPLAIN(下跌三部曲,'下跌三部曲,下跌信号;'),colorFF;
EXPLAIN(上升三部曲,'上升三部曲,上涨信号;'),colorFFFF00;
EXPLAIN(早晨之星,'早晨之星,见底回升;'),colorFF;
EXPLAIN(黄昏之星,'黄昏之星,见顶回落;'),colorFFFF00;
EXPLAIN(十字星,'十字星,重要的警告信号,原趋势停顿或反转;'),colorFFFFFF;
EXPLAIN(长十字,'长十字,重要的警告信号,原趋势停顿或反转;'),colorFFFFFF;
EXPLAIN(垂死十字,'垂死十字,下跌信号;'),colorFFFF00;
EXPLAIN(早晨十字星,'早晨十字星,上涨信号,见底回升;'),colorFF;
EXPLAIN(黄昏十字星,'黄昏十字星,趋势停顿或反转,下跌信号,见顶回落;'),colorFFFF00;
EXPLAIN(射击之星,'射击之星,出现在短期的上升趋势,表明市场顶部就在眼前,可能见顶回落,可靠性低;'),colorFFFF00;
EXPLAIN(倒转锤头,'倒转锤头构成一个看涨信号,可能见底回升;'),colorFF;
EXPLAIN(锤头,'锤头,可能见底回升,如有量配合,信号强烈;'),colorFF;
EXPLAIN(吊颈,'吊颈,上升行情中见顶回落,顶部出现,见顶信号;'),colorFFFF00;
EXPLAIN(平顶,'平顶,意味行情摸高见顶,股价行将反转。但反转下跌力度较小;'),colorFFFF00;
EXPLAIN(穿头破脚,'穿头破脚,顶部出现,见顶回落信号;'),colorFFFF00;
EXPLAIN(乌云盖顶,'乌云盖顶,见顶回落信号;'),colorFFFF00;
EXPLAIN(曙光初现,'曙光初现,行情将演化为V型反转或止跌横盘趋势。后市见底回升;'),colorFF;
EXPLAIN(身怀六甲,'身怀六甲,出现在底部,是见底回升信号;出现在顶部,是见顶回落信号;'),colorFF;
EXPLAIN(十字胎,'十字胎;'),colorFF;
EXPLAIN(平底,'平底,行情探低见底,股价行将反转上升,但力度较小;'),colorFF;
EXPLAIN(大阳烛,'大阳烛,在上升行情中出现,则意味着行情剧烈地向上攀升。在下跌行情中出现,则意味着行情剧烈地向上反弹;'),colorFF;
EXPLAIN(三个白武士,'三个白武士,每日收盘价上移,表示可能见底回升;'),colorFF;
EXPLAIN(双飞乌鸦,'双飞乌鸦,行情开始疲软将见顶回落;'),colorFFFF00;
EXPLAIN(孕育线,'孕育线,注意股价位置;'),colorFFFFFF;
EXPLAIN(多方炮,'多方炮,在底部出现有上涨可能,在中间出现有可能是上涨中继,顶部出现是复合见顶信号;'),colorFF;
EXPLAIN(出水芙蓉,'出水芙蓉,阳线穿过20、40、60日季均线,上攻势头初现;'),colorFF;
EXPLAIN(1=1,' 【资金面分析】'),colorFFFF;
VAR11:=MA(VOL/(HIGH-LOW),4);
VAR33:=ABS(CLOSE-OPEN);
VAR44:=VOL/(HIGH-LOW);
EXPLAIN(VAR44<VAR11 AND VAR33<MA(VAR33,4),'资金无入场意愿,萎缩中;'),colorFF00;
EXPLAIN(VAR44<VAR11 AND VAR33>MA(VAR33,4),'场内资金运作行为;'),colorFFCC66;
EXPLAIN(VAR44>VAR11 AND VAR33<MA(VAR33,4),'多空双方激烈争夺中;'),colorFF00FF;
EXPLAIN(VAR44>VAR11 AND VAR33>MA(VAR33,4),'场外资金介入(或出局)意愿强烈;'),colorFF;
EXPLAINEX(1=1,'该股五日换手%=',SUM(VOL/CAPITAL*100,5),2,0);
EXPLAINEX(1=1,'十日换手%=',SUM(VOL/CAPITAL*100,10),2,0);
EXPLAINEX(1=1,'二十日换手%=',SUM(VOL/CAPITAL*100,20),2,0);
EXPLAINEX(1=1,'百日换手%=',SUM(VOL/CAPITAL*100,100),2,0);
EXPLAINEX(1=1,'获利盘比例=',WINNER(CLOSE)*100,2,0);
EXPLAINEX(1=1,'套牢盘比例=',100-WINNER(CLOSE)*100,2,0);

飞狐筹码空间主图指标公式

 

相关文章