在线检测未来函数

通达信魔鬼K线指标公式

来源:Internet,编辑:股旁网,2011-02-18

N1:=6;
LC:=REF(C,1);
LO:=REF(O,1);
LH:=REF(H,1);
LL:=REF(L,1);
D1:=SMA(MAX(C-LC,0),N1,1)/SMA(ABS(C-LC),N1,1)*100;
D2:=SMA(MAX(O-LO,0),N1,1)/SMA(ABS(O-LO),N1,1)*100;
D3:=SMA(MAX(H-LH,0),N1,1)/SMA(ABS(H-LH),N1,1)*100;
D4:=SMA(MAX(L-LL,0),N1,1)/SMA(ABS(L-LL),N1,1)*100;
STICKLINE(D1>=D2,D1,D2,3,0),COLOR0055AA;
STICKLINE(D1<=D2,D1,D2,3,0),COLOR006600;
STICKLINE(D1>=D2,D1,D2,2,0),COLOR0077CC;
STICKLINE(D1>=D2,D1,D2,1,0),COLOR0099DD;
STICKLINE(D1>=D2,D3,D4,0,0),COLOR00BBFF;
STICKLINE(D1<=D2,D1,D2,2,0),COLOR009900;
STICKLINE(D1<=D2,D1,D2,1,0),COLOR00BB00;
STICKLINE(D1<=D2,D3,D4,0,0),COLOR00EE00;
{股旁网-股票公式网站 www.GupaNg.com}
DRAWICON(CROSS(RSI,25),15,1);
DRAWICON(CROSS(75,RSI),97,2);
DRAWICON(CROSS(80,RSI),97,2);
VAR10:=CROSS(RSI,25) AND EMA(EMA((((2*C+H+L)/4)-LLV(LOW,30))/(HHV(HIGH,30)-LLV(LOW,30))*100,8),5)<55;
低买:IF(VAR10,10,1),COLORYELLOW;
VAR12:=CROSS(EMA((((2*C+H+L)/4)-LLV(LOW,30))/(HHV(HIGH,30)-LLV(LOW,30))*100,8),15) AND EMA(EMA((((2*C+H+L)/4)-LLV(LOW,30))/(HHV(HIGH,30)-LLV(LOW,30))*100,8),5)<55;
追涨:IF(VAR12,50,1),COLORMAGENTA;
抄底:IF(CROSS(D3,EMA((((2*C+H+L)/4)-LLV(LOW,30))/(HHV(HIGH,30)-LLV(LOW,30))*100,8)) AND SMA(MAX(H-LH,0),N1,1)/SMA(ABS(H-LH),N1,1)*100<53,20,1),COLORRED;
逃顶:IF(CROSS(EMA((((2*C+H+L)/4)-LLV(LOW,30))/(HHV(HIGH,30)-LLV(LOW,30))*100,8),78) AND EMA((((2*C+H+L)/4)-LLV(LOW,30))/(HHV(HIGH,30)-LLV(LOW,30))*100,8)>60,70,100),COLORGREEN;

通达信魔鬼K线指标公式

 

相关文章