在线检测未来函数

大智慧KDJ优化版指标公式

来源:Internet,编辑:股旁网,2011-03-02

RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:3*K-2*D;
买:J>REF(J,1) AND K>20 AND REF(J,1)<0,LINETHICK0;
DRAWICON(买,0,7),ALIGN1,LAYER0;
低位金叉:CROSS(K,D) AND REF(K,1)<25,LINETHICK0;
DRAWICON(低位金叉,0,1),ALIGN1,LAYER0;
A2:=BARSLAST(ref(cross(k,d),1));
{股旁网-股票公式网站 www.GupaNg.com}
B2:=ref(c,A2+1)>c and ref(k,A2+1)<k and cross(k,d);
KDJ背离:FILTER(B2>0,5),linethick0,COLORYELLOW;
DRAWTEXT(FILTER(B2>0,5),0.80,'离'),COLORYELLOW;
MA4:=ma(c,30);
准:IF(买 AND MA4>REF(MA4,1),30,0),LINETHICK0;
DRAWTEXT(准,D,'准'),COLOR00FF00;
DOWN:=OPEN>CLOSE;
{去停牌和ST股}
ST:=STRFIND(stkname,'ST',1)>0;
S:=STRFIND(stkname,'S',1)>0;
股价偏离:=(c/ref(c,4)-1)*100<-20 and O/REF(LOW,1)<1.01 and COUNT(DOWN,3)=3 AND not(ST) and not(S);
aa:=HHV(股价偏离 ,5 );
杀跌:if(aa>0 and c>o,100,0),LINETHICK0;
VERTLINE(杀跌,1);
MID:=MA(J,20);
上轨:MID + 2*STD(J,20),COLOR993300;
下轨:MID - 2*STD(J,20),COLOR993300;
中轨:((上轨-下轨)/2)+下轨,COLOR993300;
抄:CROSS(J,下轨) AND J>REF(J,1),LINETHICK0;
DRAWTEXT(抄,下轨,'抄'),COLOR00FF00;

大智慧KDJ优化版指标公式

 

相关文章